Radio con mplayer y archivos .asx

Imagen de letex
0 puntos

 Hola a todos

 Llevo 2 dias investigando cómo reproducir radio de internet en linux, y lo he conseguido, gracias a toda la información que hay, por ejemplo:

http://crysol.inf-cr.uclm.es/node/158#comment-666 

http://www.tabernadelturco.com/2005/09/04/crear-tus-podcast-de-programas-de-radio-automaticamente-en-linux/ 

http://crysol.inf-cr.uclm.es/node/281 

El problema es que todos estas paginas y scripts se basan únicamente en decirle al mplayer:

mplayer [-playlist] http://miradio.asx
mplayer [-playlist] mms://miradio.com:45689

 Muy bien, los mms los escucho sin errores, pero los archivos asx no. he descargado el asx:

wget http://miradio.asx 

 Y buscado el enlace mms dentro y tampoco, por  lo que creo que sea un problema de codecs. Investigando los posibles codecs, debería instalar los w32 codecs, y los tengo....pero no lo oigo.

  TEngo Ubuntu Edgy y las actualizaciones al día.

   Por favor, probad a poner este comando en la consola a ver si no soy yo sólo:

  gmplayer -playlist http://www.los40.com/nuevo_player/40Principales.asx

Si a vosotros os funciona y a mi no.....me tendre que empezar a mosquear.... :-)

espero ayuda, gracias de antemano!! 

 

Imagen de elgatogordo
+1
0
-1

hasta que alguien te diga como solucionar el tema con el mplayer prueba con el vlc o con el kaffeine (los tienes en el synaptic, ambos funcionan con archivos asx

+1
0
-1
Imagen de letex
+1
0
-1

 He probado con el VLC y tampoco....

 Por eso puse el comando a ejecutar con el mplayer, a ver si a ustedes se le oía, siendo así, sería problema de mis codecs.....

   cosa rara, pues tengo instalado el paquete win32-codecs.

 Si puede alguien y tiene el mplayer, ejecutad:

 

mplayer -playlist http://www.los40.com/nuevo_player/40Principales.asx

 Decidme si oís algo, muchas gracias!!

Ubuntu user number # 12793

Linux user number # 444511

+1
0
-1
Imagen de elgatogordo
+1
0
-1

yo tengo los codecs perfectamente instalados, probe con todos los reproductores y no anda

+1
0
-1
Imagen de elgatogordo
+1
0
-1

yo tengo instalada una extensión de firefox que te lista todos los enlaces multimedia de un sitio, entre a esa página hice click en reproducir radio y no me muestra ningun enlace multimedia ni me abre el reproductor automaticamente

+1
0
-1
Imagen de MarianoC
+1
0
-1

Para mi le estas errando a los enlaces. Recien pude escuchar los 40 sin ningun problema. y por las dudas probe varias radios mas y tampoco tuve problemas. Te recomiendo instalarte el paquete "mozilla-mplayer" para poder escuchar y ver todo directamente desde firefox. O sino podes usar alguna extension como MediaPlayer Conectivity que te permite elegir un reproductor para cada tipo de archivo multimedia. Recien probe con los dos metodos y no tuve problemas...salvo con los enlaces que vos pusiste.

 

Saludos! 

+1
0
-1
Imagen de letex
+1
0
-1

Muchas gracias....seguramente se debe a eso!!

Las páginas de las que cogí las referencias parece que eran un "poco" antiguas.

Gracias a todos....un saludo!! 

Ubuntu user number # 12793

Linux user number # 444511

+1
0
-1
Imagen de jermum
+1
0
-1

Amigo... yo tambien tenia el mismo problema y lo solucione con el Rhythmbox. por alla en el menu Musica, le di emisora de radio de internet nueva e ingrese el url de esta, en mi caso http://www.rockemite.com/source.asx y listo emisora sonando. Hay que tener en cuenta que tengo instalado hasta lo que no existe en codecs multimedia....

Me mate la cabeza instalando y desinstalando plugins en el mozilla... hasta me quedo mas loco ese mozilla..... pero bueno... era algo sencillo como saber la url de la emisora he ingrsarla en el Rhythmbox. Cabe recalcar que tambien lo intente con el mplayer pero este no la reprodujo. 

+1
0
-1