instalando librerias

Imagen de Skatman84
0 puntos

Hola, llevo con Ubuntu como 15 dias y necesito instalar un programa, pero al hacer ./configure me aparece que me falta una libreria:

configure: error: The Motif library '-lXm' could not be found.
                Please use the configure options '--with-motif-includes=DIR'
                and '--with-motif-libraries=DIR' to specify the Xm location.
                See the 'config.log' file for further diagnostics.

He descargado un rpm con el Openmotif para Suse 9, y lo he pasado a .deb con alien para instalarlo. Lo he instalado con dpkg, pero al hacer ./configure sigo obteniendo el mismo resultado. Es la primera vez que instalo un programa en linux y todavia ando un poco perdido :S. Gracias por vuestra ayuda

Imagen de Festor
+1
0
-1

Bajate el instalador .deb de este link:

http://sunsite.mff.cuni.cz/MIRRORS/ftp.redhat.com/contrib/openmotif/linux-deb/

Con solo un click ya tendras el Openmotif en tu ordenador.

P.D. Hay otro paquete llamado openmotif-devel, que desconozco. Mi consejo es que si el openmotif_2.1.30-2_i386.deb, te pide dependencias instales el otro paquete antes y luego este.

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1
Imagen de Skatman84
+1
0
-1

Me baje el .deb de esa direccion, pero al instalarlo me dice que ya tengo instalada una version posterior. Desinstale la version que tenia (la que saque del rpm de suse) y al abrir el deb con el GDebi me dice:

Error: Dependency is not satisfiable: xlib6g

 Alguna idea? Gracias

+1
0
-1
Imagen de Festor
+1
0
-1

 Abre el synaptic y busca el paquete  xlib6g e iinstalalo, luego instala el deb

 

**********************

  • Intentando crear el mejor videjuego de la historia para Ubuntu Gnu/Linux

**********************

+1
0
-1
Imagen de Skatman84
+1
0
-1

Abro el synaptic y al buscar xlib6g no m aparece nada :S

+1
0
-1
Imagen de hugolino
+1
0
-1

buscalo acá a ver si aparece http://packages.ubuntu.com/

+1
0
-1