Problemas con kernel 2.6.9 (dev/null: not a directory)

Imagen de tonacka
0 puntos

He configurado y compilado el kernel 2.6.9 de varias formas y he obtenido siempre el mismo error al arrancar con él. Más o menos es este (algunas líneas se repetían):

/etc/init.d/rcS
line 131: /dev/null: Not a directory
The device node /dev/hda1 for the root filesystem is missing listed in /etc/fstab
line 131: /dev/null: Not a directory
The system is also unavailable to create a temp node in etc/init.d/rcS
line 131: /dev/null: Not a directory
/dev/shm to use as a work-around incorrect or there is no entry for the root filesystem
This means you have to fix it manually

He repasado la configuración del kernel y creo que está todo correcto.

Imagen de tonacka
+1
0
-1

Se me escapó antes de tiempo:

¿Alguien sabe dónde podría estar el problema?

GRACIAS de antemano.

"Software is like sex. It's better when it's free" (Linus Torvalds)

+1
0
-1

"Software is like sex. It's better when it's free" (Linus Torvalds)
www.cadenared.org

Imagen de entiak
+1
0
-1

No lo se, pero igual udev tiene algo que ver, mira a ver si lo tienes en /.dev/null

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

Imagen de tonacka
+1
0
-1

GRACIAS por responder.

No tengo ningún /dev/null ¿¿¿???

Ah sí, claro, pero ¿cómo puedo saber lo que hay dentro?

Perdón si es una tontería...

"Software is like sex. It's better when it's free" (Linus Torvalds)

+1
0
-1

"Software is like sex. It's better when it's free" (Linus Torvalds)
www.cadenared.org

Imagen de tonacka
+1
0
-1

Bueno, al final lo solucioné compilando el linux-source-2.6.8.1 (parece que el 2.6.9 no me quería hacer el favor de funcionar...)

Saludos

"Software is like sex. It's better when it's free" (Linus Torvalds)

+1
0
-1

"Software is like sex. It's better when it's free" (Linus Torvalds)
www.cadenared.org