cpu al 100% por culpa de gnome???

Imagen de amra
0 puntos

Tengo problemas con compiz ( eso creo), la historia ahi va:

 

Instale ubuntu feisty 7.04 i386 y todo parecia bien (pura felicidad).

Le instale automatix2, los codecs para ver video le active los efectos de escritorio y guuuaaaaoo, se ve de lujo.

Pero???? ( siempre un pero ), empece a tener problemas con el equipo, de momento deja de responder, no hace nada, solo admite desplazamiento del raton, pasan unos segundos y todo vuelve a funcionar y lo hace seguido.

Empece a fijarme con cuantas aplicaciones me hace esto y ho sorpresa lo hace con todas (nautilus, firefos, totem, gxine y un largo etc) a veces hasta con el escritorio vacio y unicamente activado el monitor del sistema.

Es precisamente con este programa "Monitor de Sistema" y con el "MGM System Monitor", que me di cuenta de que el cpu cuando todo se congela se va al 100% Haciendo que quien sabe, y esto es muy frecuente, entonces empece a consultar el foro buscando un problema similar y encontre de que hay muchos usuarios de ubuntu con este problema de cpu al 100%.

Empece a aplicar algunas recomendaciones para optimizar el desempeño de ubuntu, tales como forzar de que use la ram en lugar del archivo de intercambio(cuando haya ram, claro está) y nada optimice el firefox en su configuracion y el problema sigue, actualice el nucleo generico por la imagen del k7, que segun es para procesadores amd( el cual tengo) y mejoro un poco(pero muy pocooo), en fin que despues de muchos dias decidi probar otro gestor de ventanas ya que en los foros se dice de que el gnome consume muchos recursos y recomiendan en algunos casos usar el 2xfce 4" .

Pues que lo instalo y lo uso y gran sorpresa deja de fallar mi equipo ya no hay más cuelgues momentaneos.

En los programas de monitore del sistema la carga del cpu muy raras veces llega al 100% y esto solo durante un breve pero muy breve instante, normalmente el sistema se mantiene al 50% de carga de la cpu y eso de que para probar abri 4 archivos de 4mb cada uno en openoffice dos texto y dos de calc, el firefox con 6 pestañas activas en la misma ventana, el gxine reproduciendo pelicula que requiere codecs restringidos, el gedit con archivo de texto, una terminal y enviando comandos sencillos como "ls", el visor de fotos "gqview" viendo fotos clar que si y NO SE CUELGA(perdón por las mayuscula es para enfatizar el desempeño).

Entonces empiso a pensar, porque con xfce4 si funciona bien y con gnome falla y mucho, caigo en cuenta de que xfce no tiene activado los efectos de escritorio(compiz) los quiero activar y no encontre como asi que lo dejo así y me regreso a gnome, ya en gnome desactivo los efectos de escritorio y lo uso fuertemente a ver que pasa y aunque los medidores me reportan continuamente cargas de cpu al 100% ya no se bloquea y todo parece funcionar bien.

Conclusión: gnome definitivamente algo hace que usa mucho al cpu y al activar los efectos de escritorio sencillamente todo emperora (hablando de la carga del cpu al 1005).

Pregunto yo; no habrá alguna utileria para limitar a gnome el uso de cpu, yo la busque y lo más que encontre fue el programa cpulimit, ya lo instale Pero Perdon soy muy Pen$%&&%%, pero no logre hacerlo funcionar y su ayuda es muy escueta, en fin si alguien puede ayudar o como puedo hacer llegar este comentario a la gente que desarrolla ubuntu ó gnome pues para que se mejore está situación.

Por su apoyo jovenes, gracias y que esto tambien sirva a los que como yo andan por ahi sufrindo con los cuelges de ubuntu.

Desactiven los efectos de escritorio ó cambien al gestor "xfce4"

Espero sus comentario ó ayuda

Imagen de furtaxi
+1
0
-1

¿De cuanta Ram dispones?

He mirado mis recursos, con la página de ubuntu en firefox (dos pestañas), el transmission bajando 3 torrents, y el programa de red-TV Zatoo, y la CPU oscilaba entre 20 y 30 %, siendo el Gnome-system-monitor un 6-8 % , y unos 30 megas de swap (de 900 megas total, tendré que reducirlo)

Yo tengo un amd 2600+, de 2 Ghz. de velocidad real forzado a 2,2, y 1 Gb de Ram a 400 Mhz, con una Nvidia fx5200 128 Mb. con Ubuntustudio, y no me da ningún problema. Y va como una bala, comparado con el Lado Oscuro...

Saludos,

Roberto.

Mi página: www.vigonews.es.

Windows modo a prueba de fallos: Apagando.... antes del fallo. Shutdown Error in Kernell32, sorry, restart now.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Javier M.
+1
0
-1

Vamos a ver, lo mejor antes de empezar a arreglar cosas, es saber lo que hay que arreglar. Prueba cuando veas que se te sube mucho a abrir una consola y haces un top a ver cual es el proceso que se esta comiendo la cpu. A lo mejor es cualquier otra cosa, no tiene porque ser gnome, o a lo mejor si, pero de momento hazle un top y despues ya miramos.

Abre una consola y escribes simplemente top. Despues nos posteas el resultado.

Un saludo.


 

+1
0
-1
Imagen de amra
+1
0
-1

Javier, he estado observando con el comando TOP en una terminal y el comando que más seguido  se come la cpu es el Xorg tomando valores de  50 a 80 %cpu por debajo del valor de 50 trabaja bien, el otro que también se come al procesador es el compiz.real  aunque menos veces y el valor que toma es de 90 y 100% de cpu cuando se congela la maquina  y como mencione en el comentario inicial lo que hago es esperar a que se libere el uso de cpu, cuando compiz consume la cpu demora más tiempo en liberarse, el xorg se libera más rápido........y ahora  que ya se cual proceso me está llevano al baile que hago.

Gracias por la ayuda, espero más 

amra

+1
0
-1

amra

Imagen de amra
+1
0
-1

Perdon por el descuido de omitir mi hardware, ahi va;

tengo un athlon 64 X2 dual-core 4200+ con cache de 512; 512 mb en ram DDR2 a 667 mhz mca Kingston; video nvidia geforce 6100; placa base ecs elitegroup modelo C51GM-M con chipset C51G/MCP51G; disco duro sata2 de 160 gb mca western.

Espero que sirva de algo, estos datos 

 

amra

+1
0
-1

amra

Imagen de Marcianisto
+1
0
-1

Fácil...... muy fácil......

 Tu procesador es de 64 bits, y te aviso que te has descargado la versión equivocada...

 No se si se podrá usar la edición para 32 bits en un procesador de 64 bits, pero si usas Beryl, Compiz, etc, lo posible es por esto, vuelve a la web ubuntu de los gringos... (www.ubuntu.com) y descargate la versión de 64 bits. (e instalala)

+1
0
-1
Imagen de Martin2222
+1
0
-1

Disculpame que difiera Marcianisto. Pero generalmente haces el camino inverso, instalas el de 64 y despues de cansarte de no tener una infinida de programas, instalas el de 32

Saludos

 

+1
0
-1

 

 

_________________________________________________________

¡Lo que no entra como tornillo, entra como clavo!

_________________________________________________________

Imagen de medu69
+1
0
-1

Yo tengo un 64 bits y corro un Ubuntu de 32 bits sin ningún problema desde tiempos de Hoary...........

+1
0
-1

Visita: <a href="http://www.guia-ubuntu.org/index.php?title=Portada">Guía Ubuntu</a>

Imagen de amra
+1
0
-1

 Disculpa , pero ya lo hice primero instale la i386, despues pense con la amd64 es para mi equipo y que borro i386 e instalo amd64, pero la verdad la senti más lent, entonces volvi a instalar la i386 con el problema que ya comente

 

amra

+1
0
-1

amra

Imagen de furtaxi
+1
0
-1

Booteo concurrente

Booteo concurrente significa que las cosas se carguen en paralelo a la hora de bootear. Aquí la mejora se nota especialmente en los procesadores de núcleo múltiple, ya que éstos pueden separarse la carga entre uno y otro. ¿How to?
$ sudo gedit /etc/init.d/rc
Ahora busca la línea que dice “CONCURRENCY=none”, y cambia “none” por “shell

 

Salió de éste hilo:

http://www.ubuntu-es.org/index.php?q=node/50014

Como es algo frecuente, postear si funciona o no, please.

Saludos,

Roberto.

Mi página: www.vigonews.es.

Windows modo a prueba de fallos: Apagando.... antes del fallo. Shutdown Error in Kernell32, sorry, restart now.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de amra
+1
0
-1

Pues nada, que pongo CONCURRENCY=shell y estube observando con comando TOP y sigue igual Xorg y compiz.real se comen al cpu en diferentes momentos, una vez uno luego el otro y la verdad es una lata a cada rato se congela el sistema 

amra

+1
0
-1

amra

Imagen de amra
+1
0
-1

Bueno parece que este tema como muchos otros unicamente le interesa  al que lo genero, es una pena que no encontremos ayuda en la comunidad....en fin

Les comento que lo arregle parcialmente desinstalado el compiz y con eso ya el gnome llega al 100% de cpu pero un muy breve instante y no ancanza a congelar nada, el equipo funciona relativamente bien sin mayor problema.

Pero las monadas que lo hacen diferente a windows estan out, definitivamente hay quizas que configurar el equipo de forma manual pero eso no interesa al usuario comun que es a donde supuestamente  se esta orientando ubuntu.

Si alguien sabe como se hace la configuración manual que la comparta  lo ideal seria tener un script que hiciera una optimizacion de cada equipo dependiendo de su hardware, no es fácil pero tampoco imposible  todo es cuestión de tiempo. 

 

amra

+1
0
-1

amra

Imagen de Javier M.
+1
0
-1

Hola amra.

Entiendo que estes disgustado por no encontrar solución, pero de ahí a decir esto creo que va mucho:

Bueno parece que este tema como muchos otros unicamente le interesa  al que lo genero, es una pena que no encontremos ayuda en la comunidad....en fin

Si solo te interesara a ti, probablemente no hubieras recibido ninguna respuesta, otra cosa es que nadie sepa como solucionarlo. Al igual que yo te sugeri una idea a ver si nos podia orientar, otros usuarios tambien te han intentado ayudar dentro de sus posibilidades.

Aqui nadie es experto, y cada uno intenta aportar lo que puede, y si nadie sabe la respuesta, toca esperar o buscar por otro lado. Recuerda que esto ni es un servicio técnico ni se da una garantia de solucion a todos los problemas.

Siento de veras que nadie te haya podido solucionar tu problema ( igualmente hay muchos usuarios que siguen sin solucion a sus problemas, incluido yo), pero no creo que sea motivo para hacer una afirmacion de ese tipo, aunque claro esta, estas en tu derecho.

Un saludo.


 

+1
0
-1
Imagen de pimonty
+1
0
-1

Hola amra , en primer lugar no te preocupes me da que somos muchos con el mismo problema y aun estoy rastreando toda la red a ver si alguien puede dar pistas para atacar el problema.

 Bueno en mi caso el que me hace la jodienda es el nautilus, cada vez que quiero navegar por carpetas y correspondientes subcarpetas llega a detenerse ocupando la cpu 100%. Observo el proceso Xorg y suele estar por las nubes  dando picos altos ocupando cpu pero sin bloquearme nada de momento. Otra cosa que noto es latencias en el sistema, siempre dentro de Gnome, por ejemplo si ahora paro de escribir y dejo pulsado el boton de borrar unos segundos tarda, esta leeento, sospecho si puede tener eso algo que ver...

 También he estado examinando los procesos ,, las previews de videos ,sonido y fotos del nautilus, y nada...si encuentro alguna solución al respecto ya lo comentare.

 animo a todo el q pueda dar alguna pista pues heche un cabo ;)

salu2 

 

 

 

1: pi goto 1

+1
0
-1

1: pi goto 1

Imagen de RagonichaFulva
+1
0
-1

Hola a todos,

Googleando (ya que tengo el mismo problema) encontré tres maniobras a elegir para solventar esto con éxito:

  1. Downgrade de Xorg - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=471456
  2. Añadir opción en xorg.conf - http://scripts-net.com/viewtopic.php?f=17&t=64#p81
  3. Cambiar flashplugin-nonfree por la versión de Adobe

Sugeriría adoptar estas medidas en orden inverso para ver si se soluciona el tema.

Un saludo!

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Reclutador sin escrúpulos de doc.ubuntu-es.org ;)

¡Sorteo de foto de los admins de Tux!

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."