conexion con puertos locales

Imagen de yerga
0 puntos

Tengo un problema con la conexion a mis puertos locales desde ubuntu, por ejemplo, si quiero conectarme a cups no me deja, a webmin tampoco, y a cualquier otro puerto de mi maquina me es imposible...

Es algo raro ya que si puedo conectarme a internet sin problemas, a cualquier puerto, y desde otro sitio puedo conectarme a los puertos locales de mi maquina, pero directamente desde aqui no.

No se por donde empezar para solucionarlo, ¿alguna ayuda?

Muchas gracias.

Imagen de czvak
+1
0
-1

Por lo que entiendo de momento, no puedes conectarte desde tu propia maquina a un determinado "puerto". Tambien creo entender que desde fuera (de tu casa) te puedes conectar a tu maquina no?, al servidor ftp de tu maquina por ejemplo?.

Lo unico que te puedo aconsejar ahora es que mires la configuracion de inetd, mira en /etc/services y busca el puerto asociado a cada demonio (cups, webmin...) asi:

cat /etc/services | grep 'webmin'

si todo esta correcto y tiene un puerto asociado en el services, el problema puede ser de hardware, mira el router, los nuevos suelen tener filtros que impiden ciertos tipos de conexiones (ICMP por ejemplo), pero me pareceria uy raro.

Si en el services no encuentras el puerto, es posible que el webmin, por ejemplo, este configurado para arrancar en standalone (no dependiente de inetd-xinetd), para arrancarlo ve a /etc/init.d y busca el demonio correspondiente.

Espero haberte ayudado.

+1
0
-1
Imagen de yerga
+1
0
-1

hola,

realmente no se como explicarlo bien, es que nunca me habia pasado algo parecido.

Desde mi maquina, que no esta conectada a ninguna red local, solo a internet, no consigo conectarme a los puertos propios (a ella misma, vaya), o tan simple como hacer un ping $mi_ip y me responde con: "connect: invalid argument".

Lo raro es que si voy hasta casa de un amigo (con otra ip), e intento conectarme a algun servicio que tengo abierto, como webmin, si me responde y consigue entrar, por lo que supongo que sea un problemas de mi maquina.

A parte no tengo ningun porblema a conectarme a internet, a cualquier servicio, ftp, ssh, webs, etc...

Espero haberme explicado mejor ;)

Saludos y gracias.

P.D.: probe a hacer eso y tampoco responde.

+1
0
-1

Un saludo.
------------------------------------------------------------------------
GNU/Linux user: 372827
Jabber: yerga@jabber.org
M$N: yerga@linuxmail.org

Imagen de entiak
+1
0
-1

1. cuando conectas a tu maquina utilizas tu ip externa? o usas localhost?

2. intenta hacer el ping sin pasarle una variable por parámetro

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

Imagen de Anónimo
+1
0
-1

No consegui dar con el problema, pero tuve que formatear y al reinstalarlo ya va bien, no se por que seria.

Gracias a todos por la ayuda.

Un saludo!

+1
0
-1
Imagen de Lord_ZealoN
+1
0
-1

Si nos comentas que es lo que quieres hacer exactamente, quizás podamos ayudarte mejor.

Un saludo.
--------------------------------------------
Lord_ZealoN - El predicador
Linux User: #370919
Documentación
FAQ: http://www.ubuntu-es.org/book/view/171
How-to's: http://www.ubuntu-es.org/book/view/103

+1
0
-1

---
Lord_ZealoN - El predicador | LU:#370919
Guía: http://guia-ubuntu.org/
FAQ: http://www.ubuntu-es.org/book/view/171
How-TO's http://www.ubuntu-es.org/book/view/103

Imagen de czvak
+1
0
-1

Como dice entiac, que ip usas, si es la externa normalmente no deberia funcionar, para hacer este tipo de pruebas deberias coger la ip privada de tu maquina:

sudo ifconfig eth0

y mira lo que sale. La razon de porque no puedes usar la publica es, a veces, el router o el dispositivo con que te conectes porque estos dispositivos dan dos ips a cada red (la red puede ser de una sola maquina, como en tu caso), una ip privada que corresponde a cada equipo conectado al router del rango 192.168.x.x y una ip publica que sea de esta forma: 81.134.25.13, la ip publica se destina a peticiones desde la maquina a internet o de internet a la maquina, no para operaciones locales.

Lo dicho, usa la ip de la interfaz eth0 asignada a la maquina, no la ip publica.

un saludo

+1
0
-1
Imagen de yerga
+1
0
-1

la verdad es que no tengo ni idea por que pasa y por mas que intento arreglarlo nada.

Nunca me habia pasado esto, otra vez que tuve ubuntu instalado, me dejaba conectarme sin problemas, será algo mal configurado, que no he tocado, pero estará mal configurado.

Yo lo que intento hacer es conectarme a mis puertos locales, por ejemplo, conectarme a cups por el navegador en el puerto 631, o webmin, puerto 10000, intento poner mi ip ( que es fija de telefonica, modem usb), mi nombre de host, o localhost y nada, no consigo hacerlo.

Lo mas raro es eso del ping, que he comentado antes, hago un ping a mi ip y me da ese error, si hago un ping a localhost, me sale una ip que no conozco de nada...

La verdad que no tengo ni idea.
Gracias por leer todo esto.
Un saludo.

+1
0
-1

Un saludo.
------------------------------------------------------------------------
GNU/Linux user: 372827
Jabber: yerga@jabber.org
M$N: yerga@linuxmail.org