Error al iniciarQuake2

Imagen de Hurone
0 puntos

Hola, he instalado Quake2 en mi maquina mediante apt-get , y al intentar ejecutarlo me sale el siguiente error:

------- sound initialization -------
loading oss sound output driver, ok
oss: buffer size is 16384, 8192 samples
sound sampling rate: 11025
------------------------------------
------- Loading ref_softx.so -------
LoadLibrary("ref_softx.so") failed: No such file or directory
Refresh failed
Trying mode 0
------- Loading ref_softx.so -------
LoadLibrary("ref_softx.so") failed: No such file or directory
SNDDMA_Shutdown
recursive shutdown
Error: Couldn't fall back to software refresh!

¿Os suena a alguno de que puede ser?

Un saludo y gracias

Imagen de oscarossa
+1
0
-1

Hola.
Yo tambien instalé el quake2 y el quake2-data, le copié los archivos correspondientes del CD original de Quake II para windows y aún así me aparece el mismo mensaje de error.

Al parecer el problema tiene que ver con las librerías que se cargan para la parte de video, pero no termino de entender qué debo instalar.
En un manual de quakeII para linux decian que habia que instalar las librerías SVGALIB, pero mi maquina ya las tiene.
Ademas, yo uso una tarjeta Nvdia MX-440 con 128 megas con su driver bien instalado, así que no entiendo porque no puede localizr la librería ref_softx.so

+1
0
-1
Imagen de 4bb4d0n
+1
0
-1

Hola, bueno yo ando ahora mismo a vueltas con el tema que nos ocupa. Lo primero, que he hecho es leerme el README (no estoy gritando, viene asi) que viene en el directorio donde instale el ejecutable para linux. Leyendo, leyendo, me entero que hay que crear un archivo llamado /etc/quake2.conf, con permisos de root, que incluya unicamente el directorio donde se localizan las librerias (ref_gl.so ref_glx.so ref_soft.so ref_softx.so). Vale, ahora me dice que las librerias deben tener permisos de root, pos eso voy y cambio el duenho a root. Bueno, otra pega, ahora me dice que no puede cargar "pics/colormap.pcx", creo que es un archivo pak que me falta.

Editado. Bueno he tardado un poquito, pero ya estoy aqui de nuevo. Ya he solucionado el tema del pak, si lo tenia, pero su nombre todo en mayusculas, por eso no lo encontraba el ejecutable, lo renombre a minusculas y ya lo encuentra. Vaya, otra pega ... solo funciona con el render en modo software para x. Bueno a trabajar ...

Salud2.

+1
0
-1
Imagen de 4bb4d0n
+1
0
-1

Pos eso, ya esta corriendo con opengl y sonido, ejecute esta linea:
./quake2 +set vid_ref glx +set gl_driver libGL.so y a funcionar.

Salu2.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola, yo he instalado los paquetes quake2 y quake2-data. Ademas de tener que crear el fichero /etc/quake2.conf con una linea que indica la localizacion de las librerias (en mi caso /usr/lib/games/quake2). He tenido que crear un link simbolico en el directorio /usr/lib/games/quake2 con usuario root con la instruccion "ln -s ref_soft.so ref_softx.so" (sin las comillas).

+1
0
-1
Imagen de majes
+1
0
-1

Me pasa lo mismo, ni idea.

+1
0
-1

--------

Majes, Principiante en linux, pero no por ello no lo amo ;)