[COMO] Instalar wifi usb Conceptronic C54RU

Imagen de Lord_Omega
0 puntos

Tengo un nuevo y flamante Toshiba A200-12X diseñado para trabajar con Windows Vista. A los 5 minutos de ver funcinando el Vista decidí cargármelo, cosa nada fácil ya que Toshiba lo pone algo dificilillo . Bueno, al grano... este bichejo usa el nuevo Intel Wireless WiFi Link 4965AGN y.... claro está, el último kernel no lo reconoce. Probé parchear el kernel tal y como explican en http://ubuntuforums.org/showthread.php?t=493095&highlight=4965 pero sin éxito, como le ha pasado a muchos otros. Como es cuestión de tiempo que aparezca un kernel que lo implemente, me decidí a comprar un wifi por usb, concretamente el Conceptronic C54RU, uno de los más económicos. El problema es que conectado, me lo reconocía... bueno reconocía ¡¡¡¡ dos inalhambricos usb !!! y ni de coña daba señal. Buceando por google y sacando de aquí y de allí, consegui hacelo funcionar. A lo que vamos... pasos a seguir:

Conectado el wifi al usb teclear en cónsola: lsusb
y nos pondrá algo como :

BUS 004 Device 002:ID 14b2:3c22
Esa es la clave, ya que la v2 responde a 3c02.

Primero nos bajamos los drivers http://www.ralinktech.com.tw/drivers/Linux/RT73_Linux_STA_Drv1.0.3.6.tar.gz

 

Los Drivers descomprimidos están en la carpeta rt73-cvs-2007072415, dentro de la subcarpeta Module

Lo primero que hacemos es acceder a la carpeta Module
cd rt73-cvs-2007072415/Module

y tecleamos lo siguiente:
sudo make

sudo make install

sudo cp rt73.ko /lib/modules/2.6...../kernel/drivers/net/wireless

sudo insmod /lib/modules/2.6...../kernel/drivers/net/wireless (esto me dio error)

sudo depmod -a

sudo modprobe rt73

Ahora editamos el archivo aliases
sudo gedit /etc/modprobe.d/aliases

y le añadimos al final la línea
alias rausb0 rt73

Añadimos al panel de gnome el Monitor de Red. Ahora insertamos el dispositivo Wifi en el USB y en el icono del monitor de red seleccionamos wlan0 (si no aparece ponerlo a mano).

Ahora configuramos la red desde Sistema--->Administración--->Red (como dhcp o como ip fija)

Ahora levantamos la red wifi
ifconfig wlan0 up

REINICIAMOS Y COLOCAMOS EL USB Y A FUNCIONAR.

 

Pues nada, si alguien se encuentra en la misma situación que yo... suerte.

Un saludo

Imagen de kelp
+1
0
-1

Por favor, leete las normas del foro. Las mayúsculas equivalen a gritar.

Te edito el título. También te animo a que te leas el post que tienes en este foro sobre como publicar tutoriales.

Un saludo 

 


Equipo de moderadores del Foro
Normas

Mi Blog: Aceitunas sin hueso

 

+1
0
-1

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de Lord_Omega
+1
0
-1

Ok. Ya me había dado cuenta, pero no sabía como editarlo para corregir el fallo.

Lo de las mayúsculas no lo entiendo, creí que había escrito en minúsculas.

 Gracias 

+1
0
-1
Imagen de fernandino
+1
0
-1

No funciona la web para descargar el driver.

+1
0
-1
Imagen de Lord_Omega
+1
0
-1

No pinches en el enlace, seleccionalo con el botón derecho y escoge "guardar enlace como". Esto te bajará el archivo zip.

 

saludos 

+1
0
-1
Imagen de fernandino
+1
0
-1

Compruebalo tú mismo (aunque primero quizá debas borrar tu caché)

En esta web están los nuevos enlaces: http://www.ralinktech.com/ralink/Home/Support/Linux.html

Pero segun Conceptronic hay que usar: http://www.ralinktech.com.tw/data/RT25USB-SRC-V2.0.8.0.tar.gz

Y según tu tutorial, te ha funcionado este: http://www.ralinktech.com.tw/data/RT73_Linux_STA_Drv1.0.4.0.tar.gz

A mi los 2 me dan error... así que... un poco complicado. Si no es mucha molestia podrías subir la version 3.6 a megaupload o probar si la 4.0 te funciona

+1
0
-1
Imagen de Lord_Omega
+1
0
-1

Vaya Fernandino, esto si que es un misterio, jejeje. En serio, cuando pincho con el botón derecho sobre el enlace me permite guardar el fichero y te aseguro que tengo la caché vacía. Siempre que cierro el firefox se me borran la cache, los historiales y las cookies. De todos modos lo he probado en otro pc en el que nunca había entrado (es de una amiga) y sin problemas. No sé lo que te puede pasar. Como no vamos a discutir aquí si tu no puedes y yo sí ;-) te he hecho caso y lo he subido a rapidshare:

http://rapidshare.com/files/47716632/rt73-cvs-2007072415.tar.gz.html

Yo no he utilizado otros drivers por la sencilla razón de que ya no uso el usb wifi puesto que ya he conseguido que mi Wifi Link 4965AGN que incorpora mi portatil funcione. De todos modos, pruebes el que pruebes, si te da error, indicame los pasos que has segudio y el error que te marca ya que de otro modo no se como podría ayudarte.

 

saludos

 

+1
0
-1
Imagen de carlosf-san
+1
0
-1

Otra forma de hacerlo y que funciona perfecto. Por lo menos ami si que lo hizo.

A mi si me reconocía el dispositivo, lo que ocurría es que me daba la mitad de velocidad de conexión
o me costaba un triunfo el conectarme. Reconocía mejor la red del vecino que la mía.
Espero que así si funcione. Mucha suerte.

Desconecta tu wireless usb.

Primero descargas los drivers.

Yo he utilizado el de Misterios...
http://rapidshare.com/files/47716632/rt73-cvs-2007072415.tar.gz.html

- Istala el driver.
Descomprimes busca la carpeta module y te situas con la consola en la carpeta Module.
cd /rutadelpaquete/module
sudo make
sudo make install
(esto a mi siempre me da dolor de cabeza, soy un poco novato)

Ahora editamos el archivo aliases
sudo gedit /etc/modprobe.d/aliases

y le añadimos al final la línea
alias rausb0 rt73

Ahora introduce el adaptador usb en el puerto usb.
En el icono del nm-applet (arriba a la derecha) haces clic y configuración manual, tiene que aparecer conexión inalambrica. Lo seleccionas y pincha
en propiedades.

- Deseleccionas habilitar el modo intinerante
- en nombre de la red, tu nombre de red
- Tipo de contraseña, seleccionas tu tipo, el mio es WPA Personal
Si no lo sabes prueba primero con WPA es la mas comun.
- Selecciona onfiguración automática (DHCP)
- Aceptar

Ahora añade el monitor de red en la barra de herramientas.
clic derecho arriba en la barra , añadir al panel, en sistema y hardware, monitor de red.
Te sitúas en el nuevo icono icono y clikeas en propiedades.
-Donde pone nombre pones wlan0
Ahora comprueba si tienes conexión con el firefox, no te fies de que pone
estado inactivo.
Es posible que tengas que esperar unos segundos.

Ahora donde pone soporte tiene que aparecer tu dirección, Máscara de subred y etc..
Si le das a configurar te envia al nm-applet donde introducimos antes
los datos.

+1
0
-1
Imagen de golmate
+1
0
-1

Saludos, 

 He estado intentando configurar el wifi usb con los pasos que habéis seguido, pero sigo sin poder salir a la red.

Desde un principio ya me reconoce el c54ru sin problemas. Lo he probado antes de buscar este hilo pero no se conectaba. Después de instalar los drivers del enlace y configurarlo por manual, la cosa seguía igual.

Me aparece la conexión con un 0% de señal, mientras que al detectar la red está a casi el máximo (tengo el router a 3m). Por supuesto a la hora de probar el firefox no consigo cargar nada. ¿Alguna idea de lo que puede fallar?

Por si sirve de ayuda,el wifi usb lo uso en un sobremesa con ubuntu 7.04.

+1
0
-1