Kernel 2.6.11-1 no carga.

Buenas chic@s, mi problema es que tengo ubuntu hoary con el kernel que trae por defecto el 2.6.10-5-386 y me va todo bastante bien pero ahora al instalar el linux-image que hay en synaptic el 2.6.11-1 me lo instala bien sin problemas pero a la hora de arrancar el sistema una vez que arranca todo y sale la pantall esta de ubuntu Linux for human beings que ya solo falta entrar en gnome se me keda todo parado como si se bloquease algo y no se de que puede ser, si alguien tiene alguna idea y me puede ayudar se lo agradezco. Otra pregunta es si se puede ya que no lo se, soy novato en esto, si la configuracion que trae el kernel por defecto 2.6.10-5-386 se puede ver o copiar, para yo bajar el ultimo kernel que hay en www.kernel.org y cargarla ahi sin necesidad de tener que configurar yo nada, sino que ya utilizo lo que halla ahi. Y otra ultima pregunta es si no se puede hacer esto ultimo y kiero compilar un kernel yo para poder usar vmware que opciones habria que marcar para que funcione. Pues bien esto es todo mucha gracias por todo y espero que mis preguntas puedan tener facil respuesta. Un saludo bye.

Imagen de Gael
+1
0
-1

Lo que falla es el sistema grafico: xorg
Intenta pasar al modo consola (Ctrl+Alt+F1) y haces login.
Nos copias aqui el contenido de

cat /var/log/Xorg.0.log | grep '(EE)'

Dado que no tienes entorno grafico te sera de ayuda añadir un "> error.txt", es decir:

cat /var/log/Xorg.0.log | grep '(EE)' > error.txt

Lo que generara el archivo "error.txt" que contine los errores de xorg con tu kernel. Arrancas con el kernel bueno y nos lo pones.

Si no es de eso (error.txt esta vacio) mira el /var/log/syslog y nos pones las lineas que tu consideres curiosas ;-)

Lo del archivo de configuracion... pues bueno en /boot/config-2.6.10-5-386 tienes el archivo de configuracion. Lo tienes que copiar como .config en la carpeta de los nuevos fuentes, pero no te recomiendo que uses el de www.kernel.org porque no soporta cramfs, muy probablemente no vaya con tu aceleradora 3D. Ati solo soporta hasta el 2.6.11 y Nvidia dicen que va con los 2.6.12 pero a mi no me tira mas que con los 2.6.11, depende del modelo de la grafica.

Sin el cramfs vas a flipar para que el kernel arranque, ya que es necesario para la opcion --initrd, y si vas a parchear para meter el cramfs, de paso pones un "kit" de parches como los de Koliva, que lo incluyen, y el kernel te va a tirar como un avion. Si te mola el riesgo:
http://www.ubuntu-es.org/node/5363#comment-12326

Del vmware ni idea.

+1
0
-1
Imagen de versvs
+1
0
-1

Tengo el mismo problema que el Anónimo: Se cuelga al arrancar las X, voy a probar esa solución y si tengo problemas ya daré señales de vida... :P

De momento he copiado la config del kernel viejo (2.6.10) a ver si así fuera suficiente... Voy a reiniciar y eso a ver qué puede ser, si fuera necesario ya probaría a sacar un log de errores de xorg :(

Es mucho preguntar dónde se almacena el archivo que estoy creando con los errores? ;)

Saludos!

--
"never is a promise, and i'll never need a lie"

JID: versvs@jabberes.org

+1
0
-1
Imagen de Gael
+1
0
-1

Pues en la carpeta en la que estés. Si hiciste login como root en /root y si lo hiciste como "user" en /home/user.

No es bueno adelantarse, pero me huelo que será de los drivers de la gráfica ('Failed to load NVIDIA GLX' o algo así).Si es así, "apt-get remove nvidia-glx nvidia-kernel" y a instalar los de www.nvidia.com.

+1
0
-1
Imagen de versvs
+1
0
-1

Hola de nuevo, Gael,

Verás, he probado algunas cosas:

- Probé a sacar el log de errores al cargar y la única línea que me ha guardado es una leyenda (WW, warning, EE, error, etc..). Asi que supongo que no hay error en eso.

- He probado a iniciar con un entorno que no fuera gnome, como tengo instalado E17, en el GDM he seleccionado ese entorno y ha iniciado bien, pero al iniciar aMSN se me bloquea! por dos veces! ¿será porque funciona con las librerías de gnome? No tengo ni idea, lo único que sé es que luego al iniciar con el Kernel 2.6.10 para conseguir que aMSN me funcione he tenido que quitarlo (--purge) y volverlo a poner...

Así que bueno, he probado eso, no sé si será de la NV pero creo que no pq E17 carga bien...

Gracias por la ayuda en cualquier caso :)

Hasta luego
--
"never is a promise, and i'll never need a lie"

JID: versvs@jabberes.org

+1
0
-1
Imagen de Gael
+1
0
-1

Vaya, no era bueno adelantarse :-P. Si arrancabas amsn desde un terminal ¿no te daba algún mensaje concreto de error? Es que si es "del gnome" es un errorcillo un poco gordo para empezar a cojerlo por algún lado... Además, si reinstalando amsn funciona, gnome no es, supongo...
Si lo has arreglado ponlo aquí... ¡para cuando me pase a mi!

+1
0
-1
Imagen de versvs
+1
0
-1

Gael, disculpa que no pusiera respuesta, no conseguí hacer rular el kernel 2.6.11, entre otras cosas porque no tuve más tiempo para probar cosas. Ahora mismo vengo de reparar Hoary y la tengo limpita asi que creo que me dejaré de experimentos por unos días :P

Gracias de todos modos y ya volveré a la carga cuando tenga algo d tiempo ;)

Saludoshhh
--
"never is a promise, and i'll never need a lie"

JID: versvs@jabberes.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Tengo el mismo problema que el de arriba. Hice lo que dijiste y esto es lo que aparece del Xorg.0.log:
"(EE) RADEON (0): [dri] DRIScreenInit failed. Disabling DRI"

Tengo la ATI RADEON X600.

¿Alguna idea?

Gracias.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Vi en este mismo foro que cambiando en /etc/X11/Xorg.conf, donde pone Driver "ati", pones "vesa". Con eso me funciona a mí.

Suerte.

Ahora queda que funcione el sonido, internet.........

+1
0
-1
Imagen de Anónimo
+1
0
-1

Ubuntu me está decepcionando en este tema. Dos versiones seguidas del kernel me han llevado a "kernel panic" o me han dejado el sistema sin sonido, sin imagen o con cuelgues continuos.

No sé qué está pasando con las versiones de las dos últimas semanas pero leyendo este foro y por experiencia personal no lo están haciendo nada bien.

Las versiones son las mismas que se mencionan en el mensaje inicial.

+1
0
-1
Imagen de gabiel
+1
0
-1

Pues no es por nada pero las versiones que mencionan en el mensaje inicial tienen más de dos semanas (el mensaje es de junio) y de haber tenido problemas grabes ya estarían solucionados.

Además fijate en los problemas que mencionas, son demasiado dispares, ¿has comprobado que el hardware no está averiado? (módulos de RAM, CPU, placa base)

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

La verdad es que reinstalando solucioné todos los problemas y al actualizar vuelta a lo mismo. Realmente no sé si es problema del kernel o de libc6, que hasta hace poco no se me había marcado para actulizar.

fdisk y memtest no me detectan problemas, si bien no conozco demasiado bien herramientas de comprobación de disco en Linux como para hacer examen a fondo.

+1
0
-1