problema con las librerias

Imagen de felipe512
0 puntos

tengo la libreria libc6 en su version mas reciente pero me dice que no la tengo al instalar un .deb

lo e checado instalando sudo apt-get install libc6 y medice que tengo la version mas reciente

que es lo que esta fallando?

saludos.

Imagen de patagonian18
+1
0
-1

Creo haber leído aquí en el foro el otro día, que cuando el sistema pide una librería para compilar algo se refiere a aquella que tenga la extensión -dev. En este caso libc6-dev.

Probablemente sea eso. 

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de felipe512
+1
0
-1

en tonces lo que hago es hacer sudo apt-get install libc6-dev??

 

+1
0
-1
Imagen de patagonian18
+1
0
-1

Que conste que no te está respondiendo el más experto, pero yo diría que sí. Es más, acabo de buscar la librería en Synaptics y efectivamente la librería libc6-dev sí está. Yo te recomendaría que abrieras Synaptic y una ves allí buscaras libc6. Debería aparecerte libc6-dev. La seleccionas y la instalas.

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de MarianoC
+1
0
-1

Que programa queres instalar?? y cual es exactamente el error que te da?? Y ademas, que version de ubuntu usas??

Saludos!

+1
0
-1
Imagen de felipe512
+1
0
-1

ubuntu 7.4 feisty

quiero instalar un plugin de exaile que es como el coverflow de itunes

es python-daap.deb

+1
0
-1
Imagen de MarianoC
+1
0
-1

los paquetes -dev son librerias de desarrollo, necesarias solamente si se quiere compilar un programa, asi que para este caso no tienen nada que ver..

De donde sacaste el deb?? Cual es el error exacto que te aparece al tratar de instalar el paquete??

Proba escribir en una terminal:
$ dpkg --info paquete.deb

Ahi te tiene que decir exactamente cuales son las dependencias y que versiones de las mismas....Por lo que vi ese paquete no esta en los repositorios de ubuntu, asi que puede ser un tema de versiones...

Saludos!!

+1
0
-1
Imagen de felipe512
+1
0
-1

lo saque de aqui http://packages.ubuntu.com/gutsy/source/python-daap

y el error es: Error: dependency  is not satisfiable: libc6

+1
0
-1
Imagen de MarianoC
+1
0
-1

Ahi esta el problema, en gusty la version de libc6 que viene es la 2.6.1-1 y el paquete que queres instalar necesita una version mayora a 2.5-5, cuando en feisty viene la 2.5-0...ahi esta el problema...y la verdad no te recomiendo para nada instalar esa version de libc6 porque se te va a armar un despelote impresionante de dependecias...
Te recomiendo usar el paquete que trae debian testing, que tiene como dependencias versiones mas antiguas, y que por lo tanto las tenes en feisty. El paquete lo podes bajar de aca: http://http.us.debian.org/debian/pool/main/p/python-daap/python-daap_0.4...
y probar si funciona..

Saludos!

+1
0
-1
Imagen de felipe512
+1
0
-1

ahora cuando instalo el paquete que me enviaste me aparece

Error: Dependency is not satisfiable: python

 

+1
0
-1
Imagen de MarianoC
+1
0
-1

Estas al horno, lo unico que te queda para que funcione con tus librerias es compilar...La dependencia para python es que este entre la version 2.4 y la 5.5 y feisty usa 5.5.1, asi que te pasas...

O esperas a que salga gusty o te pasas a debian o compilas la libreria...

Saludos!!

PD: Buscando la pagina para de donde sacar el codigo para compilarlo, vi que habia un paquete alojado en los repositorios de tuxfamily para feisty, asi que el deb lo podes sacar de aca: http://download.tuxfamily.org/syzygy42/pool/feisty/reacocard/python-daap...

Deberia andar bien, probalo y comenta como te fue.

Saludos!!

+1
0
-1
Imagen de felipe512
+1
0
-1

ya lo he instalado y todo pero me sigue marcando el mismo error

de exaile al habilitar el plugin

ya ni modos esperare a gusty

saludos y gracias por contestar y ayudar

saludos!! 

 

+1
0
-1
Imagen de MarianoC
+1
0
-1

uhh, que lastima, pense que podia funcionar. Debe ser algun problema con la version de la libreria que instalaste y la que usa exaile...Como se llama el plugin?? Asi lo pruebo en mi exaile, jajaja.

Saludos!!

+1
0
-1
Imagen de felipe512
+1
0
-1

se llama music sharing

lo trae exaile en sus plugins

creo que es para lo de coverflow

 

+1
0
-1
Imagen de MarianoC
+1
0
-1

Lo active en arch, pero no tengo ni idea para que sirve, ni muchos que es coverflow.... jajajaja...

Espera un poco que ya aparece gusty, o sino cambiate de ditro y listo, jaja...

Saludos!

+1
0
-1
Imagen de felipe512
+1
0
-1

estoy pensando en mandriva con ubuntu jeje

gracias por responder

saludos! 

+1
0
-1
Imagen de nachotronik
+1
0
-1

Buscando alguna solución a mi problema me tope con este post, quizá ya pasadito en tiempo pero me gustaría saber si alguien ya tiene alguna solución al problema.

Os cuento como va mi problema.

Quiero instalar un pluing "coverflow" para exaile.
He entrado a algunos sitios y entré a la página del autor y me he descargado los ficheros, lo metí en un directorio al que nombre "coverflow" y lo he metido en el directorio "plugins" de Exaile como root (usr/share/exiale/plugins)

Abri exiale y en la lista de los plugins ya aparece pero al quere activarlo me sale una alerta diciendo "cannot import name track".

He instalado la dependencia Phyton-clutter que se supone es con la que trabaja y nada...

Espero alguien pueda ayudarme, Exaile merece mucho la pena y con un coverflow o algún plugin que muestre los covers sería mejor.

+1
0
-1

DarkPriest
Yo no escogí, yo nací y eso es lo que soy