Problemas con Synaptic

Imagen de Sergio44
0 puntos

Hola pues este es mi primer mensaje y me ha ayudado muchisimo esta comunidad. Pues llevo dos dias con problemas con synaptic no lo puedo abrir. Cuando lo inteto abrir me aparece el siguiente mensaje:

Ha ocurrido un error

Se proporcionan los siguientes detalles:

E: Tipo 'non-free' desconocido en la línea 59 de lista de fuentes /etc/apt/sources.list
E: No se pudo leer la lista de fuentes.
Vaya al diálogo del repositorio para corregir el problema.
E: _cache->open() failed, please report.

y en el cuadrito anaranjado que aparece cuando hay alguna actualizacion de software dice:

Se produjo un error. Por favor, ejecute el gestor de paquetes desde el menu contextual (boton derecho del raton), o use apt-get en una terminal para ver que esta fallando. El mensaje de error fue: Error: Opening the cache (E:Type 'non-free' is not known on line 63 in source list /etc/apt/sources.list, E: The list of sources could not be read.)

Ayudenme por que soy totalmente nuevo en ubuntu y pues no quiero reinstalarlo ni nada. Pues si se puede hacer de algun modo que no sea la terminal mejor por que no la se usar mucho pero si no igual intentare. Gracias de antemano.

Imagen de orionce
+1
0
-1

Hola Sergio44.

¿Has agregado algun repositorio al resources.list en los ultimos dos dias? 

si lo has hecho es probable que no lo hayas hecho bien.

y ni modo, te toca terminal.

copia y pega esto en la terminal

sudo gedit /etc/apt/sources.list
Esta te abrira el archivo de los repositorios

te va a pedir tu contraseña, aunque no veas los asteriscos se escribe.

y dime que hay e la linea 59 y 63.

Si has agregado un repositorio hace poco prueba borrándolo y me cuentas. 

+1
0
-1
Imagen de josmen
+1
0
-1

Viejo muchas gracias por la ayuda, fue genial ustedes si que conocen, a Ubuntu, problema resuelto en esto gracias

+1
0
-1

josmen

Imagen de Sergio44
+1
0
-1

# PLF - Collection of Non-Free Proprietary Codecs & Applications
deb ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ dapper free
non-free
deb-src ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ dapper free non-free

# WINE - Windows API for Linux
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main

non-free linea 59

deb http://wine.budgetdedicated.com/apt dapper main linea 63

Pues que recuerde no he instalado casi nada por que me toco reinstalar ubuntu solo he instalado listen y pues de ahi no mas ni me dio tiempo de instalar automatix. Gracias por tu respuesta tan pronta. 

+1
0
-1
Imagen de orionce
+1
0
-1

Sergio44

Me imagino que tienes Ubuntu Dapper, porque yo no tengo esos repositorios en mi resources.list.

Si abres la direccion del primer repositorio en el navegador web te daras cuenta que tira error al buscar el directorio.

Has la siguiente prueba:

al principio de cada uno de los repositorios, pon este signo "#" sin las comillas para el sinaptyc no te los tome en cuenta como repositorio.

guarda el resources.list o si quieres borralos, pero antes copialos en un archivo de texto por si las moscas. 

habre el sinaptyc y y clikea el boton RECARGAR y me cuentas 

+1
0
-1
Imagen de Sergio44
+1
0
-1

Pues tenia el dapper pero me pase al 7.04 asi que voy a intentar eso de # y te cuento ya que no ando como root y no lo puedo modificar pero gracias por la intencion

 

+1
0
-1
Imagen de orionce
+1
0
-1

Con: 

sudo gedit /etc/apt/sources.list   tendras permisos para borrar los repos.

Probe tus repositorios en mi resources.list y me dio el mismo problema, la solucino esta en que borres las siguentes líneas:

# PLF - Collection of Non-Free Proprietary Codecs & Applications
deb ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ dapper free
non-free
deb-src ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ dapper free non-free

y

non-free linea 59

 

Con eso creo que el problema se soluciona

+1
0
-1
Imagen de Sergio44
+1
0
-1

Gracias ese era el problema gracias por responderme tan rapido ya estoy con el synaptic. Gracias por responder tan rapido.

+1
0
-1
Imagen de Sergio44
+1
0
-1

Pues ahora que ya tenia solucionado este problema al encender la otra computadora me tira otro error esta vez era distinto y la sources list era distinta. Total me tiro otro error no se por que talvez es por que estan conectadas en red o el destino... jeje bueno aqui va mi nuevo error.

E: Dynamic MMap ran out of room
E: Ocurrió un error mientras se procesaba libpng12-dev (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_dapper-security_main_binary-i386_Packages
E: Las listas de paquetes o el archivo de estado no se pueden analizar sintácticamente o abrir.
E: _cache->open() failed, please report.

y mi sources list :

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://archive.ubuntu.com/ubuntu/ feisty main restricted
deb-src http://archive.ubuntu.com/ubuntu/ feisty restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ feisty-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu/ feisty-updates main restricted #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu/ feisty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu/ feisty multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://gt.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
# deb-src http://gt.archive.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ feisty-security main restricted
deb-src http://archive.ubuntu.com/ubuntu/ feisty-security restricted main multiverse universe #Added by software-properties
deb http://archive.ubuntu.com/ubuntu/ feisty-security universe
deb http://archive.ubuntu.com/ubuntu/ feisty-security multiverse
deb http://us.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ dapper main restricted

# Ubuntu 'Universe' Repository
deb http://archive.ubuntu.com/ubuntu/ dapper universe main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ dapper universe main restricted multiverse

# Ubuntu 'Backports' Repository
deb http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

# Ubuntu Security Updates
deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe

# WINE - Windows API for Linux
deb http://wine.budgetdedicated.com/apt dapper main
deb-src http://wine.budgetdedicated.com/apt dapper main

# Skype - VoIP Software

deb http://download.skype.com/linux/repos/debian/ stable non-free

# Opera - Web Browser
deb http://archive.ubuntu.com/ubuntu/ feisty-proposed restricted main multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ feisty-proposed restricted main multiverse universe
deb http://archive.ubuntu.com/ubuntu/ feisty-backports restricted main multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ feisty-backports restricted main multiverse universe
deb http://deb.opera.com/opera/ etch non-free

 

Espero me ayuden y ya se que han de estar hartos de tanto problem con el synaptic pero soy un novato.

Por cierto actualize los repositorios y despues ya no pude entrar. 

+1
0
-1
Imagen de orionce
+1
0
-1

Amigo para ayudarnos estamos.

Otra cosita, recargue los repos desde agregar y quitar.. y parece que los repos del wine tambien te pueden dar problemas aunque te funcione bien el sinaptyc asi que puedes quitarlos.

Saludos y que viva linux 

+1
0
-1
Imagen de Sergio44
+1
0
-1

Pues gracias pero el synaptic no lo puedo abrir solo me tira ese error y se cierra. Si me funciona pero en la otra computadora. En esta me acabo de dar cuenta. Otra cosa, quite los repos del wine pero siguio el mismo error.

+1
0
-1
Imagen de orionce
+1
0
-1

Amigo quisiera que me respondieras lo siguiente

¿Tienes Ubuntu Drapper o Feisty?

Si cambiaste de Drapper a Feisty, ¿Lo hiciste con instalación limpia o actualizaste via Internet? 

Es que en tu lista de repos noto que tienes tanto repos para drapper como para feisty, yo tengo feisty y no tengo ningun repo para drapper, alli podria estar el problema.

Yo tenía Ubuntu 6.10 a actualicé al 7.04 por internet y averié el sistema. si hiciste eso mejor te recomiendo que hagas una instalación limpia al 7.04 con el live cd, si lo tienes por supuesto, sino lo tienes lo puedes descargar aqui

http://www.ubuntu.com/getubuntu/download 

Que la suerte te acompañe. 

+1
0
-1
Imagen de Sergio44
+1
0
-1

Pues tengo el feisty y lo actualize con el live cd.

+1
0
-1
Imagen de orionce
+1
0
-1

Pero hiciste instalacion limpia oactualizaste?

si actualizaste cual tenias antes? 

+1
0
-1
Imagen de Sergio44
+1
0
-1

Pues en hice la instalacion limpia. No actualize por que no sabia como asi que instale ubuntu desde 0 y tenia la dapper.

+1
0
-1
Imagen de orionce
+1
0
-1

Te recuerdas si al instalar le pusiste el chequesito a la opcion para volver a formatear la particon?

es probable que te haya instalado sobre la inatalación del drapper, y por eso te salgan los repositorios del draper.

Como te digo, yo tengo feisty esos repositorios no me salen. 

puedes hacer lo siguiente, aunque es arriesgado pero como ya estas emproblemado no creo que pueda ser peor.

 

1. Has una copia de tu sources.list.

2. borra todos los repos que tengan la palabra drapper del sources.list original y prueba.

luego me cuentas. 

+1
0
-1
Imagen de Sergio44
+1
0
-1

Gracias no se como le haces pero funciono a la perfeccion me arranco a la primera como si acabara de instalar el S.O. Gracias por tomarte el tiempo.

+1
0
-1
Imagen de orionce
+1
0
-1

De nada amigo,

Veras que no tardaras en aprender mas si eres curioso y te gustan los foros, la verdad te diré que adivinando es como acabamos de solucionar tu problema, igual a ti yo tambien so algo nuevo pero los foros me han ayudado como no tienes idea, espero que cuando sepas un poquito mas o las experiencias te hagan experto pongas un granito de arena para ayudar a los demas de los foros que se han encontrado con problemas como nosotros.

y otra ves, viva linux 

+1
0
-1
Imagen de alixe
+1
0
-1

 

E: Tipo '“' desconocido en la línea 1 de lista de fuentes /etc/apt/sources.list
E: No se pudo leer la lista de fuentes.
Vaya al diálogo del repositorio para corregir el problema.

E: _cache->open() failed, please report

 

Me dice esto cuando intento abrir el synaptic

abri el source list en la terminal borre todos los repositorios y aun asi me sigue dando problemas. Y encima ya no tengo repositorios.

me podría ayudar alguien?

Y estoy haciendo todo estoy por que intente instalar los drivers de una ati radeon 9600 pero es incompatible con el composite del beryl o eso he leido por ahi asi que estaba intentando seguir unas instrucciones para instalar el beryl con la tarjeta gráfica ati pero es todo un poco locura, aunque no me arrepiento de haberle dado muerte a microsoft y aprendo así o muero en el intento.

 

Otra en el terminal me dice esto:

E: Tipo '“' desconocido en la línea 1 de lista de fuentes /etc/apt/sources.list
 

Muchas gracias

+1
0
-1
Imagen de orionce
+1
0
-1

Que hiciste que?

Borraste todos los repositorios?

Asi ninca te cargará el synaptic.

Rebisa en sistema de archivos/etc/apt. tendría que haber una copia o bachup del sources.list original.

Recuerda que para hacer los cambios lo tienes que hacer como root.

por en la consola

$ sudo nautilus

y busca la dirección, renombra el backup a resources.list, te dira que sobreescribirá el original, dale que si. 

si no está lo único que se me ocurre es que inicies con el Live cd y que saques una copia del sources.list y que lo agregues al original.

es probable que te haya fallado por alguna mala manipulación de los repositorios.

para instalar beryl busca manuales en google porque hay bastantes, yincluso creo que en esta web.

+1
0
-1
Imagen de furtaxi
+1
0
-1

http://www.ubuntulinux.nl/source-o-matic

Os genera un sources limpio. Editáis el vuestro, borrais TODO, y pegáis el que os genera la Web. Guardar. Luego,

sudo apt-get update. 

 

Saludos,

Roberto.

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar. Sé amable, tolerante y comprensivo. Disfruta. Sonríe. Ubuntu es más que un S.O.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de jhefry20
+1
0
-1

 este es mi error:

E: Tipo '--22:20:21--' desconocido en la línea 1 de lista de fuentes /etc/apt/sources.list.d/mediabuntu.list
E: No se pudo leer la lista de fuentes.
Vaya al diálogo del repositorio para corregir el problema.
E: _cache->open() failed, please report.

 

lo abri tambien por el terminal y es este:

 #
# deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016.1)]/ gutsy main restricted

deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016.1)]/ gutsy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://es.archive.ubuntu.com/ubuntu/ gutsy main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://es.archive.ubuntu.com/ubuntu/ gutsy universe
deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy universe
deb http://es.archive.ubuntu.com/ubuntu/ gutsy-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb http://es.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu gutsy partner
# deb-src http://archive.canonical.com/ubuntu gutsy partner

deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse

 

----------------------------------------------------------------------------------------------------------------

bueno espero que me puedan ayudar soy nuevo este sistema operativo 

 

+1
0
-1
Imagen de furtaxi
+1
0
-1

 Si te fijas, te pone:

/etc/apt/sources.list.d/mediabuntu.list

O sea, que estás abriendo  sources.list.d y no el correcto:

sudo gedit /etc/apt/sources.list

Y no es mediaubuntu, sino medibuntu , sobra la "a".

Probablemente, alguna copia de seguridad. 

Saludos,

Roberto.

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar. Si tienes éxito con un problema, edita el título y ponle (solucionado).

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de josmen
+1
0
-1

 lo que hice fue es copiar todo lo que tú colostes alli, donde se abrio las listas, y listo problema resuelto, como se dice por aca venezuela "Perro a cagar". 

josmen

+1
0
-1

josmen

Imagen de weirdo07
+1
-1
-1

no me deja ni añadir aplicaciones ni actualizar me aparece ese problema

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: Las listas de paquetes o el archivo de estado no se pueden analizar sint\u00e1cticamente o abrir.
E: _cache->open() failed, please report.

porfavor si me pueden ayudar se los agradeceria mucho

+1
-1
-1
Imagen de weirdo07
+1
-1
-1

tengo un problema con synaptic no puedo actualizar ni añadir programas si al guien me ayuda me aparece el sig. error

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E: Las listas de paquetes o el archivo de estado no se pueden analizar sint\u00e1cticamente o abrir.
E: _cache->open() failed, please report.

+1
-1
-1
Imagen de aiki
+1
-1
-1

feliz navidad y un buen proximo ano

nivel novTO a intermedio

cuando abro synaptic me da el error:

E: Dynamic MMap corrió fuera de la sala. Incremente el tamaño de APT::Cache-Limit. Valor actual: 15000000. (man 5 apt.conf)
E: Ocurrió un error mientras se procesaba tuxtype-data (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid-updates_universe_binary-i386_Packages
E: Las listas de paquetes o el archivo de estado no se pueden analizar sintácticamente o ns.
E: _cache->open() failed, please report.

W: Unable to munmap

he tratado de reparar paquetes rotos en la forma segura y sigue el mismo mensaje
trate de reinstalar synaptic y sale otro error, editar el sudo gedit /etc/apt /sources.list pero no se que reparar
gracias por su ayuda y de nuevo feliz navidad

+1
-1
-1
Imagen de urdaa
+1
-1
-1

soy nuevo en este sistema operativo .. me aparece esto
E: Tipo «ain» desconocido en la línea 1 de lista de fuentes /etc/apt/sources.list.d/ubuntu-wine-ppa-maya.list
E: No se pudo leer la lista de fuentes.
Vaya al diálogo del repositorio para corregir el problema.
E: _cache->open() failed, please report.
me dicen como solucionarlo?

+1
-1
-1

soy nuevo utilizando linux mint