Xampp no funciona

Imagen de umbral
0 puntos

Hola tengo un problema con xampp y es que directamente no funciona. He instalado distintas versiones en mi Ubuntu Gutsy y nada me dice esto, tanto como root o como usuario normal:

luis@luis:/opt/lampp$ sudo lampp start
sudo: lampp: command not found
luis@luis:/opt/lampp$ lampp start
bash: lampp: orden no encontrada

He ido al directorio directamente e intento ejecutarlo desde allí y tampoco y no sé cual puede ser el motivo. A ver si alguien puede ayudarme con esto.

Gracias y un saludo.

Imagen de harold9007
+1
0
-1

root@pccasa2007:/# opt/lampp/lampp start
Starting XAMPP for Linux 1.6.4...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
XAMPP: XAMPP-MySQL is already running.
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

Por mi parte solo logro levantar el MySQL y el ProFTPD... ademas tengo problemas en levantar el Servidor Web Apache.

Colmenares

+1
0
-1

colmenares

Imagen de Valc
+1
0
-1

Hola harold9007, :)

Parece como si tuvieras habilitado permanetemente el arrancar con SSL y a lo mejor es eso lo que te está ocasionando problemas.

para deshabilitar SSL, desde la consola:

sudo /opt/lampp/lampp stopssl

Luego pruebas de arrancar o reiniciar XAMPP y se te debería cargar sin la opción SSL. Si desaparece el error, el problema está por ahi.

Por otra parte, si usas el SKYPE u otro tipo de aplicación similar que use el puerto 80 o 443 para establecer comunicación, te puede originar este tipo de problemas mientras se estén ejecutando al mismo tiempo que intentas arrancar a apache. Cambia el puerto a esas aplicaciones o páralas en el momento que quieras usar el servidor. 

Espero te pueda servir.

Saludos 

 

 

--- Servidores Caseros sobre Ubuntu---

+1
0
-1

Mi Web: --- Servidores Caseros sobre Ubuntu---

Imagen de harold9007
+1
0
-1

Gracias estimado  Valc 

 

tenia problemas por en el arranque de apache porque tenia SSL

lo que hice fue algo muy simple... tuve que irme al Gestor de paquetes Synaptic para poder desabilitar el PAQUETE DE "APACHE SSL" y activar el otro paquete de APACHE  

me funciono muy bien... al hora de levantar el XAMPP

/opt/lampp/lampp start

colmenares

+1
0
-1

colmenares

Imagen de Valc
+1
0
-1

Hola, umbral :)

Para arrancar el AMP, se hace desde la consola con:

sudo /opt/lampp/lampp start

para reiniciarlo (si ya estaba en marcha)

sudo /opt/lampp/lampp restart

para detenerlo:

sudo /opt/lampp/lampp stop (si ya estaba en marcha)

Lo que puede provocar advertencias o errores es, por ejemplo, intentar reiniciarlo si aún no se había puesto en marcha.

Saludos 

 

--- Servidores Caseros sobre Ubuntu---

+1
0
-1

Mi Web: --- Servidores Caseros sobre Ubuntu---

Imagen de akhil
+1
0
-1

q tal, les dejo lo q me aparece a mi, cuando quiero iniciarlo.

 

upper@servidor:~$ sudo /opt/lampp/lampp start
[sudo] password for upper:
/opt/lampp/lampp: line 74: arch: orden no encontrada
Starting XAMPP for Linux 1.6.4...
/opt/lampp/lampp: line 74: arch: orden no encontrada
/opt/lampp/lampp: line 74: arch: orden no encontrada
XAMPP: Starting Apache with SSL (and PHP5)...
/opt/lampp/lampp: line 74: arch: orden no encontrada
XAMPP: Starting MySQL...
/opt/lampp/lampp: line 74: arch: orden no encontrada
XAMPP: Starting ProFTPD...
Warning: World-writable config file '/opt/lampp/etc/my.cnf' is ignored
Warning: World-writable config file '/opt/lampp/etc/my.cnf' is ignored
Warning: World-writable config file '/opt/lampp/etc/my.cnf' is ignored
Warning: World-writable config file '/opt/lampp/etc/my.cnf' is ignored
XAMPP for Linux started.
upper@servidor:~$
 

 

igual es lo unico q se hacer,

lo instale porq me dijeron q me servia para montar un servidor web, pero llegue hasta ahi y no q se mas se hace jejeje

 pero de movida ya me tira esos errores.

y cuando entro en la parte de seguridad, le pongo contraseña a todo, y la de MYSQL sigue como inseguro. 

+1
0
-1
Imagen de juankvillegas
+1
0
-1

Buenas, acabo de instalar Xampp y está funcionando, bueno, eso pareciera...

Si entro al localhost lo hace bien y me aparece la pantalla naranja de xampp y toda la configuración etc, etc, etc... pero le puse una carpeta en dónde tengo un proyecto que estoy haciendo en la oficina, y cuando le doy localhost/rd (rd es la carpeta donde está el proyecto) me aparece lo siguiente:

 

Warning: Unknown: failed to open stream: Permiso denegado in Unknown on line 0

Fatal error: Unknown: Failed opening required '/opt/lampp/htdocs/rd/index.php' (include_path='.:/opt/lampp/lib/php') in Unknown on line 0

 

¿Alguien sabe qué podrá ser?

Además pegué (con permisos de superusuario) la base de datos de MySQL en la carpeta correspondiente, y cuando intento acceder a alguna tabla por medio del phpMyAdmin me muestra lo siguiente:

 

Error

consulta SQL: 

SHOW INDEX FROM `directorio` ;

MySQL ha dicho: 

#1017 - Can't find file: './rd/directorio.frm' (errno: 13)

 

Se les agradece toda la ayuda que me puedan brindar.

Un saludo.

+1
0
-1
Imagen de lrra1961
+1
0
-1

para que tu servidor funcione correctamente debes poner el directorio en que tienes tu proyecto dentro de htdocs que es el directorio por defecto para ver tu paginas web o de lo contrario debes cambiar la configuracion en el archivo httpd.conf y decirle ahi donde estaran tu paginas web, pero esto ha de ser siempre dentro de la ruta /opt/lampp, en tu caso deberia quedar /opt/lampp/htdocs/rd y luego en el web browser colocar http://localhost/rd y ahi si te levantara tu pagina principal que debe llamarse index.html, index.htm, index.php o algun nombre que tambien viene configurado por defecto en el mismo archivo que menciono mas arriba. De otro modo es imposible que el servidor apache te levante un pagina web porque estaria tratando de llamar a una pagina fuera del entorno del servidor. Respecto de la base de datos es algo similar las BD deben ir en un directorio determinado que en este momento no me acuerdo el nombre, pero crea una BD cualquiera y despues trata de exportarla a otro lugar y ahi te dira cual es el dierectorio donde se guardan todas....espero haberte ayudado con esto....si es que entendi bien tu problema.

+1
0
-1

Tengo todas las ganas de migrar a Linux definitivamente, pero es bien complicado solucionar algunos problemas que se presentan...tienen que mejorar el uso de controladores para que el usuario comun no tenga tanto problema....eso aleja a la gente de est

Imagen de mimimi
+1
0
-1

Yo lo resolví de la siguiente forma:

 

cd /opt/lampp/htdocs/(nombre de la carpeta de mi proyecto)

chmod a+rw *

 

Eso es todo...

+1
0
-1
Imagen de Nadal
+1
0
-1

hola, resulta que yo instalé el xampp y me iva de maravilla, y yo sabia que al reiniciar el equipo tenia que volver a iniciar el xampp y así lo hice, pero sorpresa cuando me encontré esto al ir a mi localhost:
Index of /
[ICO] Name Last modified Size Description
Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.1 with Suhosin-Patch Server at localhost Port 80

si alguien sabe que puede ser se lo agradezco, gracias.

+1
0
-1
Imagen de neopablinho
+1
0
-1

Esto es lo que me encuentro yo cuando intento lanzar xampp:

root@pablo-laptop:/home/pablo/Escritorio# /opt/lampp/lampp start
Starting XAMPP for Linux 1.5.5a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

El caso es que mi compañero ha hecho lo mismo que yo y a el le está funcionando.

No lo entiendo. ¿Será algo que tenia instalado de antes?

+1
0
-1
Imagen de mancocapac
+1
0
-1

Bueno, aunque soy nuevo en el uso de Ubunto, me encontré con el mismo problema, busque la soluci{on en linea, no la encontré pero si me dieron muchas pistas.
Al parecer cuando se instala XAMPP, se lo hace con una versi{on difernte de Apache que ya debe estar instalada en tu máquina, sin desinstalar la primera. Esto crea un conflicto cuando arrancamos XAMPP, por lo que te aconsjo que primero detengas apache:

sudo /etc/init.d/apache2 stop

luego inicia XAMPP:

sudo /opt/lampp/lampp start

o si ya lo iniciaste antes tienes que resetearlo:

sudo /opt/lampp/lampp restart

y con esto te funcionará sin problemas.

(ojo, esto tienes que hacerlo cada vez que quieras iniciar LAMPP, pero es posible que podamos desinstalar la una versión de apache para no tener que hacerlo siempre)

+1
0
-1
Imagen de guvtuv
+1
0
-1

Mi problema se origino porque tenia instalado xampp y funcionaba perfecto, pero luego instale desde consola otra version de apache.
Fui al centro de software de ubuntu y desinstale el nuevo apache, reinstale xampp y listo

+1
0
-1

Mi equipo es una Laptop Sony Vaio Modelo VGN-FS980F, más detalles aquí
Gustavo Román Martínez

Imagen de electronico_linux
+1
0
-1

Problema: Al instalar el MYSQL server sobre el MYSQL que ya estaba por defecto cuando se instaló Linux, provocó que se cambiaran los permisos de MYSQL, ya no habia conexión con las bases de datos MYSQL (en Xampp aparece MySQL Database ? Desactivado). Se desinstaló XAMPP por completo y al volver a instalarlo tampoco funciono.,

El siguiente error aparece en consola cuando se quiere realizar la activación de MySQL:

root@ubuntu:~# /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

root@ubuntu:/opt/lampp# ./lampp startmysql
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!

************************************************************************************************************
SOLUCION:

Solución: Gracias al foro http://www.apachefriends.org/f/viewtopic.php?p=147421 se establece la reconexion de Apache y MySQL. Mediante la siguiente línea de comandos.

root@ubuntu:~# /etc/init.d/mysql stop
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service mysql stop

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) utility, e.g. stop mysql
mysql stop/waiting
root@ubuntu:~# /opt/lampp/lampp restart
Stopping XAMPP for Linux 1.7.7...
XAMPP: Stopping Apache...
XAMPP: XAMPP-MySQL is not running.
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

root@ubuntu:~# /opt/lampp/lampp restart
Stopping XAMPP for Linux 1.7.7...
XAMPP: Stopping Apache...
XAMPP: Stopping MySQL...
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

+1
0
-1
Imagen de rafa_88988
+1
+1
-1

Me sirvio esto ...
Para solucionarlo hay que parar apache2:
$ sudo /etc/init.d/apache2 stop
Y listo. Reiniciamos XAMPP (si ya lo habíamos intentado iniciar):
$ sudo /opt/lampp/lampp restart
Ya tenemos XAMPP Funcionando!

sacado de http://www.linuxinicio.com.ar/2010/10/solucion-xampp-error-1-couldnt-sta...

+1
+1
-1
Imagen de arthusu
+1
0
-1

gracias me sirvio :D

+1
0
-1