Problema con grub

Hola, antes que todo quisiera agradecerle al que me responda esto.

En mi pc, tengo instalado Windows Xp y Ubuntu, la instalacion fue la correcta, anda todo perfecto.

Hasta que la otra vez mi "queridisimo" Windows dejo de funcionar bien, entonces, se me dio por formatear, formatee la unidad c: (la de windows) y deje intacta la ext2 y la swap, el problema ahora: cuando formatee, es como que se cambio el MBR y quedo solo Windows, osea, no inicia grub, directamente va a windows, como si nunca hubiera instalado linux, quisiera saber como hacer para reinstalar grub sin tener que instalar todo el Ubuntu nuevamente.

Salu2.-

Imagen de foxfuz
+1
0
-1

Entra en consola con algun livecd:

root@personal:~ # grub

grub> root (hd0,2) (debes poner la particion / de tu linux)

grub> setup (hd0)

grub> quit

Saludos

+1
0
-1
Imagen de Anónimo
+1
0
-1

Cuando te referis a algun livecd, este livecd tiene que ser de ubuntu??

Porque yo tengo el de knoppix, o tengo que bajar el livecd de ubuntu?

Salu2 y gracias.-

+1
0
-1
Imagen de entiak
+1
0
-1

puede ser cualquier livecd, linux es linux y grub es grub sea la distribución que sea ;)

Fíjate que yo para cuando pasa algo de eso lo que hago es arrancar con el cd de instalación de SuSE y decirle que me inicie el sistema instalado en la partición donde tengo ubuntu... X'D (se puede complicar la cosa tanto como quieras... amo a mi linuxin ;) )

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

+1
0
-1

--
Saludos,
Juan. (http://blog.entiak.com)
jbaixauli (at) gmail.com

Imagen de Anónimo
+1
0
-1

Gracias capo!!!!

Ahora tengo otra prgunta, al querer montar la particion de windows, me dice que no es ntfs, pero si es ntfs, la cosa que ahora el windows que estoy usando es el sp2, y quiza el linux la reconoce de otra manera, alguien me podria decir que poner en el fstab??

Salu2 y muchas gracias.-

+1
0
-1
Imagen de herje
+1
0
-1

¿Has cargado el módulo ntfs?

Saludos
Herje
http://www.herje.com

+1
0
-1

Saludos
Herje
http://www.herje.com

Imagen de Anónimo
+1
0
-1

como se carga??? porque ahora cuando intento cargar grub me lo toma como particion desconocida /dev/hda1, ya me estoy asustando, no puedo arrancar windows!!!

Salu2.-

+1
0
-1
Imagen de Anónimo
+1
0
-1

Bueno, les cuento, instale ubuntu 64 bit en mi maquina de 64 bit, todo perfecto la intalacion pude ocupar ubuntu, sin ningun problema, me reconocio todo mi hardware(algo que es un milagro!!!), pero al volver a arrancar mi maquina, no me muestra la opcion para windows xp, y solo arranca con ubuntu, que puedo hacer?, por favor ayudenme, quiero aprender a utilizar linux!!!!.

Desde ya muchas gracias.

+1
0
-1
Imagen de joseluis
+1
0
-1

Intenta modificar /boot/grub/menu.lst según pone en este comentario

+1
0
-1

Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

Imagen de Anónimo
+1
0
-1

El problema es que instalaste Windows después de tener instalado Ubuntu. La solución:

http://www.ubuntuguide.org/#restoregrubmenuafterwindowsinstallation

Saludos.

+1
0
-1