lgeneral

Imagen de kyo21
0 puntos

hola soy nuevo en linux y por eso no se mucho, lo poco y nada que se es por la guia ubuntu de esta pagina, que por siacaso esta muy bien explicada. bueno mi duda es que descargue este juego el panzer general, pero no se como se instala, venia en extencion tar.gz, y la descomprimi en una carpeta de linux, pero de ahi no se que mas hacer tengo que ejecutar un comando para instalar, por ayuda!!!.

Imagen de aitorcalero
+1
0
-1

No deberías haber bajado ningún archivo. Basta con que actives los respositorios multiverse (guia-ubuntu), y con synaptic, busca el juego y el conversor de escenarios (lgeneral y lgc-pg). Los instalas y ya está. Luego lo que si te tienes que bajar son los mapas y escenenarios y cargarlos lgc-pg (en su web viene bien explicado).

+1
0
-1
Imagen de kyo21
+1
0
-1

no tenia idea, bueno sera, pero como hago lo que me dijiste como dije anteriormente estoy recien aprendiendo a ocupar linux y se hacer algunas cosas no mas

+1
0
-1
Imagen de Geo
+1
0
-1

Qué tal, yo también soy nuevo (llevo una semana con esto), pero si tienes conexión a internet te será de MUCHA ayuda (yo no tengo, tengo que andar descargando los paquetes que me hacen falta en cafés o en el trabajo :P).

Visita esta página: http://www.guia-ubuntu.com, allí explican varias cosas, entre ellas cómo agregar repositorios para poder descargar paquetes fácilmente.

El juego que comentas, ¿dónde lo conseguiste?

Saludos,
José Jorge (Geo).

+1
0
-1

~~~~~~~~~~~~~~~~~~~
La imaginación es el límite.

Imagen de Anónimo
+1
0
-1

si se mas o menos como agragar repositorios pero hay que agregar una direccion especifica y mi pregunta cual es para descargar el juego que baje?
Aproposito el juego ese lo descargue de http://lgames.sourceforge.net/index.php?project=LGeneral

si lo puedes instalar por favor podrias decirme como una por otra :p

saludos

+1
0
-1
Imagen de Geo
+1
0
-1

si no te funciona instalarlo automáticamente, prueba descargando el paquete desde http://packages.ubuntu.com, seleccionas la versión que tienes y buscas lgeneral (también tendrás que descargarte las dependencias, aunque probablemente esas si te funcionen descargando automáticamente).

Luego, para instalarte el paquete (ya que lo hayas descargado), abre un terminal, ve a la carpeta donde está el paquete y escribe:

$ sudo dpkg -i nombre_del_paquete.deb

Asi es como he instalado la mayoría de las cosas en mi sistema ya que no cuento con internet :P. Al rato pruebo con el paquete descargado de allí y quizá luego compilando yo mismo el juego, ya te comentaré (aunque espero que con esto lo arregles :D).

Por cierto, si tienes paquetes rotos, te irán dando algunos problemas, lo mejor será que los elimines.

Saludos,
José Jorge (Geo).

+1
0
-1

~~~~~~~~~~~~~~~~~~~
La imaginación es el límite.

Imagen de Geo
+1
0
-1

Bien, ya lo instalé (tanto compilando como con los paquetes .deb). Para hacerlo mediante los paquetes, hay que descargar estos dos:

lgeneral
lgc-pg

lgeneral depende de libsdl-mixer1.2 y de libsdl1.2debian (recomiendo descargarse la libsdl1.2debian-esd o mejor la libsdl1.2debian-all, por un problema con el audio).

Ahora, lgeneral no es un juego completo en si, sino un engine que puede utilizar la información del juego Panzer General, por lo que es necesario contar con ella y luego "convertirla" (para lo cual se usa lgc-pg).

Hay que ir a http://lgames.sourceforge.net/index.php?project=LGeneral y descargar el archivo

pg-data.tar.gz => Panzer General (DOS) Data (410 KB)

Este archivo contiene los datos del juego Panzer General, necesarios para poder jugar (en esa página también es posible descargarse una campaña y varios escenarios, pero solo sigo con este archivo que es indispensable para poder jugar).

Hay que descomprimirlo, y luego ejecutar el comando (no lo recuerdo muy bien, pero viene en el archivo readme incluído. Luego lo reviso).

lgc-pg -s /directorio/donde/lo/descomprimimos -u /directorio/del/juego

El directorio del juego será /usr/share/games/lgeneral (si lo instalaron con los paquetes .deb de los repositorios de Ubuntu).

Aquí, a mi me dió problemas diciéndome que no encontraba algún archivo, lo que pasa es que el programa de conversión busca los archivos con nombres en mayúsculas y a mi me aparecían en minúsculas una vez descomprimidos, tuve que renombrarlos y ejecutar nuevamente el comando.

Bueno, espero que le sirva de ayuda a quien desee instalarse este juego (aunque debo confesar que no es del todo de mi agrado, espero seguir probándolo hasta entenderle :P).

Saludos,
José Jorge (Geo).

+1
0
-1

~~~~~~~~~~~~~~~~~~~
La imaginación es el límite.

Imagen de Anónimo
+1
0
-1

Pero cuando trato de instalarlo me aparece el sig. error

root@pc-18-196-120-200:/ # aptitude install lgeneral
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
E: No se pudieron corregir los problemas, usted ha retenido paquetes
rotos.
E: No ha sido posible corregir las dependencias, no se pueden instalar algunos de los paquetes
E: Unable to resolve some dependencies!
No se cumplen las dependencias de algunos paquetes. Esto puede significar que ha
solicitado una situación imposible o que si usa la distribución inestable algún
paquete requerido aún no ha sido creado o sigue en «Incoming».

No se satisfacen las dependencias de los siguientes paquetes:
lgeneral: Depende: libc6 (>= 2.3.4-1) pero está instalado 2.3.2.ds1-20ubuntu14.

que puede ser

+1
0
-1