Mi disco SATA es sda y no me monta el usb.

Imagen de jordi
0 puntos

Hola

Tengo Ubuntu Warthy instalada igual en un portatil y en el pc.Al conectar un dispositivo usb (pendrive, mp3...) en el portatil me lo monta el solo como sda1, todo correcto.Pero en el pc el dispositivo sda en el disco duro, ya que es SATA y no me monta los dispositivos usb,como saber q dispositivo es en el sistema mi usb?he probado copn sda4,sda5... y nada :(

He mirado el kernel, los modulos...todo esta configurado como en el portatil asi que ya no se que hacer y tampoco he visto gente por aqui con el mismo problema...

A ver si me podeis ayudar.

Gracias.

Imagen de Caribdis
+1
0
-1

Yo tengo dos discos duros, ambos SATA. Uno de ellos es sda y el otro es sdb, de forma que el pen usb lo monto como sdc1. Sin ningún problema. Así que tú si sólo tienes un disco SATA (sda) prueba a montar el flash usb como sdb1.
Saludos.
Jorge

+1
0
-1

-----
Jorge

Imagen de jordi
+1
0
-1

mount: special device /dev/sdb1 does not exist

+1
0
-1
Imagen de Caribdis
+1
0
-1

Pues haz lo siguiente: tras insertar el flash pen, teclea desde una terminal:

tail /var/log/messages

en mi caso aparece lo siguiente:

Dec 30 23:01:56 localhost kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Dec 30 23:01:56 localhost kernel:   Vendor: Generic   Model: Flash Disk        Rev: 7.78
Dec 30 23:01:56 localhost kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
Dec 30 23:01:56 localhost kernel: SCSI device sdc: 64000 512-byte hdwr sectors (33 MB)
Dec 30 23:01:56 localhost kernel:  /dev/scsi/host2/bus0/target0/lun0: p1
Dec 30 23:01:56 localhost kernel: Attached scsi disk sdc at scsi2, channel 0, id 0, lun 0
Dec 30 23:01:56 localhost kernel: usbcore: registered new driver usb-storage
Dec 30 23:01:56 localhost kernel: USB Mass Storage support registered.
Dec 30 23:01:56 localhost usb.agent[7084]:      usb-storage: loaded successfully
Dec 30 23:01:57 localhost scsi.agent[7147]: disk at /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1:1.0/host2/2:0:0:0

donde se ve claramente (en la cuarta línea) que lo detecta como sdc
Mira a ver qué sale en el tuyo.
Saludos
Jorge

+1
0
-1

-----
Jorge

Imagen de jordi
+1
0
-1

Se me han roto lsos esquemas:

dic 30 23:50:35 localhost gconfd (jordi-4582): Se resolvió la dirección «xml:readonly:/etc/gconf/gconf.xml.defaults» a una fuente de configuración de sólo lectura en la posición 2
dic 30 23:50:45 localhost gconfd (jordi-4582): Se resolvió la dirección «xml:readwrite:/home/jordi/.gconf» a una fuente de configuración escribible en la posición 0
Dec 30 23:51:49 localhost kernel: [__report_bad_irq+49/115] __report_bad_irq+0x31/0x73
Dec 30 23:51:49 localhost kernel: [note_interrupt+76/111] note_interrupt+0x4c/0x6f
Dec 30 23:51:49 localhost kernel: [do_IRQ+146/249] do_IRQ+0x92/0xf9
Dec 30 23:51:49 localhost kernel: [common_interrupt+24/32] common_interrupt+0x18/0x20
Dec 30 23:51:49 localhost kernel: [default_idle+0/38] default_idle+0x0/0x26
Dec 30 23:51:49 localhost kernel: [default_idle+35/38] default_idle+0x23/0x26
Dec 30 23:51:49 localhost kernel: [cpu_idle+29/50] cpu_idle+0x1d/0x32
Dec 30 23:51:49 localhost kernel: [start_kernel+403/407] start_kernel+0x193/0x197

Flipao...

+1
0
-1
Imagen de jordi
+1
0
-1

Si tengo una terminal abierta, al meter el usb me dice esto:

Message from syslogd@localhost at Fri Dec 31 11:52:04 2004 ...
localhost kernel: Disabling IRQ #193

+1
0
-1
Imagen de Caribdis
+1
0
-1

Parece que tienes un conflicto con las IRQ.
Teclea:

dmesg > mensajes.txt

con lo cual se creará un archivo llamado mensajes.txt con toda la información que se va generando durante el arranque. Revísalo para ver si te sale algún mensaje de error referente a conflictos IRQ o dispositivos USB. No se me ocurre otra cosa.
Saludos.
Jorge

+1
0
-1

-----
Jorge

Imagen de jordi
+1
0
-1

Ya he creado el fichero,esto es lo q me mosquea:

...
ACPI: PCI interrupt 0000:00:1d.7[D] -> GSI 23 (level, low) -> IRQ 193
ehci_hcd 0000:00:1d.7: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
ehci_hcd 0000:00:1d.7: BIOS handoff failed (104, 1010001)
ehci_hcd 0000:00:1d.7: can't reset
ehci_hcd 0000:00:1d.7: init 0000:00:1d.7 fail, -95
ehci_hcd: probe of 0000:00:1d.7 failed with error -95
ICH5: IDE controller at PCI slot 0000:00:1f.1
PCI: Enabling device 0000:00:1f.1 (0005 -> 0007)
...

y casi al final:

drivers/usb/input/hid-input.c: event field not found
drivers/usb/input/hid-input.c: event field not found

Ahora voy a arrncar con el usb metido, a ver q veo.

Con el USB dentro dice lo mismo.:(

+1
0
-1