Actualizando hardy, me ha dado un fallo irreparable

Imagen de mijel84
0 puntos

Hola, uso un portatil toshiba dual core.

Estaba trabajando como siempre en mi ordenador (ya se que es una versión inestable y no se debe, etc etc, se lo que hago que tengo otro sistema por si me falla este, pero me va bien hardy) y aparecieron 80 actualizaciones nuevas, hoy dia 13-03-2008 entre ellas solo reconocí, unas sobre compiz fusion otras sobre el kernel xxxx-44-12 etc etc.

he actualizado y cuando estaba instalando las primeras, un fallo gordísimo, core dump, errores por todos los lados, en la carpeta usr/lib empezó a fallar varios arcihivos. 

He entrado a prueba de fallos y nada, en modo consola ni siquiera me deja poner el nombre de usuario, me dá error, eso que probé en todas las sesiones.

Inicié el ordenador a prueba de fallos, probé todas las opciones que me daba pero nada, no me deja escribir ni entrar ni hacer nada de nada.

volví a grabar el sistema d cero, solo conservando mi home, todo bien, entre por primera vez al escritorio, no me cargó, me dio errores de aplets, algo que no creo que tenga relación con lo anterior.

Seguidamente desde modo texto hice un sudo apt-get update y upgrade y me volvió a saltar el mismo problema de antes, y aqui estoy en windows, esperando a que alguien comente algo sobre ello y volver a instalar de nuevo el S.O.

Por cierto, he borrado de home casi todas las carpetas referentes a gnome, config, nautilus, local, etc etc por si fuese fallo de eso.

Imagen de j666
+1
0
-1

Me acaba de pasar exactamente lo mismo, ya se que hardy es una versión en desarrollo, pero este fallo es muy grave, mirare a ver si encuentro información, pero me parece que voy a tener que instalar ubuntu de nuevo, porque no hay manera de logearme nisiquiera en modo texto.

 

Saludos. 

+1
0
-1
Imagen de mijel84
+1
0
-1

Instálalo de nuevo pero no actualices porque yo lo he hecho y ha vuelto a pasar, nose donde podrían hablar del error ese .. si sabes algo avisa.

 

 

 

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

+1
0
-1

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

Imagen de mijel84
+1
0
-1

Si el archivo que está mal es ese que nos  dijeron, si se borra manualmmente desde live cd??? 

Bueno, el caso es que probé las 2 opciones que dan en la página de lauchpad y ni una ni otra. 

La primera llego a donde hay que poner nombre y usuario y pongo cualquier usuario y me da error ya.

El segundo, monto todo, hago todo bien, pero en cuanto mando instalar el archivo libc6.... da el mismo error que daba cuando se estropeó core dumped y muchas letras, aludiendo a la carpeta usr/lib/ archivos que tiene dentro.

 

 

 

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

+1
0
-1

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

Imagen de pleirb
+1
0
-1

Estoy en Windows porque me pasa lo mismo que mijel84.
Ayer estaba tratando de resolver un problema con los socket ya que el mysql server me daba unos problemas con eso. Creia que la solucion de esto estaba en buscar un archivo el cual me hiba a dar una pista para la solucion. Asi que puse a buscar en todo el disco dicho. La deje buscando y me fuí a la casa de mi novia, quedó toda la noche prendida. Hoy vuelvo y estaba colgada, no me respondía asi que hice un CTRL+ALT+Retroceso e inicié seción normalmente. Aquí fué, hoy 13/3/08 dende me aparecieron actualizaciones del kernel, nvidia, compiz, unos cuantos lib´s etc creo que eran como 80 también. Le di el OK para que actualizara y en determinado momento me dio un error no se si es el mismo que comenta mijel84 pero puede ser, la cosa es que la actualizacion quedó incompleta. Decido reiniciar el sistema y aparece el logo de Ubuntu como siempre, en determinado momento se congela la barra de progreso pero enseguida aparece pantalla negra con todos los modulos que va cargando quedandose un timepo muy largo en "Starting System log deamon" resultando este al fin como fallido, sigue cargando modulos y como que empieza a cargar la pantalla de login porque veo el mouse y lo puedo mover pero queda aqui idefinidamente con fondo negro (puede ser negro en mi caso porque yo lo configure asi para el arranque, en vez del naranja)
Como no hay forma de salir de esto, tengo que recetear la maquina a lo bruto y aqui intente las otras opciones del menu, la de recovery, entre con el genérico, hasta le hice el testeo de memoria que esta al final de la lista. NADA. ¿Debo usar Windows mientras terminan de desarrollar Hardy? Yo se que hay muchos que me va a decir que debo usar Gusty hasta que Hardy esté listo, pero este tipo de errores son demaciado importantes. Nunca pensé que me fuera a suceder.

+1
0
-1
Imagen de j666
+1
0
-1

Parece ser que se puede reparar sin tener que reinstalar el sistema, he encontrado información aquí https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/201673 el unico problema es que no tengo ningun live cd de ubuntu porque utilizo la versión con instalador en modo texto, en cuanto acabe de bajar el live cd pruebo las posibles soluciones que he visto en el enlace que he puesto arriba, pero el live cd se me esta bajando  a paso de tortuga así que tardare bastante.

 

Saludos.

 

+1
0
-1
Imagen de pleirb
+1
0
-1

Use un Live CD que ya montaba todos los discos (ubuntu 7.10)

Configuré el pppoeconf para conectarme a internet 

Y desde un terminal puse:
sudo chroot /media/disk-2 wget http://us.archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6_2.7-5ubuntu2...

Bajó el paquete correctamente, luego

sudo chroot /media/disk-2 dpkg -x libc6_2.7-5ubuntu2_i386.deb

Puso esto: 

*** glibc detected *** dpkg-deb: munmap_chunk(): invalid pointer: 0xb7dbbed0 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7e24a87]
/lib/libc.so.6[0xb7eb6740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7eb67c6]
/lib/libc.so.6[0xb7ddd0ab]
/lib/libc.so.6[0xb7ddc891]
/lib/libc.so.6[0xb7ddca7a]
/lib/libc.so.6[0xb7dd58e1]
/lib/libc.so.6[0xb7dd42a7]
/lib/libc.so.6[0xb7de1d4a]
/lib/libc.so.6[0xb7de2452]
/lib/libc.so.6(dcgettext+0x43)[0xb7de11b3]
dpkg-deb[0x804cf03]
dpkg-deb[0x804df7a]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7dd33a0]
dpkg-deb[0x8049f61]
======= Memory map: ========
Cancelado (core dumped)

Use /media/disk-2 porque es donde está montado mi hardy pero no se si estoy haciendo bien. La cosa es que no pasó nada sigue igual

+1
0
-1
Imagen de mijel84
+1
0
-1

Encontré esto, 

 

Here's how I did:

* Boot from the Live CD/DVD
* Depending on the Live CD you are using (Gnome is better, cause you'll only need to double click the appropriate icon on your desktop), you'll have to manually mount your root partition or not.
If you need to mount it (so, if you are using KDE), the best way is:

sudo su
mkdir /myroot
mount /dev/sda1 /myroot (where /dev/sda1 should be replaced in case)

* Then, download the old glibc:

chroot /myroot wget http i386.deb

(copiar bien la dirección completa, que está abreviada)

* And run dpkg in order to downgrade it:

chroot /myroot dpkg -x libc6_2.7-5ubuntu2_i386.deb

* After, you can always remove the package from your root dir.

 Si alguien la prueba y le vá, avisar, según el foro de bugs a la gente esto le fue.

 

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

+1
0
-1

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

Imagen de j666
+1
0
-1

Bueno pues por fin he acabado de descargar el live cd (ha tardado varias horas!!!), y he seguido las instruciones de uno de los comentarios que habia en el enlace que habia puesto mas arriba (son las mismas que ha posteado mijel_84) solo que he tenido que cambiar la linea:

<code>chroot /myroot dpkg -x libc6_2.7-5ubuntu2_i386.deb

por: 

chroot /myroot dpkg -i libc6_2.7-5ubuntu2_i386.deb

 

vamos he cambiado la -x por -i</code>

de todas formas copio la solución dentro de un code porque en el post de mijel_84 el foro comvierte automaticamente en enlace la diección al paquete que hay que descargar.

<code>

Here's how I did:

* Boot from the Live CD/DVD
* Depending on the Live CD you are using (Gnome is better, cause you'll only need to double click the appropriate icon on your desktop), you'll have to manually mount your root partition or not.
If you need to mount it (so, if you are using KDE), the best way is:

sudo su
mkdir /myroot
mount /dev/sda1 /myroot (where /dev/sda1 should be replaced in case)

* Then, download the old glibc:

chroot /myroot wget http://us.archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6_2.7-5ubuntu2_i386.deb

* And run dpkg in order to downgrade it:

chroot /myroot dpkg -x libc6_2.7-5ubuntu2_i386.deb

* After, you can always remove the package from your root dir.</code>

+1
0
-1
Imagen de mijel84
+1
0
-1

He actualizado de nuevo y ya no hay ningún fallo, listo, fallo resuelto, rápido y seguro, un diez para ellos.

 

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

+1
0
-1

Actualizate, vive al día, estate al día, busca, rebusca, depende de alguién lo menos posible.

Imagen de pleirb
+1
0
-1

hago todo lo que comentan y obtengo esto:

*** glibc detected *** dpkg: munmap_chunk(): invalid pointer: 0xb7e65ed0 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7ecea87]
/lib/libc.so.6[0xb7f60740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7f607c6]
/lib/libc.so.6[0xb7e870ab]
/lib/libc.so.6[0xb7e86891]
/lib/libc.so.6[0xb7e86a7a]
/lib/libc.so.6[0xb7e7f8e1]
/lib/libc.so.6[0xb7e7e2a7]
/lib/libc.so.6[0xb7e8bd4a]
/lib/libc.so.6[0xb7e8c452]
/lib/libc.so.6(dcgettext+0x43)[0xb7e8b1b3]
dpkg[0x80613f9]
dpkg[0x805f06b]
dpkg[0x804b02b]
dpkg[0x805572d]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7e7d3a0]
dpkg[0x804acd1]
======= Memory map: ========
Cancelado (core dumped)

Ayuda, no puedo seguir sin trabajar, me he vuelto dependiente de Ubuntu.

Hice esto:

Inicié con un Live CD
Puse:
sudo su
monte sda2 (mi particion de ubuntu) en /myroot que tuve que crear primero.
baje el archivo y lo dejé en la raiz de /myroot
Y luego:
chroot /myroot dpkg -i libc6_2.7-9ubuntu2_i386.deb
Tuve que bajar este porque libc6_2.7-5ubuntu2_i386.deb core no estaba disponible en los vinculos que estan arriba. De todas formas ya lo había intentado antes con esta versión.

Ayuda !!!!!!

+1
0
-1
Imagen de j666
+1
0
-1

Hola pleirb  pues si que es raro de todas formas se me ocurre que podrias probar esto:

<code>

inicias el live cd

montas tu partición root

(todo esto siguiendo el mismo procedimiento que seguias anteriormente)

ahora viene lo nuevo, no lo he probado, pero deberia funcionar 

chroot /myroot apt-get update

chroot /myroot apt-get -s upgrade | grep libc6

 </code>

 

Prueba haber si te sirve de esta manera

 

Saludos.

+1
0
-1
Imagen de pleirb
+1
0
-1

Hice: chroot /myroot apt-get update

como me has dicho y obtengo:

*** glibc detected *** /usr/lib/apt/methods/http: munmap_chunk(): invalid pointer: 0xb7c103b8 ***
*** glibc detected *** /usr/lib/apt/methods/http: munmap_chunk(): invalid pointer: 0xb7c863b8 ***
*** glibc detected *** /usr/lib/apt/methods/http: munmap_chunk(): invalid pointer: 0xb7c473b8 ***
*** glibc detected *** /usr/lib/apt/methods/http: munmap_chunk(): invalid pointer: 0xb7bd03b8 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7c7da87]
/lib/libc.so.6[0xb7d0f740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7d0f7c6]
/lib/libc.so.6[0xb7c360ab]
/lib/libc.so.6[0xb7c35891]
/lib/libc.so.6[0xb7c35a7a]
/lib/libc.so.6[0xb7c2e8e1]
/lib/libc.so.6[0xb7c2d2a7]
/lib/libc.so.6[0xb7c3ad4a]
/lib/libc.so.6[0xb7c3b452]
/lib/libc.so.6(dcgettext+0x43)[0xb7c3a1b3]
/lib/libc.so.6(dgettext+0x20)[0xb7c3a1e0]
/usr/lib/apt/methods/http[0x80526f9]
/usr/lib/apt/methods/http[0x804dd11]
/usr/lib/apt/methods/http[0x80502cf]
/usr/lib/apt/methods/http[0x8051453]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7c2c3a0]
/usr/lib/apt/methods/http(__gxx_personality_v0+0xe9)[0x804abf1]
======= Memory map: ========
======= Backtrace: =========
/lib/libc.so.6[0xb7cf3a87]
/lib/libc.so.6[0xb7d85740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7d857c6]
/lib/libc.so.6[0xb7cac0ab]
/lib/libc.so.6[0xb7cab891]
/lib/libc.so.6[0xb7caba7a]
/lib/libc.so.6[0xb7ca48e1]
/lib/libc.so.6[0xb7ca32a7]
/lib/libc.so.6[0xb7cb0d4a]
/lib/libc.so.6[0xb7cb1452]
/lib/libc.so.6(dcgettext+0x43)[0xb7cb01b3]
/lib/libc.so.6(dgettext+0x20)[0xb7cb01e0]
/usr/lib/apt/methods/http[0x80526f9]
/usr/lib/apt/methods/http[0x804dd11]
/usr/lib/apt/methods/http[0x80502cf]
/usr/lib/apt/methods/http[0x8051453]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7ca23a0]
/usr/lib/apt/methods/http(__gxx_personality_v0+0xe9)[0x804abf1]
======= Memory map: ========
======= Backtrace: =========
/lib/libc.so.6[0xb7cb4a87]
/lib/libc.so.6[0xb7d46740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7d467c6]
/lib/libc.so.6[0xb7c6d0ab]
/lib/libc.so.6[0xb7c6c891]
/lib/libc.so.6[0xb7c6ca7a]
/lib/libc.so.6[0xb7c658e1]
/lib/libc.so.6[0xb7c642a7]
/lib/libc.so.6[0xb7c71d4a]
/lib/libc.so.6[0xb7c72452]
/lib/libc.so.6(dcgettext+0x43)[0xb7c711b3]
/lib/libc.so.6(dgettext+0x20)[0xb7c711e0]
/usr/lib/apt/methods/http[0x80526f9]
/usr/lib/apt/methods/http[0x804dd11]
/usr/lib/apt/methods/http[0x80502cf]
/usr/lib/apt/methods/http[0x8051453]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7c633a0]
/usr/lib/apt/methods/http(__gxx_personality_v0+0xe9)[0x804abf1]
======= Memory map: ========
======= Backtrace: =========
/lib/libc.so.6[0xb7c3da87]
/lib/libc.so.6[0xb7ccf740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7ccf7c6]
/lib/libc.so.6[0xb7bf60ab]
/lib/libc.so.6[0xb7bf5891]
/lib/libc.so.6[0xb7bf5a7a]
/lib/libc.so.6[0xb7bee8e1]
/lib/libc.so.6[0xb7bed2a7]
/lib/libc.so.6[0xb7bfad4a]
/lib/libc.so.6[0xb7bfb452]
/lib/libc.so.6(dcgettext+0x43)[0xb7bfa1b3]
/lib/libc.so.6(dgettext+0x20)[0xb7bfa1e0]
/usr/lib/apt/methods/http[0x80526f9]
/usr/lib/apt/methods/http[0x804dd11]
/usr/lib/apt/methods/http[0x80502cf]
/usr/lib/apt/methods/http[0x8051453]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7bec3a0]
/usr/lib/apt/methods/http(__gxx_personality_v0+0xe9)[0x804abf1]
======= Memory map: ========
*** glibc detected *** apt-get: munmap_chunk(): invalid pointer: 0xb7c67ee8 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7cd0a87]
/lib/libc.so.6[0xb7d62740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7d627c6]
/lib/libc.so.6[0xb7c890ab]
/lib/libc.so.6[0xb7c88891]
/lib/libc.so.6[0xb7c88a7a]
/lib/libc.so.6[0xb7c818e1]
/lib/libc.so.6[0xb7c802a7]
/lib/libc.so.6[0xb7c8dd4a]
/lib/libc.so.6[0xb7c8e452]
/lib/libc.so.6(dcgettext+0x43)[0xb7c8d1b3]
/lib/libc.so.6(gettext+0x21)[0xb7c8d211]
apt-get[0x806504b]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_ZN10pkgAcquire3RunEi+0x24c)[0xb7f1ca7c]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_Z10ListUpdateR16pkgAcquireStatusR13pkgSourceListi+0x312)[0xb7f14132]
apt-get[0x8059666]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_ZN11CommandLine11DispatchArgEPNS_8DispatchEb+0x5b)[0xb7ef1e8b]
apt-get[0x804f06b]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7c7f3a0]
apt-get(__gxx_personality_v0+0x125)[0x804ce91]
======= Memory map: ========
Cancelado (core dumped)

 

Luego intenté por las dudas con: 

chroot /myroot apt-get -s upgrade | grep libc6

Y:

*** glibc detected *** apt-get: munmap_chunk(): invalid pointer: 0xb7bf4ee8 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7c5da87]
/lib/libc.so.6[0xb7cef740]
/lib/libc.so.6(__libc_dlsym+0x36)[0xb7cef7c6]
/lib/libc.so.6[0xb7c160ab]
/lib/libc.so.6[0xb7c15891]
/lib/libc.so.6[0xb7c15a7a]
/lib/libc.so.6[0xb7c0e8e1]
/lib/libc.so.6[0xb7c0d2a7]
/lib/libc.so.6[0xb7c1ad4a]
/lib/libc.so.6[0xb7c1b452]
/lib/libc.so.6(dcgettext+0x43)[0xb7c1a1b3]
/lib/libc.so.6(dgettext+0x20)[0xb7c1a1e0]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_Z18pkgMakeStatusCacheR13pkgSourceListR10OpProgressPP4MMapb+0x1fc)[0xb7ec0ffc]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_ZN12pkgCacheFile11BuildCachesER10OpProgressb+0xb9)[0xb7eb7019]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_ZN12pkgCacheFile4OpenER10OpProgressb+0x34)[0xb7eb7144]
apt-get[0x80576a8]
/usr/lib/libapt-pkg-libc6.7-6.so.4.6(_ZN11CommandLine11DispatchArgEPNS_8DispatchEb+0x5b)[0xb7e7ee8b]
apt-get[0x804f06b]
/lib/libc.so.6(__libc_start_main+0xe0)[0xb7c0c3a0]
apt-get(__gxx_personality_v0+0x125)[0x804ce91]
======= Memory map: ========

 Los Live CD que usé fueron 7.10 final y 8.04 alpha 3

Ahora me estoy bajando el alpha 6. ¿Hay posibilidades de reinstalar ubuntu sin perder datos, usuarios y programas? Es la que me queda
Muchas gracias de todas formas por el apoyo, se agradece mucho

+1
0
-1
Imagen de j666
+1
0
-1

Si vas a reinstalar el sistema y no quieres perder tus datos creo que puedes probar a reinstalarlo sin formatear tu partición home (supongo que tendras 3 particiones la root / y la /home) formateando solo la partición root no deberias perder tu configuración de todas formas si puedes guardar tus datos en otra partición o hacer copias de seguridad de tus datos mejor.

Aunque si quieres aun puedes probar una ultima cosa desde un live cd, yo use el alpha 6 no se si eso tendra algo que ver ¿?

 

 bueno pues antes de formatear puedes probar a desintlar la libreria y volverla a instala, que supongo que se instalaria en su versión más nueva.

 

inicias el live cd

montas tu partición root

(todo esto siguiendo el mismo procedimiento que seguias anteriormente)

ahora probamos a desintalar:

chroot /myroot apt-get remove libc6

 

sino funciona prueba con un force:

 chroot /myroot apt-get -f remove libc6

o un purge

 

chroot /myroot apt-get purge libc6 

o fuerzas el purge

chroot /myroot apt-get -f purge libc6 

 

si algo de esto funciona pues haces un update y reinstalas la libreria que se instalara en su versión "buena"

chroot /myroot apt-get update

chroot /myroot apt-get install libc6  

 

 

O también puedes probar a utilizar aptitude en vez de apt-get haber si te da mejor resultado.

 

Saludos.

+1
0
-1
Imagen de pleirb
+1
0
-1

Bueno, probé todo lo que amablemente me comentas. Lamentablemente en todo lo que pongo me da el mismo error que ya he pegado varias veces.

Lo que me falta es probar con el alpha 6 que acabo de bajar en mi trabajo. Espero que funcione, de lo contrario voy a tener que restaurar el sistema (si es que esto se puede en ubuntu). Y de última borro todo e instalo de 0 con la versión final que está por salir. Es una lástima porque ya tenía todo bien pulidito, funcionaba todo bastante bien a pesar de los tropiezos que implica usar software libre. Tenía todo pronto para empezar una migración de un software hecho en C#, pensaba portarlo a Linux mediante mono, mysql y xsp. En fin, por el momento, debo abandonar esta meta hasta tener todo en orden otra vez.

+1
0
-1
Imagen de pleirb
+1
0
-1

Estos fueron los pasos:

wget http://launchpadlibrarian.net/11110565/libc6_2.7-5ubuntu2_i386.deb

#al hacer doble clic monté la particion de ubuntu dañada en /media/disk-1

sudo dpkg -x libc6_2.7-5ubuntu2_i386.deb /media/disk-1

#supongo que este comando desempaquetó el deb en la raiz del disco (esto fué en realidad lo que me salvó)
#Luego de esto desmonte desde el escritorio y volvi a montar:

 
sudo mount /dev/sda2 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo cp libc6_*.deb /mnt/tmp/
sudo chroot /mnt dpkg -i /tmp/libc6_2.7-5ubuntu2_i386.deb
sudo chroot /mnt dpkg --configure -a
sudo chroot /mnt update-initramfs -u
sudo umount /mnt/proc
sudo umount /mnt/dev
sudo umount /mnt

# luego se me antojo hacer:

sudo su
cd..
cd..
mkdir /myroot
mount /dev/sda2 /myroot
chroot /myroot apt-get update

reinicié y reinstale el paquete roto, actualice todo y mande un informe de error. Gracias a todos !!!!

+1
0
-1