duda pavota sobre nvidia

Imagen de FedeTheGreat
+1
0
-1

efectivamente si quiero sacar el kernel para i386 me pide tambian sacar nvia-glx.

Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de gabiel
+1
0
-1

Seguramente sea suficiente con instalar el paquete linux-restricted-modules correspondiente a la versión del kernel que quieras usar; después de eso no creo que tengas problemas en eliminar el kernel que no desees (por supuesto asegurate de tener una imágen del kernel que sepas que funciona correctamente, para poder arrancar con ella en caso de problemas).

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de FedeTheGreat
+1
0
-1

que tema, al elegir este:Non-free Linux 2.6.12 modules on AMD K7-nvidia-legacy
me visa que se instalan tambienhay estos 2:
Restricted Linux modules on AMD K7
Non-free Linux 2.6.12 modules helper script
ok, pero cuando instalados esto saco el i386 me avisa qeu saca el mismo programita que te mensione mas arriba.. vere que pasa..

Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de FedeTheGreat
+1
0
-1

al parecer por mas aviso que paso las cosas siguen estando igualque bien con el kernel de amd instalado.
antes de instalar los drivers, el refresco maximo de mi monitor era de 60hz no tenia mas opciones, luego fue de 85hz (lo de siempre) y ahora sigue igual o sea que se mantiene.
la aplicacion de seteos de nvidia sigue estando y funcionando. o sea qeu supongo que todo esta en orden, hay algun modo de chequer que efectibamente esta bien instalado el driver?
gracias!
Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de gabiel
+1
0
-1

Basta con que le des un vistazo al registro de xorg (/var/log/Xorg.0.log) para saber si el controlador se carga correctamente.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de FedeTheGreat
+1
0
-1

como se lee este log? es una suma de todos los arrances, se hace cada vez?
porque es muy largoy dice muchas cosas, trate de subirlo algun lugar pero me dan todos error, asi que nolo voy a postear aca porque es muy largo.
Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de gabiel
+1
0
-1

Es solo el de la última vez que se inició xorg (el anterior se guarda en Xorg.0.log.old), lo puedes leer mediante less /var/log/Xorg.0.log

También puedes ver de forma más rápida si la aceleración 3d funciona, y por extensión el controlador se encuentra bien instalado, mediante glxinfo | grep direct; si aparece una línea diciendo yes ya lo tienes.

De todas formas, el hecho de que dependa del kernel genérico debe de ser un error del paquete, porque se tendría que conformar con cualquiera de los paquetes linux-restricted-modules. Así que no debería existir ningún problema al respecto.

Saludos.

--------
Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Para ver algo más interesante, haz clic aquí.
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de FedeTheGreat
+1
0
-1

me aparece esto:
federico@Fede:~$ sudo glxinfo | grep direct
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de gabiel
+1
0
-1

Pues eso indica que no tienes aceleración 3d, así que hay algo que no está bien.

Repasando los mensajes anteriores, he visto que instalas nvidia-glx, pero el paquete con el módulo del kernel que instalas es linux-restricted-modules-"version"-nvidia-legacy. Eso no es correcto, los paquetes en los cuales aparece nvidia-legacy al final del nombre corresponden a una versión antigua del controlador de nvidia; se incluyen porque en versiones posteriores no se daba soporte a tarjetas antiguas (TNT, etc. la lista completa la tienes en la descripción del paquete); así que lo primero que tienes que hacer es instalar lo que corresponda al modelo de tu tarjeta, si es de las antiguas nvidia-glx-legacy y el linux-restricted-modules-"version"-nvidia-legacy que corresponda (que al parecer ya tienes instalado); si por el contrario es de las nuevas, necesitas nvidia-glx (que ya tienes instalado) y el linux-restricted-modules-"arquitectura" que es el que no tienes instalado.

Saludos.

--------
Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Para ver algo más interesante, haz clic aquí.
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de FedeTheGreat
+1
0
-1

aaaaaaaaaaa, ok, muchas gracias ya lo pruebo
Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818

Imagen de FedeTheGreat
+1
0
-1

sos un groso, mil gracias!

federico@Fede:~$ glxinfo | grep direct
direct rendering: Yes
federico@Fede:~$

Linux User #404818

+1
0
-1

Me gustan las cosas simples por eso uso Arch!
Linux User# 404818