consulta opciones de kernel

Imagen de geohack
0 puntos

mi consulta es la siguiente...
estoy instalando un codigo antiguo, el cual fue hecho con en un kernel 2.4.x
el cual me pide ciertas opciones, estas las escribo en seguida.

Packet socket (CONFIG_PACKET)
Kernel/User netlink socket (CONFIG_NETLINK)
Routing messages (CONFIG_RTNETLINK)
IP: Socket Filtering (CONFIG_FILTER)
IP: advanced router (CONFIG_IP_ADVANCED_ROUTER)
IP: policy routing (CONFIG_IP_MULTIPLE_TABLES)
IP: tunneling (CONFIG_NET_IPIP)
Wireless LAN (non-hamradio) (CONFIG_NET_RADIO)

ahora de todas esas opciones, en la version de kernel 2.4.36.5 faltan
2 las cuales son
Kernel/User netlink socket (CONFIG_NETLINK)
Routing messages (CONFIG_RTNETLINK)

¿porque no aparecen?
¿que significa?

ahora peor en otra version de kernel, como por ejemplo 2.6.24.16
en la cual faltan muchas mas.

¿me funcionara adecuadamente el programa si lo compilo?
¿sino, como puedo hacerlo funcionar?

muchas gracias....

Imagen de eld1e6o
+1
0
-1

Hola, te recomiendo compilarlo y ver si te da algún error. Además usar el kernel precompilado de linux y no uno compilado por vos ya que en general son los mas completos, algunas veces las opciones se fusionan en otras, otras simplemente las quitan por alguna función mejor pero en general son compatibles los programas para kernels viejos aunque hay algunas funciones específicas que no.
En el archivo .config del directorio del kernel están las opciones a las que supongo que te referís... Las podes editar manualmente con nano o algún editor de texto y ver si realmente existen, como hiciste para buscarlas? con el buscador de gxconfig o similar? o como?

Deberías ser más específico, supongo que el soft que estás intentando compilar tiene una version mas nueva o alguna que cumple con tus requerimientos ya que por referirse a ese kernel debe ser bastante viejo... Además de que seguro que va a aprovechar bien y mejorar en el rendimiento del kernel actual ya que en general intentan mejorar y optimizar el código

Si comentás que programa es y de que web lo bajas posiblemente te podamos ayudar

Saludos

+1
0
-1
Imagen de geohack
+1
0
-1

mira primero que todo gracias por contestar.
el programa se llama dynamics-0.8.1
este programa es para trabajar con ip movil
esta basado en el kernel 2.4 pero el problema es
que no lo siguieron actualizando...

lo trate de compilar en el kernel 2.6 pero dio muchos errores...

apenas pueda nuevamente subo la lista de errores...

+1
0
-1