Por fin, Tarjeta TV Kworld: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)

+1
0
-1

Esta entrada la escribo en mi bitácora, pues no pretendo escribir un tutorial, ya existen muchos...

Les cuento que por fin pude instalar mi tarjeta capturadora de TV Kworld con chip philips SAA7134/SAA7135HL, he tenido experiencia instalando la tarjeta TV Terminator con chip SAA7133/SAA7135 que teiene el computador de mi hijo.

1. La tarjeta Terminator fue fácil de configurar:

Para estar seguro que es la tarjeta en Terminator puede usarse el comando desde la consola:

$ lspci | grep Multimedia

y retorna:

Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d0)

Para configurar la tarjeta con los parámetros adecuados se edita el archivo de opciones con la orden desde la consola:

$ sudo gedit /etc/modprobe.d/options

y se agrega la siguiente linea al final del archivo:

options saa7134 card=65 tuner=54

Puedes instalar tvtime.

Se reinicia y listo.


2. Por mucho tiempo no pude configurar mi capturadora Kworld de TV, lo intente desde que tenia Gutsy (ahora tengo felizmente Hardy) pero la solución no la encontraba aunque hay varias páginas donde aparecen soluciones para tarjetas con chip Philips SAA713x. Como lo pueden imaginar para mi era frustrante que en mi nuevo equipo no tuviese TV y el que estaba heredando a mi hijo funcionaba de lujo, por otro lado me encanta encanta editar vídeos con cinelerra.

Como podrán darse cuenta el método de solución es exactamente el mismo que describí anteriormente, lo que no encontraba era los parámetros correctos de card y tuner. Aunque en varias partes aparece la lista de hardware soportado, e indican que se puede desmontar y montar los parámetros con:

$ sudo modprobe -r saa7134_alsa
$ sudo modprobe -r saa7134
$ sudo modprobe saa7134 card=63 tuner=47

para luego probar si sirve con tvtime, esto no es aconsejable pues por alguna razón no carga los módulos requeridos y uno podría descartar la combinación triunfadora(en nuestro caso card=63 tuner=47).

Y ahora sí manos a la obra:

Para estar seguro que es la tarjeta Kworld que describo puede usar el comando desde la consola:

$ lspci | grep Multimedia

y retorna:

07:02.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)

Para configurar la tarjeta con los parámetros adecuados se edita el archivo de opciones con la orden desde la consola:

$ sudo gedit /etc/modprobe.d/options

y se agrega la siguiente linea al final del archivo:

options saa7134 card=63 tuner=47

Puedes instalar tvtime.

Hasta aquí valdría la pena ver si funciona la configuración reiniciando el sistema, y corriendo tvtime, tal vez sin sonido, para resolver esto solo un pequeño "truco hardware"(ja,ja,ja): conecte los parlantes a la salida de la tarjeta capturadora y listo, el defecto que queda con este método es que no puedo controlar el volumen hasta momento.

Otra posible solución para el sonido podría ser utilizar un cable con conectores "machos", para conectar la salida de sonido de la tarjeta capturadora con una de las entradas de la tarjeta de sonido (Puede usar la entrada del microfono o Line In, en teoría podría tener controlar el volumen). Creo que también se puede usar el comando arecord para hacerlo a nivel software.

Invito a los que tengan tarjetas de Tv a postear la salida del comando lspci | grep Multimedia y los parámetros card y tuner que están usando, de esta manera ayudar a configurar a los que todavía no han podido.

Saludos.

PD: Sé que lo que presento aquí no es nada innovador pero en verdad no encontré los parámetros adecuados en otros post, ni en páginas especializadas. Me gustaría tener opiniones de como puedo mejorar la configuración de esta tarjeta.

PD: Por el momento sólo me queda un problema de Hardware configurar la impresora Lexmark z1320, que la reconoce ubuntu pero no tiene drives para poder imprimir, por el momento imprimo desde una maquina virtual con el Inombrable...Bueno pero esa es otra historia para mi bitácora...

PD: Adjunto los archivos de configuración de tvtime que se encuentran en el directorio oculto .tvtime:

Archivo tvtime.xml:


<?xml version="1.0"?>
<!DOCTYPE tvtime PUBLIC "-//tvtime//DTD tvtime 1.0//EN" "http://tvtime.sourceforge.net/DTD/tvtime1.dtd">
<tvtime xmlns="http://tvtime.sourceforge.net/DTD/">
  <option name="WideScreen" value="0"/>
  <option name="DefaultBrightness" value="-1"/>
  <option name="DefaultContrast" value="-1"/>
  <option name="DefaultSaturation" value="-1"/>
  <option name="DefaultHue" value="-1"/>
  <option name="PrevChannel" value="50"/>
  <option name="Channel" value="50"/>
  <option name="FramerateMode" value="0"/>
  <option name="OverScan" value="3.5"/>
  <option name="CheckForSignal" value="1"/>
  <option name="AudioBoost" value="90"/>
  <option name="AlwaysOnTop" value="0"/>
  <option name="QuietScreenshots" value="0"/>
  <option name="UnmuteVolume" value="23387"/>
  <option name="Muted" value="1"/>
  <option name="V4LInput" value="1"/>
  <option name="V4LDevice" value="/dev/video2"/>
  <option name="VBIDevice" value="/dev/dsp"/>
  <option name="AudioMode" value="stereo"/>
  <option name="PalDKMode" value="0"/>
  <option name="FullScreen" value="0"/>
  <option name="Norm" value="NTSC"/>
</tvtime>


Puede cambiar video2 por video0 o video1 según sea el caso, así como dsp por ejemplo por vbi0.

Como el archivo stationlist.xml es largo, lo adjunto parcialmente:


<?xml version="1.0"?>
<!DOCTYPE stationlist PUBLIC "-//tvtime//DTD stationlist 1.0//EN" "http://tvtime.sourceforge.net/DTD/stationlist1.dtd">
<stationlist xmlns="http://tvtime.sourceforge.net/DTD/">
  <list norm="NTSC" frequencies="us-cable" audio="bg">
    <station name="1" active="1" position="1" band="US Cable" channel="1" finetune="0" norm="NTSC" audio="auto"/>
    <station name="2" active="1" position="2" band="US Cable" channel="2" finetune="0" norm="NTSC" audio="auto"/>
      .
      .
      .

    <station name="98" active="1" position="98" band="US Cable" channel="98" finetune="0" norm="NTSC" audio="auto"/>
    <station name="99" active="1" position="99" band="US Cable" channel="99" finetune="0" norm="NTSC" audio="auto"/>
  </list>
</stationlist>

Comentarios

Imagen de quaker

Buena informacion tendre que probarla para ver como va.

Pasate por aqui lo unico:http://www.ubuntu-es.org/index.php?q=node/87900

Es una guia para novatos,para hacer lo mismo que tu has puesto en tu bitacora,pero de manera mucho mas sencilla :D.

"Obtener informacion es el 1º paso hacia la sabiduria,pero compartir la informacion es el 1º paso hacia la comunidad"

Imagen de mmaca

Hola Quaker,

Si tu notas en el post que comentas sólo se edita el archivo /etc/modprobe.d/saa7134 para configurar la tarjeta, aquí para configurar la tarjeta sólo se edita el archivo /etc/modprobe.d/options. Para efectos prácticos modificar cualquiera de estos dos archivos conduce a lo mismo, especificar al modulo saa7134 los parámetros card y tuner.

La orden previa lspci | grep Multimedia sólo es para estar seguro que los parámetros aquí indicados le sirven a la correspondiente tarjeta, pues si no aparece los mismos mensajes se debe buscar los respectivos parámetros para card y tuner.

Como comente, no se trata de presentar un procedimiento innovador, pues este procedimiento aparece en cientos de post, se trata de mostrar los parámetros adecuados para tarjetas que tienen el chip Philips Semiconductors SAA7134/SAA7135HL y creo que la dificultad está en encontrar la combinación perfecta de card y tuner, que aunque aparece la información en un listado de los dos parámetros, el problema es encontrar dicha combinación.

Aclaro que la solución que presento es la que aparece a partir de "Y ahora sí manos a la obra:", todo lo anterior hace referencia a las vivencias que he tenido para configurar la tarjeta y no hacen parte de la solución.

Por lo expuesto anteriormente, no veo la diferencia (en cuanto la sencillez) entre lo que tu planteas en tu post y lo que planteo en esta bitácora. Básicamente es lo mismo, tal vez la diferencia está en que tu usas kaffeine y yo tvtime :)

Para terminar, reitero la invitación a postear la salida del comando lspci | grep Multimedia y los parámetros card y tuner.

SaLuDoS.

-o-o-

Si quieres lograr algo en la vida, no permitas que cualquier piedrita en el camino se te convierta en una gran muralla.


-o-o-

Si quieres lograr algo en la vida, no permitas que cualquier piedrita en el camino se te convierta en una gran muralla.

Imagen de quaker

La salida del comando,tengo una Avermedia dvb 777 y este es el chip

01:08.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)

ya pegare el de la pinncale 310i

"Obtener informacion es el 1º paso hacia la sabiduria,pero compartir la informacion es el 1º paso hacia la comunidad"

Imagen de m0nster

Para los que esta targeta no les da sonido doble click en el icono de sonido y habilitar la linea de entrada ademas en editar y luego preferencias y habilitar esto ademas subir el volumen y fijarse ke el altavos no este deshabilitado o en silencio

/quit

Imagen de areseo

Si luego de la solucion planteado anteriormente no da el sonido, lo que tienen q hacer es conectarlo en la parte trasera de la tarjeta de tv, ponen ahi los parlantes buscan uno de audio de salida y ia et!!! el sonido se hixo, pero el problema es q una ves q terminas de vr tv y quieres escuchar musica, te vas a dar cuenta de q no da!!!, en eso tienes q sacar los parlantes(el cable oviaente) y conectarlo en su lugar normal, es un truco q m costo aprender, iva 2 dias buscando tutoriales sobre esto, digo 2 dias porq en realidad es mas, bueno, tambien queria agradecer por este tutorial, porque fue el que mas me sirvio por el card y el tunes, ahora va mi pregunta, como se configura la radio??? eso es lo q quisiera saber, gracias

Imagen de DominicB

Estome sale en lspci | grep Multimedia:

03:02.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)

Al hacer escaneo desde la consola, me encontró muchos canales, pero al abrir tvtiem no muestra nada. tampoco hay sonido. Tengo una Kworld Plus Tv 71134SE y encontré que debía usar:

card=59 tuner=56

Lo saqué de

... ¿Algún consejo?

Imagen de iWagner

Perdonen mi ingnorancia, soy nuevo en esto de ubuntu, ya instale en mi equipo la version 10.10 y me gusta mucho todo este sistema.

Mi problema es que tengo una capturadora Philips Semiconductors SAA7134 y no puedo utilisarla, y no se como introducir codigos... es posible que exista una aplicacion que se pueda instalar por medio de (Centro de software de Ubuntu)?....

Les agradesco mucho la ayuda que me puedan dar....

Imagen de alonso1974

Hola tengo mas de 1 año tratando de poner dicha tarjeta e leído cualquier cantidad de foros y nunca la pude ponerla a trabajar la tenia guardada en un cajón hasta que leí tu bitácora y que paso ya tengo tv en mi ubuntu querido.
Muchas gracias..

Imagen de vhs95

Esta guia es muy buena en versiones de ubuntu hasta la 12.04.

en 13.04 cambia un poco la lectura de los archivos .conf
http://linuxtv.org/wiki/index.php/KWorld_Studio_TV_Terminator

en teoria ya no se reconocen estos archivos sin el .conf al final

hice la modificaciones y no funciono....
ideas?

saludos

Imagen de jorgecaso

La guía es muy buena, Mi Ubuntu es 13.04 y funcionó perfectamente, la uso desde la versión 9.04 sin problemas.
Gracias por el aporte, saludos.

Jorge Caso.