iwlist wlan0 scan salida ! wlan0 No scan results ¡

Imagen de Energy1011
0 puntos

Hola , tengo ubuntu 7.10 gutsy en una p4 2.0ghz lo que quiero hacer es escanear redes wifi y no me da resultado

datos de la tarjeta pci que instale :

ENCORE electronics 802.11g wireless pci adapter ENLWI-G2

sudo lspci

<code>

00:00.0 Host bridge: VIA Technologies, Inc. P4M266 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1b)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1b)
00:11.4 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1b)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 30)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 70)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)

</code>

sudo iwconfig

salida:

<code>

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g Mode:Managed Frequency=2.447 GHz
Access Point: Not-Associated Bit Rate:11 Mb/s
Retry:on Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
</code>

buscado drivers y encontre este

http://www.encore-usa.com/product_item.php?region=us&bid=2&pgid=4&pid=285

lo descarge y lo intente instalar de la siguiente manera como viene en su archivo readme

./makedrv

salida:

<code>

make[2]: *** [/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/ieee80211/ieee80211_softmac.o] Error 1
make[1]: *** [_module_/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/ieee80211] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-386'
make: *** [modules] Error 2
rm -f *.mod.c *.mod *.o .*.cmd *.ko
rm -rf /home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/tmp
make -C /lib/modules/2.6.22-14-386/build M=/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1 CC=gcc modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-386'
CC [M] /home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.o
In file included from /home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:61:
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180.h:29:26: error: linux/config.h: No such file or directory
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c: In function ‘rtl8180_rx’:
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:2080: warning: implicit declaration of function ‘rdtsc’
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:2953:67: error: macro "INIT_WORK" passed 3 arguments, but takes just 2
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c: In function ‘rtl8180_init’:
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:2953: error: ‘INIT_WORK’ undeclared (first use in this function)
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:2953: error: (Each undeclared identifier is reported only once
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:2953: error: for each function it appears in.)
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:3276: warning: ‘deprecated_irq_flag’ is deprecated (declared at include/linux/interrupt.h:66)
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:3276: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c: In function ‘rtl8180_pci_probe’:
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:4031: error: ‘struct net_device’ has no member named ‘get_wireless_stats’
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c: In function ‘rtl8180_pci_module_init’:
/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.c:4156: warning: implicit declaration of function ‘pci_module_init’
make[2]: *** [/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1/r8180_core.o] Error 1
make[1]: *** [_module_/home/energy/Desktop/rtl8185_linux_26.1010.0531.2006/rtl818x-0.1] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-386'
make: *** [modules] Error 2

</code>

no encontre solucion a este error y foreando encontre NDISwrapper

y lo baje de sourceforge para probar

ndiswrapper-1.52.tar.gz

al leer el manual de instalacion vi los prerequisitos :
<code>

Prerequisites
=============

You need a recent kernel, at least 2.6.6 or 2.4.26, with header files
for the kernel. Make sure there is a link to the kernel source from
the modules directory. The command

ls /lib/modules/`uname -r`/build

should have at least 'include' directory and '.config' file.

</code>

al hacer

uname -r

salida :
<code>

2.6.22-14-386

</code>

logre instalar el ndiswrapper y baje los drivers de la misma pagina que abje para linux pero ahora para version 98/xp de windows para instalarlos con ndiswrapper

ya instalados

sudo ndiswrapper -l

salida:

<code>

net8185 : driver installed
device (10EC:8185) present (alternate driver: r8180)

</code>

sudo modprobe ndiswrapper

cargo el modulo y no me da salida ( no se si sea normal esto)

sudo ndiswrapper -m

salida:

<code>

module configuration already contains alias directive
</code>

 

y bien , mi pregunta es ¿ tengo algo mal? no tengo mucha experiencia con redes wifi ..

 

¿ porque no escanea redes wifi a la redonda siendo que estoy seguro que si existen redes activas ?

iwlist wlan0 scan

salida:

<code>

iwlan0 No scan results

</code>

instale tambien el programa de wifi-radar pero no veo opcion para hacer un escaneo..

cualquier ayuda es buena gracias...

Imagen de krpalospo
+1
0
-1

Yo tuve exactamente el mismo problema cuando configuraba la tarjeta todo iba perfecto pero cuando hacia un scan no funcionaba decia que no habian resultados, despues cuando iba a intentar conectar dejaba de funcionar despues de un tiempo y al llegar a la conclusion de que el problema no era wpa movi mi computadora cuando hice eso empezo a detectar las redes cercanas espero que te sirva ...

+1
0
-1
Imagen de robertolaiz
+1
0
-1

A mi me pasa exactamente lo mismo, tengo mi tarjeta instalada mi salida de sudo iwconfig es:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Y Sistema-->Administración-->Red me sale la opción de configurar redes inalámbricas. He instalado wifi radar, pero no encuentra niguna red inalámbrica y estoy seguro de que la hay, tanto como que la configuré yo.

+1
0
-1
Imagen de firewall27
+1
0
-1

El problema es la compatibilidad del puto windows mundial, con linux que no lo conoce nadie y por ende son pocos los fabricantes que gastan tiempo en este s.o

Ese programa es muuuy malo la verdad, tiene mil millones de vueltas, fijesen ustedes todos los problemas que da, OBVIAMENTE ESTA LA PERSONA QUE DICE.. : YO NUNCA TUVE PROBLEMAS.. Realmente SON MUY POCAS!!!
Yo tengo los mismos problemas, y lo soluciono reiniciando el s.o porque aparentemente, reiniciando el modulo ndiswrapper junto con el, /etc/init.d/networkin sigue sin funcionar.

Proba borrando todo lo que instalaste, e instalar el driver con el programa ndisgtk, me dio mejores resultados.

Los que tiene ethernet no saben lo que se siente, pero realmente es para llorar, porque uno no quiere volver a la inseguridad del puto windows, pero realmente, linux.. ES DURO ADMITIRLO, es un buen s.o por el lado de que no tiene virus, pero realmente inestable y hace 2 años que lo uso asi que yo se de que hablo.
Piensen esto: Si en windows no hubieran virus, seria el mejor S.O, porque son pocas las aplicaciones que se cuelgan sinceramente, y mayormente se cuelgan por los virus.
La realidad es dura, pero yo tuve y tengo mas dolores de cabeza con linux que con win, pero soy masoquista y sigo en este s.o porque tambien digo, que una vez que quedo todo andando bien, SI NO SE TOCA NINGUNA CONFIGURACION POSTERIORMENTE!!! funciona de 10.
Personalmente, tengo la esperanza de que el S.O evolucione pero todo depende de nosotros, de usuarios comunes, porque las empresas importantes, no van a gastar su tiempo en crear controladores para linux sobre los hardware que producen, son muy pocas las que lo hacen.
Pero gracias a windows como, porque yo soy tecnico de PC jajaja
Bueno disculpen esta reflexion que no tiene intenciones de ofender a nadie, simplemente es el punto de vista de UN usuario de linux, no digo que lo que yo digo es la verdad.
Saludos! :)

+1
0
-1