El grub no detecta un sistema operativo

Imagen de xuxo
0 puntos

He instalado:

1º Xp
2º Leopard 10.5.2
3º Ubuntu 7.10

Tambien he editado el fichero menu.lst y he escrito:

title Leopard
root (hd0,7)
makeactive
chainloader +1

Nota:he puesto (hd0,7) porque al hacer fdisk -l he visto que leopard estaba en la particion sda8 que en la notacion del grub creo q es (hd0,7).

Pero el grub no me detecta el leopard.Cuando seleciono la entrada Leopard que he creado en el menu del grub sale el error:
Error 12:Invalid device requested

Imagen de jprdo77
+1
0
-1

hola xuxo no has intentado en reinstalar el grup de nuevo, existe un fichero (iso) para hacerlo, yo lo tengo en mi pc, es de 3Mb mas o menos.

+1
0
-1
Imagen de xuxo
+1
0
-1

Si,como ya he dicho ubuntu lo he instlado en ultimo lugar.Ademas volvi a reintalar el grub varias veces.

+1
0
-1
Imagen de jprdo77
+1
0
-1

Prueba con comentar #Leopard 10.5.2, para ver si es el que te está dando bateos, y saber donde radica el problema, yo tengo xp y ubuntu en varios ordenadores no exite problemas con eso.

+1
0
-1
Imagen de luchobarrios
+1
0
-1

hola a todos, necesito saber como hacer para redetectar las particiones en el disco.
Yo tengo actualmente instalado y funcionando ubuntu-server, con un minimalista entorno grafico de kde; luego volvi a instalar ubuntu-server, pero en otra particion. Durante la instalacion salio todo bien, salvo por el paso en el que hay que instalar GRUB en en disco principal. Por alguna razon me dio error, y no se como arreglarlo.
Les cuento que anteriormente, en esa particion donde acabo de instalar ubuntu-server, estuve haciendo una clonacion de particion, que me dio error, ya que pòr accidente quite el pendrive desde el cual estaba ejecutando G4L. Y como ya di por perdido windows (no me interesa recuperarlo) instale sobre esta, ubuntu-server nuevamente.

Resumiendo:
Tengo 2 instalaciones de ubuntu-server. de las cuales, solo puedo bootear una sola. y quisiera que de alguna manera, el S.O. me redetectara los sistemas que tengo instalado y me reinstale GRUB como corresponde.

¿sera eso posible?

+1
0
-1
Imagen de jprdo77
+1
0
-1

trata de ver si el GRUB esta correctamente instalado, si te muestra el grub solo debes modificar el fichero /boot/grub/menu.lst

## array will desync and will not let you boot your system.
default 0

en 0 debes poner la partición que quieres arrancar...

suerte

+1
0
-1