wifi atheros en ubuntu 8.04 y 8.10, problemas (Solucionado)

Imagen de gilber1988
0 puntos

en ubuntu 8.04 y 8.10 el sistema reconoce aparentemente la tarjeta atheros AR242x 802.11abg ,el gestor de controladores dice que esta instalada y en uso, pero al momento de ver si hay redes inalambricas no aparece nada, es mas en network manager no aparece la opcion de redes inalambricas.

La unica forma de que me funcione es utilizando NDISwraper (controladores de window$).

Si alguien sabe como hacer que funcionen correctamente sin nececidad de Ndiswraper, le agradeceria que publicara como hacerlo.

LA SOLUCION

la solucion fue desinstaR ndiswraper y desactivar controladores privativos y Puff!! funciono prefectamente y a pesar de actualizar kernel en 8.10 sigue funcionando perfectamente

Imagen de jorgemanjarrezlerma
+1
0
-1

Que tal gilber1988

Mira, yo tengo la misma wifi atheros y cuando instale intrepid beta no me la detectó. Lo que hice en un principio fué deshabilitar el controlador en sistema, administración, dispositivos de hardware, reinicié y funcionó a la perfección. El gusto me duró poco ya que al estar actualizandose el kernel esta facilidad se perdió, por lo que opté por madwifi. Hasta este momento se han bajado un par de actualizaciones del kernel y sigue funcionando perfectamente bien. Yo en lo personal te recomiendo madwifi ya que funciona de manera "nativa" y hay ciertas prestaciones que no funcionan bien con ndiswraper.

El controlador lo puedes descargar del site de madwifi en formato tar.gz, lo descomprimes lo compilas (recuerda instalar build-essential) y los instalas. Debes tener deshabilitado el controlador que trae la distro y una vez que instales el de madwifi, lo reactivas y reinicias la pc.

Cabe menconarse que esta solución tiene mucho tiempo en los foros por lo que te recomiendo efectues una búsqueda. No se trata de no ayudar pero la verdad si investigas un poco te darás cuenta de la inmensa cantidad de información disponible que puede ayudarte en muchas de las dudas que pudieses tener.

Que estes bien

Atentamente
Jorge Manjarrez Lerma
Consultor en TI

+1
0
-1
Imagen de gilber1988
+1
0
-1

La verdad alguna vez intente usar madwifi pero no me funciono, por eso no mire mas esa opcion, pero si me dices que funciona lo voy a intentar otra vez, el problema con ndiswraper es que se pierde con facilidad la coneccion, te agradeceria que me dejaras el link exacto con el controlador que usas.

"funciona de manera "nativa" y hay ciertas prestaciones que no funcionan bien con ndiswraper."
A que prestaciones te refieres?

Con respecto al bluetooth y wifi, me presento fallos al activarlos ala vez, no se que tipo de conflicto se presente, pero cuando en servicion activo el bluetooth, el wifi me presenta muchas fallas y a veces no funciona, en el mismo laptop (toshiba A305d 6801), deje una pequeña (muy pequeña :) ) particion con el win vista que venia instalado por defecto, cuando le activo el bluetooth sale un aviso diciendo que desactivara el wifi para evitar posibles interferencias, por eso es que tengo la duda soble el manejo ala vez de estos dos dispositivos.

Gracias

+1
0
-1
Imagen de jorgemanjarrezlerma
+1
0
-1

Que tal gilber1988

Antes que nada una disculpa por contestar hasta hoy pero estaba fuera de la Cd. y el trabajo no me dejo mucho tiempo para darme una vuelta por la red. Te paso un link de este mismo foro ()donde se intruye paso a paso que hacer o bien si quiers hacer la descarga directamente (el link es: ).

Recuerda que para cualquier modoficación que realices a los controladores deberás de tener actualizado el sistema e instalado los build-essential.

Espero te sea de utilidad.

Un cordial saludo y que estés bien

Atentamente
Jorge Manjarrez Lerma
Consultor en TI

+1
0
-1
Imagen de jorgemanjarrezlerma
+1
0
-1

Que tal gilber1988

Disculpa pero parece ser que el comando de inserción de enlaces o links no funciona bien y va de nuevo.

Te paso un link de este mismo foro (http://ubuntuforums.org/showpost.php?p=5577447&postcount=13)donde se intruye paso a paso que hacer o bien si quiers hacer la descarga directamente (el link es: wget http://snapshots.madwifi.org/madwifi-hal-0.10.5.6/madwifi-hal-0.10.5.6-r...).

Recuerda que para cualquier modoficación que realices a los controladores deberás de tener actualizado el sistema e instalado los build-essential.

Espero te sea de utilidad.

Un cordial saludo y que estés bien

Atentamente
Jorge Manjarrez Lerma
Consultor en TI

+1
0
-1
Imagen de mmaarrccoo
+1
0
-1

hola, te cuento que yo habia logrado solucionar los problemas con la placa atheros utilizando madwifi en 8.04 (aqui tienes los pasos que segui en mi blog: http://sleeplessmonkey.wordpress.com/2008/10/06/ubuntu-y-wifi/), pero una de las actualizaciones de la beta ha hecho que dejen de funcionar.
intente instalar la ultima version por svn pero parece no solucionar el problema, espero también algun consejo

saludos :D

+1
0
-1
Imagen de gerryto00
+1
0
-1

hola, mira yo actualize desde ubuntu 8.04 y la primera vez que lo hice me frego el sistema, pero ahora hoy termine la actualizacion y todo salio bien, dsed la tarjeta nvidia aunque sale de nuevo lo de los restrictivos... y a lo de la tarejta atheros, bueno segui los siguientes pasos, aunque no elimine los modulos... espero te funcione pues yo despues de la actulazacion el modulo 24 paso al 27 pero creo este link te servira.

http://www.ubuntu-es.org/index.php?q=node/99450

saludos.

+1
0
-1
Imagen de trasnos
+1
0
-1

He seguido las instrucciones de:
http://elteclado.wordpress.com/2008/11/02/instalando-wifi-atheros-ar242x...

y estoy conectado saludos

+1
0
-1
Imagen de anandica
+1
0
-1

saludos

Yo instale Ubuntu hardy, y no me iba bien, de echo al final termine comprandome un Pendrive Wifi Usb, por que ya estaba cansado de hacer una cosa y otra, para que al final no me funcionase nada.

Ahora cuando actualice a Intrepid, me pico otra vez el gusanillo, ya que al parecer Atheros se habia decidido por fin a dar drivers para linux.

He seguido durante dias las instruciones tanto de este sitio, como de otros de gran solvencia, y lo unico que he conseguido ayer a las dos de la madrugada es que durante el tiempo que tarde en einiciar mi equipo, tubiera wifi por dos canales, uno por el pen wifi, al 65 %, y el otro de la tarjeta atheros de mi Compaq c700, y este al 100%, pero al reiniciar lo he perdido todo, no solamente todo lo que hice, sino que ahora voy a consultar los controladores de terceros y !!! maravillas no me aparece nada ¡¡¡, ya ni siquiera tengo el controlador para tarjetas para atheros ar242x800....etc...etc....

Necesito ayuda, por que no soy capaz ni con madwifi, ni con ndiswraper, y algo tan sencillo como lo que dice al principio de este foro:
LA SOLUCION

la solucion fue desinstaR ndiswraper y desactivar controladores privativos y Puff!! funciono prefectamente y a pesar de actualizar kernel en 8.10 sigue funcionando perfectamente

Gracias anticipadas

+1
0
-1

saludos