Instalacion de Flash Player en Procesadores de 64 Bits

Imagen de cesarego
0 puntos

Despues de tanto batallar lo he logrado, espero que tambien les sirva.

Para instalar Flash en Firefox utilizando nspluginwrapper, primero necesitamos descargar el plugin de Adobe. Una vez descargado el plugin, instalamos el paquete nspluginwrapper:

sudo apt-get install nspluginwrapper

Una vez instalado, abrimos el archivo comprimido y extraemos el archivo libflashplayer.so. Ahora lo movemos a la carpeta /usr/lib/mozilla/plugins/:

sudo mv Directorio_de_Descarga /libflashplayer.so /usr/lib/mozilla/plugins

Ahora sólo falta utilizar el paquete nspluginwrapper:

/usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so

Ahora reinicia Firefox y funcionará el Flash.

Imagen de kelp
+1
0
-1

Por favor utilizad el foro de tutoriales y trucos, las bitácoras no son para publicar tutoriales.
Te lo muevo, tenlo en cuenta la próxima vez.


Equipo de Ubuntu-es
+1
0
-1

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de kikeh
+1
0
-1

Sigo todos estos pasos.. y van bien.. hasta el último.. al ejecutar el NSPluginWrapper.. me sale el siguiente mensaje:

*** NSPlugin Viewer *** ERROR: libnss3.so: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/mozilla/plugins/libflashplayer.so

¿qué puede ser?

Gracias,

Kike

+1
0
-1
Imagen de LolaMora
+1
0
-1

Dejo este comentario por si alguien llega aqui con el siguiente error despues de ejecutar el tutorial de arriba:

*** NSPlugin Viewer *** ERROR: libnss3.so: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/mozilla/plugins/libflashplayer.so

Lei en un foro ejecutar la siguiente instruccion:

sudo apt-get install ubuntu-restricted-extras

Despues de un rato de estar instalando los paquetes restringidos, reinicié la PC por las dudas.
Ahora funciona todo lo referente a sonido, plugins y videos a la perfección. Abre links a radios, canales de television con audio e imagen. En fin: arreglado!!!

 

_________________________________________________________________________

Hasta la victoria siempre...

+1
0
-1

 

_________________________________________________________________________

Hasta la victoria siempre...

Imagen de frankarrell
+1
0
-1

Hola!! soy nuevo en esto y uso ubuntu 10.04 LTS 64 bits... me dió el mismo error con el paquete nspluginwrapper...... pero ejecutando

sudo apt-get install ubuntu-restricted-extras los problemas desaparecieron una vez reiniciado mi navegador!!!

excelente... MUCHAS GRACIAS!!!

+1
0
-1

FRANK

Imagen de diazjavier10
+1
0
-1

Me funcionó perfectamente en Ubuntu 8.04_64 sobre un Athlon x2 64 (1.9GHz)
Muchas gracias cesarego por compartir tu experiencia, me ha sido de gran ayuda.

+1
0
-1
Imagen de hitokiri_red
+1
0
-1

Ya hay soporte nativo de flash para 64 bits:
http://labs.adobe.com/technologies/flashplayer10/releasenotes_64bit.html

-----------------------------------------------------------------------------
GCS/E@ d- S: a-- c++$ UL++>$ P L++ E--- W++ N?
o? K- w++(+)>$ O? M? V? PS+++ PE-- Y+ PGP? !t
!5 !X R tv b++ DI+++ D+ G++ e++ h! r z++
--------------

+1
0
-1

-----------------------------------------------------------------------------
GCS/E@ d- S: a-- c++$ UL++>$ P L++ E--- W++ N?
o? K- w++(+)>$ O? M? V? PS+++ PE-- Y+ PGP? !t
!5 !X R tv b++ DI+++ D+ G++ e++ h! r z++
----------------

Imagen de fdefreitas6
+1
0
-1

Muchas Gracias amigo! Me funciono perfecta e inmediatamente. Tengo Ubuntu 8.10 de 64 bits corriendo sobre un Core 2 Duo T9300 por si acaso alguien con ese mismo procesador quiere intentarlo, funciona perfectamente.

Gracias de nuevo.

Saludos.

+1
0
-1
Imagen de 1DHk
+1
0
-1

todo me salio muy bien pero a la hora de copiar el "libflashplayer.so" a la carpeta de plugins me sale un error diciendome "permiso denegado, yo soy el administrador asi que por eso no estiendo como no puedo copiarlo si me pueden ayudar se los agradeceria.

Jaunty Jackalope Ubuntu 9.04 64 bits

+1
0
-1
Imagen de ddavito
+1
0
-1

bueno realice el tutorial muy bien, con la diferencia q tuve que instalar nspluginwrapper desde synaptic despues todo normal.
uhmm ahora leyendo los commentarios eh visto que ya salio en adobe soporte para 64bits, mi duda era que si es mejor intalarme el que esta en la pag de adobe ( si es asi como desisntalo el que tenia) o me quedo con el que instale ya espero me hayan entendido gracias

soy nuevo en Linux (ubuntu)

+1
0
-1
Imagen de elviclozano
+1
0
-1

Hola a todos, les dejo un script para instalar automaticamente el flash player 10.
Guarden el archivo con la extension .sh y luego asignenle permisos de ejecucion.
Si tiene dudas, por favor diganme para ayudarles.
- - - - - - - - - - - - - - - - - - - - - - - - - - - -
#!/bin/bash
# Based on a script created by
# Romeo-Adrian Cioaba romeo.cioaba@spotonearth.com
# Actualizado por Victor Manuel Lozano para usarse en Adoble Flash Player 10 # for GNU/Linux 64 bits. November 4, 2009.
# Released under GPL

echo "Closing Firefox"
sudo killall -9 firefox

echo "Removiendo instalaciones previas de Flash"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper

wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10....

tar zxvf libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

echo "Enlazando librerias de manera que firefox pueda verlas"
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/
read

echo "Terminado :-)"
echo "Ahora debes de iniciar el Firefox"

+1
0
-1

Trust in God

Imagen de jinglada
+1
0
-1

Muchas gracias. Estaba loco con el dichoso flash en Firefox. Lo he ejecutado manualmente y sólo me ha dado la siguiente 'disconformidad':
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/mozilla/plugins/
ln: «/usr/lib/mozilla/plugins/libflashplayer.so» i «/usr/lib/mozilla/plugins/libflashplayer.so» són el mateix fitxer (son el mismo fichero)

Pero funciona bien. ¿Debo cambiar algo? ¿A lo mejor esa instrucción debia ser:
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox/plugins/?

¿No falta
sudo rm -f /usr/lib64/mozilla/plugins/*flash*
y después
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib64/mozilla/plugins/?

¿O no es necesario ya que el directorio lib64 es un espejo del lib?

+1
0
-1
Imagen de 3mpe
+1
0
-1

Tu Script Funciona Muy Bien, Gracias Por el aporte, me sirvio de mucho!!!

+1
0
-1

Mi Existencia Es La Justificacion De Todos Mis Actos

Imagen de roach6891
+1
0
-1

muy bien el tutorial excelente me funcionó al 100% el único detalle es que la ruta donde se descomprime el plugin es diferente (bueno eso fue en mi caso) está en /usr/lib64/mozilla/plugins
en lugar de /usr/lib/mozilla/plugins pero igual me funcionó
muchas gracias!

+1
0
-1
Imagen de marcogo50
+1
0
-1

Hola me funciona muy bien, segui los pasos mencionados y funciona perfecto, gracias.
Tengo Mandriva lINUX 2009.1

+1
0
-1
Imagen de VIsp
+1
0
-1

He seguido exactamente los pasos y todo funciona perfectamente.

Ubuntu 9.10 - 64 bits :)

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

~$ /usr/lib/nspluginwrapper/x86_64/linux/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so
nspluginwrapper: /usr/lib64/mozilla/plugins/libflashplayer.so is not a valid NPAPI plugin

bajé el tar de Adobe, extraí el archivo, lo moví, lo quise configurar y esto salió.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de AdrianT
+1
0
-1

Despues de haber tratado de muchas formas porfin consegui que funcionara y segui los siguientes pasos:

1.-
aptitude install fakeroot binutils nspluginwrapper ia32-libs

2.-
Hay que bajar y correr este sript http://people.debian.org/~bartm/flashplugin-nonfree/ia32-libs-workaround...

3.-
dpkg -i ia32-libs-workaround-499043_0.0.1+lenny1_amd64.deb

4.-
Por ultimo instalar este paquete http://people.debian.org/~bartm/flashplugin-nonfree/flashplugin-nonfree_...

Informacion de http://wiki.debian.org/FlashPlayer

+1
0
-1
Imagen de meve
+1
0
-1

Yo seguí los pasos del primer post y me salio a la primera en ubuntu 10.04 LTS 64 bits con un althlon de 64 bits.

Sin mover nada ni cambiar nada del post original.

Gracias mil.

+1
0
-1

Tabasco los saluda

Imagen de jada00
+1
0
-1

la verdad que soy nuevo Linux Ubuntu 64... tanto había escuchado hablar de este sistema mmmmm la verdad que me decepciono.. por ejemplo haces horas que trato de instalar flash player y no hay caso, probé en Firefox y en chromium y nada.. esta todo tan oculto donde están los archivos de configuración???por mas que bajo el plugin no se instala... quizás este sistema tiene cosas buenas... pero falta mucho para que usuarios novatos no tengan que quebrase la cabeza tratando de dejarlo todo a punto, si bien los foros hablan del tema pero con tantos tecnicismos propio de linux... una lastima, tendré que volver a Windows 7

+1
0
-1