interfaz usb de sonido behringer uca200

Imagen de brunoMasterMixer
0 puntos

Hola a todos, yo acabo de dar el gran paso de cambiar todo mi sistema operativo de xp a nuestro grandioso ubuntu 8.10, sin embargo se me estan presentando varios problemas para mi trabajo de edicion de audio ya que aun no entiendo como configurar el audacity pero en fin el verdadero problema es el siguiente:
yo uso una mixer behringer para grabar a mi laptop y la conecto con una inteface usb behringer uca 200, que convierte el sonido analogo a digital por medio de conexion USB pero simplemente cuando lo conecto no lo reconoce o en todo caso no se como activarlo.
Esto es para mi importantisimo para continuar con mi trabajo en mi laptop.
alguien me puede ayudar con esto?
muchisimas gracias

Imagen de Pablo_F
+1
0
-1

A ver si te la reconoce,
Escribe en terminal y pega aquí el output de:

lsusb

cat /proc/asound/cards

cat /proc/asound/modules

A partir de ahí, se podrá investigar mejor.

Saludos

Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de brunoMasterMixer
+1
0
-1

Hola, bueno aplique los comandos y me salio lo siguiente:

bruno@DJMixer:~$ Isusb
bash: Isusb: orden no encontrada
bruno@DJMixer:~$ cat/proc/asound/cards
bash: cat/proc/asound/cards: No existe el fichero ó directorio
bruno@DJMixer:~$ cat/proc/asound/modules
bash: cat/proc/asound/modules: No existe el fichero ó directorio
bruno@DJMixer:~$

gracias por la ayuda

+1
0
-1
Imagen de sergiosan00709
+1
0
-1

El comando para ver el listado de componentes Usb es LSUSB... Pero en minusculas. Osea lsusb, no ISUSB como tu pones. Osea no va con I. Una vez puesto el comando, copialo y pegalo para poder ver si reconoce a tu mixer o no.

Ahora en las otras indicaciones o comandos, al comienzo hay un espacio entre CAT y el resto de la linea osea es:

cat(espacio)/proc/asound/modules Osea va un espacio despues de cat para que quede: cat /proc/asound/modules igual con el otro

+1
0
-1


Viewsonic 22", 8Gb de Ram Kingston, AMD Phenom X4, 2 multiquemadoras LG, 2 Nvidia Gforce 9600GT en SLI, 2 HDD de 250GB c/u,Mainboard Gigabyte GA-M57SLI-S4, Case COSMOS de Cooler Master.

Imagen de brunoMasterMixer
+1
0
-1

Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 08bb:2902 Texas Instruments Japan
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
bruno@DJMixer:~$
bruno@DJMixer:~$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_usb_audio
bruno@DJMixer:~$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_usb_audio
bruno@DJMixer:~$ cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xc0000000 irq 16
1 [default ]: USB-Audio - USB Audio CODEC
Burr-Brown from TI USB Audio CODEC at usb-0000:00:13.0-1, full s

Al parecer lo detecta y en las opciones de audio aparece un dispositivo usb, pero lo selecciono y no suena

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Con esa información puedes entrar a google y verás información interesante. Yo creo que esto aplica a tu caso:

Edita como administrador el archivo /etc/modprobe.d/alsa-base, poniendo en la terminal:

sudo gedit /etc/modprobe.d/alsa-base

(Truco para evitar errores tipográficos en los comandos: Abre terminal, selecciona la línea de arriba con el botón izquierdo y "déjala caer" en la terminal con el botón central)

Busca la línea :

options snd-usb-audio index=-2

y coméntala, esto es, ponle una almohadilla delante, de forma que quede:

# options snd-usb-audio index=-2

Guárda el archivo y ciérralo.

Tu dispositivo hw:0 es la tarjeta integrada y tu dispositivo hw:1 es tu tarjeta usb genérica, en este caso la uca200.

Para controlar los niveles te tienes que conformar con alsamixer, no sé cómo andará para esa tarjeta, pero es lo que hay.

alsamixer -Dhw:0 para controlar los niveles de tu tarjeta integrada
alsamixer -Dhw:1 para la USB

Pruébala primero con la configuración de sonido de gnome, para playback.

Si te funciona ahora (elige driver alsa), has dado el primer paso que es el más importante.

Si quieres usarla para grabar, supongo que estás en ubuntustudio, la mejor opción es el servidor de sonido de baja latencia y conectividad flexible entre aplicaciones, jack (Jack control en el menú de sonido). Ojo al setup, si tienes problemas pregunta o busca por ahí.

Saludos

Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de brunoMasterMixer
+1
0
-1

Gracias por la ayuda, bueno aplique lo que me dijiste al pie de la letra pero sigue sin sonar? reinicie la sesion pero aun asi no suena, estas son las opciones que me salen para seleccionar:
usb audiocodec (alsa mixer) imagino q era a este al cual te referias
y la que uso normal para controlar es:
HDA ATISB (alsa mixer).

Entendi que seleccionando la primera "usb audiocodec (alsa mixer)" funcionaba pero no sonaba, o es que debo hacerlo de otra manera?
gracias por toda la ayuda.

+1
0
-1
Imagen de Pablo_F
+1
0
-1

No me expliqué bien. En Sistema-> Preferencias-> Sonido, elige alsa en todas las casillas, en lugar de default, y en el dispositivo, elige usb audiocodec (alsa mixer), vale.

Ahora, vuélvete a asegurar que la Behringer es la número 1:

cat /proc/asound/cards

Y si efectivamente es la 1 (la segunda que aparece, ya que la primera es la 0), teclea en la terminal:

alsamixer -Dhw:1 (si es la 0 sería lo mismo con un 0 en lugar de un 1)

Y espero que tengas acceso a los niveles de conversión A/D y D/A de tu tarjeta, puede que los veas como ADC y DAC. Las salidas son los DAC, puede que los tengas a cero? Con suerte, esto sólo lo tendrás que hacer una vez, deja los niveles entre 60 y 80, bueno, ya cogerás tú el nivel ideal, pero déjalos fijos, no uses alsamixer como mezclador, para eso ya tienes tu mezcladora.

Ahora otra cosa, a tener en cuenta:

Para que las tarjetas tomen números de dispositivo fijos, ya que a veces ocurre que se cambian de número al arrancar el ordenador, tienes dos opciones:

1) Si vas a utilizar la tarjeta de sonido integrada:

sudo gedit /etc/modprobe.d/alsa-base

Y añade al final las líneas:

alias snd-card-0 snd-hda-intel
options snd-hda-intel index=0
alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1

2) Si no la piensas utilizar para nada (siempre que la usb te llegue a funcionar, claro está):

Deshabilítala desde la BIOS

Espero haberte ayudado. Saludos

Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de brunoMasterMixer
+1
0
-1

Si mira ya funciona el audio seleccione esta opcion para que todo sonara
Burr-Brown from TI USB Audio CODEC
ahora estoy investigando para ver como hago para captar el sonido, si tuvieras alguna recomendacion te lo agradeceria mas de lo que ya has hecho
Espero que este foro le sirva a alguien mas.
Gracias

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Como pasa siempre en Linux, el abanico está tan abierto y la información tan difusa, que sólo el enterarse de cuál es la aplicación mejor adaptada a tus necesidades puede ser un pequeño problema. Hay un montón de aplicaciones con las que puedes capturar audio, depende de lo que quieras hacer. En los foros de ubuntustudio seguro que encuentras información. Musix es otra distribución de Linux basada en Debian y orientada a la producción multimedia, al igual que 64studio. Hay otras como JACKLAB, Planet CCRMA, que también son Linux, aunque no derivadas de Debian. En sus foros y tutoriales también puedes encontrar cantidad de información útil. Otro foro y wiki interesante para gente haciendo música en Linux es www.linuxmusicians.com. En castellano no encuentras tanta información como en inglés.

Ahora que ya sabemos que alsa conoce tu tarjeta de sonido el siguiente paso, si te interesa la grabación y producción de música, es que te funcione JACK.

JACK es un servidor de sonido que consigue baja latencia y una interconectividad superflexible entre hardware y programas. Gracias a Jack puedes suplir la falta de un estudio de grabación completo para Linux (de momento), lanzando varias aplicaciones MIDI y audio, racks con plugins, reproductor de música... e interconectarlos entre ellos. Busca en internet y tendrás mejor información sobre qué es JACK exactamente.

Jack se lanza desde el menu, Jack Control, o desde terminal, qjackctl. Ojo, una vez que arrancas Jack, alsa sólo le responde a él. De forma que si quieres escuchar música con Rythmbox o desde internet etc, no vas a poder. Yo cuando uso el ordenador para escuchar música o navegar por internet jack está parado. Si hago trabajo de grabación o producción, entonces, jack es indispensable para mí.

Osea, que lo primero es tener jack funcionando de forma estable, lo cual no es tarea tan fácil. Como no te funcione a la primera y no sepas muy bien lo que hagas, te puedes volver un poco loco. Para editar la configuración, botón setup

El consejo, como siempre, es: Ante la duda, opción por defecto.
Por el resto:

En la columna de la derecha, arriba, elige el interface deseado. Con la flechita podrás ver tus dos tarjetas. La tuya, si no has deshabilitado la integrada y has fijado su orden como te comenté, es la hw:1.

Con un poco de suerte, con esto ya te funcionará jack de forma estable. Verás la latencia resultante con ese setup. Para bajar la latencia baja el valor de frames/period, bájala paso a paso, hasta que consigas un valor de latencia aceptable que no t eprovoque xruns. También puede que quieras modificar el sample rate, aunque 44100 es OK para audio, también puedes ir a 48000 con tu tarjeta. No modifiques el valor de periods/buffer. En todo caso, y sólo si no te funciona, pónlo en 3 (algunas tarjetas usb y con algunas versiones de jack funcionan con periods=3 con algunas versiones de jack, no estoy seguro si aplicará en este caso).

Una vez que tengas Jack funcionando, puedes grabar de varias formas. Audacity está bien para empezar, aunque está más orientado a editor de audio que a estudio de grabación. En Edición-preferencias, elige el dispositivo jack para captura y reproducción. En calidad, elige la frecuencia de muestreo que hayas elegido en jack. Audacity va a conectar las entradas de tu tarjeta a las entradas de la pista automáticamente, cuando le des a grabar, y con esto podrás grabar directamente.

De todas maneras, Audacity está mas orientado a la edición de audio que a la grabación. Rezound es otro programa de enfoque similar.

Como estudios de grabación digital, tienes unas cuantas aplicaciones nativas para Linux, más las que son para Windows y funcionan a través de wine. Yo sobretodo uso Rosegarden y ardour, y algunos plugins libres a través de jack-rack o directamente en ardour, y un ampli virtual para guitarra llamado rakarrack. También se pueden usar instrumentos VST, estos a través de wine obligatoriamente y de algún programa que haga de "host", dssi-vst, VSThost... Y todo esto lo interconecto a través de JACK, con el botón connect.

Busca por internet. Si tienes alguna duda concreta con alguno de estos programas, busca por ahí, o abre otro hilo.

Cuenta qué tal te ha ido. Si tienes problemas con la configuración de jack, postea los mensajes.

Sí, yo también espero que este hilo sirva también a otras personas.

Saludos

Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de Sicarivs
+1
0
-1

Saludos!

Tengo el mismo problema que tenía el creador del tema: conecté una pedalera multiefectos Zoom G2.1u a mi laptop (con Ubuntu Studio 8.10), pero no la detectó.
Intenté seguir los pasos descritos por Pablo, pero al ingresar los comandos que dio, me apareció esto:

sicarivsperfidorvm@sicarivsperfidorvm:~$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
sicarivsperfidorvm@sicarivsperfidorvm:~$ cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xb0000000 irq 23
sicarivsperfidorvm@sicarivsperfidorvm:~$ cat /proc/asound/modules
0 snd_hda_intel

No detecta el 1 que, por lo que leí, debería ser el USB.

Espero que alguien pueda ayudarme...
De antemano, muchas gracias.

+1
0
-1

¡Amigo mío, hay que morir!

Imagen de Pablo_F
+1
0
-1

Hola,

Puede ser que al arrancar el ordenador con la pedalera enchufada no te la reconozca.

Desconectala y vuelvela a conectar al puerto USB y si no, reinicia y enchúfala una vez que ubuntu haya terminado de arrancar.

Y vuelve a mirar el contenido de /proc/asound/cards y /proc/asound/modules.

Problema similar: http://lists.linuxaudio.org/pipermail/linux-audio-user/2005-November/028...

Saludos. Pablo.

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de Sicarivs
+1
0
-1

Hola!

Al parecer era un problema con el cable; lo cambié y la detectó. Ahora veré cómo capturar el sonido.
Gracias por la ayuda y por el link.

Salud!

+1
0
-1

¡Amigo mío, hay que morir!

Imagen de josejin
+1
0
-1

buenas tengo un problema con el reconocimiento de mi mezclador phonic ne es reconocido por la entrada usb en mi caso solo reconoce :

# lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0cf3:3000 Atheros Communications, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
# cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xd0540000 irq 22
# cat /proc/asound/modules
0 snd_hda_intel

y no me reconoce el mezclador phonic o no es posible realizar el control desde ubuntu lucid. agradeceria cualquier tipo de ayuda gracias de antemano.

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Hola,

¿No sería mejor haber abierto un hilo nuevo con este problema?

Yo creo que hay poca esperanza. Desconéctalo, conéctalo y mira en la salida de "dmesg".

Saludos, Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de AbBeginner
+1
0
-1

Para principiantes absolutos (como yo). A mí me ha funcionado muy fácilmente. Conectas la Behringer UCA 200 y en el 'botón de Inicio' ( arriba a la derecha): /configuración del sistema/ sonido/entrada. Una vez aquí, escoges: IEC 958.

Es decir, tan fácil como conmutar la entrada. Además, se puede regular el nivel de entrada (no como en Windows).

Gracias a todos; no lo hubiera logrado sin vuestra ayuda.

+1
0
-1