Ubuntu 8.10 como controlador de dominio

Imagen de xanubisx
0 puntos

Buenas, hace unas semanas que vengo peleando con Ubuntu server.

Estoy haciendo unas pruebas para migrar un servidor Win 2003 server controlador de dominio local, por uno linux.

el tema es que no puedo lograrlo :S

me he leido y probado todos los howto de samba+pdc, bind9, etc.

y no puedo lograr montar el servidor :S

alguna recomendación, o alguna experiencia de como configurarlo!

Gracias !

Imagen de leptom
+1
0
-1

Recomendaciones para que te ayuden:
- Explica que has intentado(por ej.tutoriales que has seguido, cosas que has hecho).
- ¿Qué falla?

Suerte

-----

No tengo blog pero tengo dominio ;)

+1
0
-1
Imagen de xanubisx
+1
0
-1

ok,

Instale Ubuntu 8.10, con samba, bind9, apache, mysql, swat.

los link de los tuto no me los acuerdo porque los borre al no funcionar :S

Configuro samba como controlador de dominio.

Los archivos compartidos funcionan bien, pero el tema es que cuando quiero añadir un equipo al dominio, me dice que no se pudo encontrar el usuario.

+1
0
-1
Imagen de leptom
+1
0
-1

¿Puedes poner el fichero de configuración que estás usando?
¿cómo estás intentando añadir es máquina?

-----

No tengo blog pero tengo dominio ;)

+1
0
-1
Imagen de xanubisx
+1
0
-1

este es el archivo smb.conf

[global]
workgroup = DOMINIO
realm = SERVER.DOMINIO
server string = Server
map to guest = Bad User
obey pam restrictions = Yes
passdb backend = tdbsam
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
domain logons = Yes
os level = 65
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d

logon script = scripts\default.bat
logon path = \\%N\perfiles\%U
#logon path = \\%L\perfiless\%U
logon home = \\%N\%U
#logon home = \\%L\%U
logon drive = H:

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers

[homes]
comment = Directorio personal
path = /home/%S
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No

# Compartimos el recurso de inicio en red
[netlogon]
comment = Network Logon Service
path = /home/samba/netlogon
read only = Yes
write list = root
browseable = No
guest ok = Yes

# Recurso para los perfiles en red
[perfiles]
comment = Users profiles
path = /home/samba/perfiles
read only = No
create mask = 0600
directory mask = 0700
browseable = No

# Recurso de acceso solo-lectura publico
[publico]
comment = Directorio publico
path = /home/samba/public
guest ok = Yes
locking = No
valid users = %S

y la maquina que intento añadir es una con windows XP.

+1
0
-1
Imagen de CarteretT
+1
0
-1

aparte de esa configuracion
aparte de eso, no deberias añadir usuarios locales primero?

sudo adduser [nombredeusuario]

luego añadir usuarios samba con eso usuarios locales:

sudo smbpasswd -a [nombredeusuariolocal]

ami me ha funcionado asi, al meter el equipo en el dominio, pones el usuario que has creado y ya sta.

+1
0
-1