Mi tarjeta de audio no suena.

Imagen de frippado
0 puntos

Pues recientemente le he puesto una tarjeta de audio-midi, mejor que la que tenía al pc; con la espectativa de poder sacarle mayor partido a mi ubuntustudio 8.10. Se trata de la terratec dmx6 fire 24/96; pero a pesar de que sysinfo me dice que la ve:


Multimedia audio controler
VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Chanel I/O Controller (rev 02)
Subsystem: TERRATEC Electronic GmbH Device 1138

No consigo hacerla funcionar. Ni siquiera suena un simple archivo de audio, del formato que sea.

ALSA Sequencer (Aconnectgui) lo reconoce; todos los programas parecen "ver" la tarjeta, pero solo Audacity me ha alegrado un poco, haciéndola sonar.

He podido leer algún post antiguo, que refería que le iba bien esta misma tarjeta; pero no decía cómo.

Agradecería un poco de luz sobre como proceder, para que el sistema "eche a andar" de modo eficiente mi interfaz de audio-midi.

Gracias.

Imagen de frippado
+1
0
-1

No se mueve mucho este foro, no... :(

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Hola,

Yo también tengo una tarjeta basada en ICE1712.

1) El primer consejo es, si no vas a usar para nada la tarjeta de audio integrada en la placa base, lo mejor que puedes hacer es desactivarla desde la BIOS.

2) cat /proc/asound/cards

Con ello verás las tajetas de audio y MIDI que reconoce el sistema.

3) cat /proc/asound/modules

Con ello verás los módulos que manejan tus tarjetas. ¿snd_ice1712?

4) Olvídate de pulseaudio. Elige alsa para el sonido en el menú del entorno gráfico.

5) Instala el paquete (si es que ubuntustudio no lo ha instalado ya) alsa-tools-gui. Y mira los niveles de tu tarjeta con la aplicación envy24control

6) JACK es el servidor de audio recomendado para trabajar con muy baja latencia y excelente interconectividad entre aplicaciones de audio (el MIDI lo maneja alsa, pero puedes verlo también en Jack control) y hardware.

Saludos
Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de frippado
+1
0
-1

Antes de nada, Pablo; agradecerte la respuesta. :)

Comprobaré lo que me dices en cuanto llege a casa, pero salvo error por mi parte (que queda pendiente de confirmar); la placa base no lleva módulo de sonido integrado.

Efectivamente, tanto con la tarjeta antigua que quité, como con ésta, uso el driver ALSA, pero por ahora no he tenido mucha suerte con ésta última.

He intentado también "conectar" la tarjeta con los diferentes programas con JACK, pero el resultado sigue siendo el mismo :?

Estoy deseando terminar el curro, para revisar todo lo que apuntas, y ojalá, contestarte que era lo que necesitaba.

De cualquier modo, gracias y hasta pronto ;)

+1
0
-1
Imagen de frippado
+1
0
-1

Lo 1º, confirmarte que la placa base no integra sistema de sonido alguno (como creía recordar).

He usado el terminal para aclarar este punto y la información que me devuelve es:

"0 [DMX6fire ]: ICE1712 - TerraTec DMX6fire
TerraTec DMX6fire at 0xa400, irq 18
"

Y en cuanto a los módulos -como predecías-: "0 sound_ice1712"

Lo de obviar pulseaudio, así como open sound system; lo tenía más o menos claro:

http://img355.imageshack.us/img355/4766/pantallazopreferenciasdzh4.png

En cuanto a lo que veo en envy24control:

http://img228.imageshack.us/img228/2518/pantallazoenvy24controlfx8.png

Respecto a Jack, he intentado usarlo; pero con poca fortuna hasta ahora. Solo lo he usado para poder lanzar los programas que lo requieren.

¿Alguna idea?

Gracias

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Hola,

Que yo sepa, las pestañas "monitor inputs" y "monitor PCM's" tienen sentido cuando haces monitorización por hardware, es decir, cuando utilizas el mezclador de la propia tarjeta de sonido para monitorizar. Yo no utilizo este tipo de monitorización pues la latencia que consigo a través de JACK es muy baja y no me hace falta, hago "monitorización por software", es decir, que la propia aplicación (ardour por ejemplo) me da la salida de audio de lo que estoy grabando. En mi tarjeta, los monitor inputs y monitor PCM's están a cero.
La pestaña Patchbay/router la tengo con las opciones de arriba del todo seleccionadas (PCM Outs y S/PDIF Outs).
En la pestaña Hardware Settings, uses el sample rate que uses, elige reset para el "rate state" para que lo puedas configurar desde JACK y evitar problemas de discrepancia de sample rates (esto no tiene nada que ver con que no suene pero de paso lo comento).

La clave está en los niveles de los convertidores analógico a digital (DAC) y digital a analógico (ADC), en la pestaña Analog volume. Los DAC's para la señal que entra y los ADC's para la señal que sale de la tarjeta. ¿Cómo tienes esos valores? Ten en cuenta que el nivel del output 1 corresponde al ADC0 y así sucesivamente. No es necesario (ni creo que conveniente) subir los convertidores a tope. Tampoco hay un valor fijo recomendado que yo sepa. Yo los tengo al 80% del total, más o menos, tanto los DAC como los ADC. Una vez que los hayas fijado, no conviene moverlos. Más bien utiliza los niveles de salida de las aplicaciones que uses (para monitorización/reproducción) o instrumentos reales o virtuales (para captura).

Espero que este sea el problema, si no, hay que mirar por otro lado.

Con respecto a JACK Control, si pones un pantallazo de los settings te lo comento.

No olvides el botón connect de Jack. Comprueba sobretodo las conexiones de audio.

Ten en cuenta que una vez que lances JACK, las aplicaciones que no son "jack-aware" no te van a sonar. Jack se adueña del audio de tu tarjeta de sonido.
Por otro lado, las aplicaciones "jack-aware" pueden llevar un poco de trabajo para hacerlas sonar. Como prueba previa, puedes conectar (a través de jack connect) el capture 1 directamente a los playbacks 1 y 2 y enchufar un micro o instrumento al input 1 de tu tarjeta, a ver si suena.

Otra prueba que puedes hacer, antes de que te animes a grabar algo, es escuchar música. Hay varias formas. Yo uso audacious. Instala audacious y audacious-plugins-extra. Es un reproductor sencillito, si conoces XMMS, es muy similar. En preferencias de audio selecciona el jack output plugin.

Saludos

Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de frippado
+1
0
-1

Estimado Pablo_F; independientemente del resultado final que dé esta "travesía", te quedo enórmemente agradecido por tu tiempo y paciencia.

Los niveles de envy24control, ayer noche me los encontré casi todos al mínimo; pero, para probar si cambiando parámetros conseguía algo, los fuí subiendo uno a uno. sin reparar prácticamente en lo que hacía (recién salido del curro y ya ves qué horas).

Ahora, como me aconsejas, he bajado al mínimo, tanto los monitor inputs como los monitor pcms.

Asimismo he seguido tu consejo con las pestañas Patchbay/router, como con la de hardware settings

En la analog volume; ¿estás seguro de que los dacs son entradas y los adcs salidas? o yo estoy muy equivocado o es a la inversa; también puede haber sido un error al escribirlo ¿no? Por favor corrígeme si me equivoco :?

Por sentido común (y dado que sólo uso dos monitores), yo lo he puesto así (siguiendo tu consejo del 80%) ;)

http://img208.imageshack.us/img208/5904/pantallazoenvy24controlhr8.png

Lamentablemente sigo sin poder usar ni siquiera audacius que también era el que yo usaba antes de cambiar de tarjeta :(

Respecto a Jack, lo usaba, más que nada porque para probar aplicaciones como rosegarden, no encontraba mejor modo...

http://img99.imageshack.us/img99/3907/pantallazosetupjackaudiuu5.png

Lo de conectar a través de Jack capture1 de system con playbacks1 y 2 para probar con un micro, no ha servido tampoco para nada.

Y bueno, Pablo_F; no sé qué decirte más. Desde luego gracias.

+1
0
-1
Imagen de Pablo_F
+1
0
-1

Rectifico, tienes razón:

...los convertidores analógico a digital (ADC) y digital a analógico (DAC), en la pestaña Analog volume. Los ADC's para la señal que entra y los DAC's para la señal que sale de la tarjeta...

Gracias por el comentario :)

En otro post te comento los settings de jack, ahora el problema es que no suena con alsa. No sé por qué no suena. Has probado con las pruebas del controlador de sonido de gnome?

Otra prueba que puedes hacer es reproducir un archivo .wav desde terminal con aplay /ruta/al/archivo/loquesea.wav

Puedes probar con el Live CD de 64studio, a ver si te va bien. A ver si das con ello. Suerte.

Pablo

+1
0
-1

"Los analfabetos del siglo XXI no serán aquellos que no sepan leer y escribir, sino aquellos que no sean capaces de aprender, olvidar lo aprendido y aprender de nuevo" (Alvin Toffler)

Imagen de frippado
+1
0
-1

He probado con el livecd de ubuntu 8.10, he probado a reinstalar el sistema, para probar si lo reconocía de mejor modo, en tiempo de instalación; en fin, que he probado todo lo que se me ocurrió...

Todo esto me causa una cierta tristeza e impotencia, ya que había depositado bastantes esperanzas en esta distro, con este interfaz de audio-midi :(

De cualquier manera Pablo_F, gracias por el esfuerzo. Creo que me doy por vencido.

+1
0
-1
Imagen de frippado
+1
0
-1

Resuelto

Por si le fuera útil a alguien (eso espero); mi problema se solucionó gracias a Guitman en Hispasonic -desde aquí mi más sincero agradecimiento- La solución ha consistido en desinstalar todo lo que "oliera" a pulseaudio.

Así de simple ;)

De nuevo, Gracias Guitman.

+1
0
-1
Imagen de ferchosur
+1
0
-1

Me es util la info de hispasonic pero podrias darme el link por favor

gracias

es que tengo el mismo problema con el audio

+1
0
-1
Imagen de jpmiranda
+1
0
-1

http://lamaquinadiferencial.wordpress.com/2010/05/06/funcionando-m-audio...

En cuanto llegue a casa lo pruebo!!

Contar vuestras experiencias con vuestras tarjetas

Yo tengo 2 Terratec una EWS88MT con Ubuntustudio y otra DMX6 fire en un Ubuntu desktop.
Con las versiones del 9.04 funcionaban las dos perfectamente.
Al querer actualizar a 9.10 ya tuve problemas,...pero con la esperada 10.04 Nada de Nada.
Ya os contaré.
Saludos

+1
0
-1