Problemas al Actualizar el sistema

Imagen de Omerta
0 puntos

Saludos compañeros, en el momento de actualizar mi sistema parece que interrumpir la instalación y ahora que trato de actualizar el sistema tengo este error:

# aptitude safe-upgrade
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

Y al ejecutar "dpkg --configure -a":

# dpkg --configure -a
Configurando initramfs-tools (0.85eubuntu39.3) ...
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24.3-custom
Cannot find /lib/modules/2.6.24.3-custom
update-initramfs: failed for /boot/initrd.img-2.6.24.3-custom
dpkg: el subproceso post-installation script devolvió el código de salida de error 1

Imagen de furtaxi
+1
0
-1

O sea, poner sudo antes de la orden:

sudo dpkg --configure -a

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Omerta
+1
0
-1

como puedes ver ya tengo permisos de superusuario cuando ejecuto el comando.

+1
0
-1
Imagen de furtaxi
+1
0
-1

Sorrys por kilos... menos mal que no te mandé a buscar por el foro, que el tema estaba más contestado... :(

Viendo con más detalle, al parecer, hay un problema al actualizar un módulo del kernel, del tipo "custom" ¿Lo añadiste a mano por alguna razón ?

Si conservas un kernel anterior, arranca con él, y repite el dpkg ( en terminal de root, o con sudo, como quieras ) :)

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Omerta
+1
0
-1

No hay problema y agradezco tu colaboración, con respecto a la actualización del kernel no lo actualice de forma manual presumo que el sistema fue interrumpido (apagado o reiniciado) durante la actualización. No tengo kernel anterior esta era la primera vez que se actualizaba desde su instalación este sistema posee el nucleo Linux 2.6.24-19

+1
0
-1
Imagen de furtaxi
+1
0
-1

Si necesitas traducción, avisa.

I deleted the file /boot/initrd.img-2.6.22.9-hyperion and retried with "dpkg --configure -a" with no success. Note that there are no kernel-, vmlinuz- or similar of this specific kernel version, and /lib/modules has only the 22.14-generic standard ubuntu modules, no custom built modules.
Synaptic won't start, just complained to run the above dpkg command. Aptitude same thing. I was just stuck, until i tried:

Code:

root@hyperion:/boot# update-initramfs -k 2.6.22.9-hyperion -d
update-initramfs: Deleting /boot/initrd.img-2.6.22.9-hyperion

Finally, i could successfully run "dpkg --configure -a", now synaptic works again and mdadm is installed.

Fuente: Post número 7 de http://ubuntuforums.org/showthread.php?t=616523

En lo que te puse en negrilla, creo que puedes cambiar el kernel citado por el tuyo.

Léete el resto del hilo, hay otras opciones. Cualquier "atranco", y avisas.

Mi WEB 100 % GNU/Linux: www.vigovideo.es
El que busca encuentra. El que no, se pierde. Arriba a la derecha, un precioso buscador.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.