Instalar Xgl/Compiz en Dapper

Comentarios

Imagen de Trevice

es impresionante.... llevo una semana intentando hacer funcionar, pero no hay manera!! no consigo instalar los drivers la ati en dapper ( en breezy funcionan perfectamente )

alguien a conseguido esta maravilla del glx compliz?

viva linux!

No eres mas ateo que yo. Niegas la existencia de todos los dioses menos uno. Simplemente yo voy un dios mas allá

Imagen de bull3tpr00f

Cual es el error?

Tal vez te interesaría mirar esto

https://wiki.ubuntulinux.org/BinaryDriverHowto/ATI
________________________________
Bullets of Proof

Imagen de Trevice

ya tengo aceleracion con los drivers de ati en dapper! he seguido una guia de www.ubuntu-forums.org

lo que no he conseguido todavia es hechar a andar glx/compiz .... esta complicado! y es que aun esta muy beta

alguien ha encontrado un buen manual para instalarlas con una ati en gnome??

No eres mas ateo que yo. Niegas la existencia de todos los dioses menos uno. Simplemente yo voy un dios mas allá

Imagen de bull3tpr00f

1º el enlace a ubuntuforums es erroneo

2º mira esto How To: Install Xgl/compiz with Dapper, ATI, Gnome

SaludoS
________________________________
Bullets of Proof

Imagen de Trevice

sorry por el link roto, aqui dejo la direccion correcta http://www.ubuntuforums.org/

por otra parte, me temo que ya prove esa guia, pero sin resultados. cuando pide ir en el gconf-editor a /apps/compiz... la carpetita "compiz" no aparece...ña, seguire investigando

muchas gracias por tu ayuda con la aceleracion grafica!

No eres mas ateo que yo. Niegas la existencia de todos los dioses menos uno. Simplemente yo voy un dios mas allá

Imagen de Segarra

Entonces con NVidia que tal funciona?

Silver Segarra

Ubuntu 13.10

Imagen de bull3tpr00f

Funciona perfecto siempre y cuando esté el driver Nvidia debidamente instalado.

En Dapper es aconsejable (y necesario) instalar el driver de los repositorios, ya que el driver propietario necesita un parche para poder funcionar con los nuevos kernels.
________________________________
Bullets of Proof

Imagen de Segarra

Pero en el Ubuntu 5.10 funciona?

Silver Segarra

Ubuntu 13.10

Imagen de bull3tpr00f

Para Breezy el metodo es diferente y algo arriesgado.

http://www.ubuntuforums.org/showthread.php?t=133772&highlight=xgl+breezy

HAZLO BAJO TU RESPONSABILIDAD.

Yo personalmente no lo haría.
________________________________
··· Blog ···

Imagen de kenmaster

con lo que sale en la guia http://www.guia-ubuntu.org/breezy/personalizar_ubuntu?DokuWiki=919276ec4...

0 problemas,bueno solo 1, y es que se me desaparecio la barra de minimizar y maximizar de las ventanas pero lo arregle con lo que sale aca http://crysol.inf-cr.uclm.es/drupal/node/240 en arrancando y probando xgl, y listo asunto arreglado, obiamente lo he probado haciendome otra particion y ver como esta, y no se me a colgado ni nada, todo funciona bien, tengo una tarjeta nvidia fx5200 128 mb,
lo he probado 2 dias, y solamente en 1 cerrar sesion me dio error y me mando a la consola, y otro detalle es que xine la barra de controles sencillamente desaparecio, y ve como si la ubiesen borrado con goma, ni idea que le paso, bueno aparte de eso 0 dramas, uso todos los programas bien.

solo eso, para los que quieren xgl ahora y ya, pruebenlo primero y luego lo usan en su particion.

saludos

----------------------------------------------------------------
Blog http://kenmaster.blogsome.com/
Descargas directas de Cedega, Crossover, Maya, Limewire pro y mas.

----------------------------------------------------------------
Blog http://kubuntu-chile.blogspot.com/
Descargas directas de Cedega, Crossover, Maya, Limewire pro y mas.

Imagen de bull3tpr00f

Me alegra ver que ya incluyeron en la guia un tutorial para instalar Xgl.
________________________________
··· Blog ···

Imagen de Anónimo

Antes de nada, dar las gracias x ayudar a tanta gente ;), despues d conocer ubuntu tras años de uso d windows he visto la luz.Tengo un problema en el paso :

7. Start gconf-editor and go to "apps/compiz/general/all screens/options", and adjust "plugins" in the following order:
Code:

gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher

Ya que no sale el compiz, y he seguido los primeros pasos instalandolo todo. Espero una respuesta.

Gracias x anticipado.

Imagen de Anónimo

Yo tengo una Ati Radeon Xpress 200M, compaq presario M2000 series 1 Gb RAM AMD sempron 2800+, no jala nada de lo que posteas, alguna otra recomndacion????

Imagen de http

a mi me funciono en una nvidia geforce 2 ahora estoy con xgl y compliz iniciados los puse para que iniciara compliz desde el inicio y asi reemplazar metacity

Imagen de kamaleon-linux

Buenas,
yo he logrado poner el Xgl/Compiz con una ATI pero tiene problemas.

Una vez puesto el driver ATI fglrx, por cierto, el driver solo funcionará con la última versión del kernel, ya que cuando carga las X's comprueba la versión del modulo del kernel y con los kernel previos la version del fglrx cambia, no poniendote la aceleración 3D (direct rendering). El ultimo kernel hasta ahora es el 2.6.15-16.

Respecto a la guia que se menciona arriba, para el driver de ATI fglrx debe tener puesto el modulo "dri" en el archivo /etc/X11/xorg.conf, sino no se carga la aceleración y el display no puede ser el :0, no se porque bug misterioso del driver o de Xgl.

Yo lo he logrado lanzar el Xgl e instalar el Compiz manualmente pero solo puedo trabajar con él unos minutos ya que se para, digamos que se cuelga, cuando se configura en el arranque del gdm se me cuelga desde el inicio.

Quizás el problema viene de que Xorg en Dapper es la version 7.0 y el driver fglrx está forzado, ya que trae compatibilidad hasta la 6.9. Con X funciona bien pero a mi con Xgl se cuelga. Mi tarjeta de video es un X600.

Os digo como lo he conseguido, aunque sea por unos minutos :), parto del hecho de que los drivers de ATI propietarios (fglrx) están bien instalados.

Seguid las guias de arriba, recordad, el module "dri" hay que dejarlo sin la #.

1. Nos preparamos dos scripts ejecutables:

~> gedit xgl.sh

#!/bin/sh
sudo Xgl :1 -fullscreen -ac -kb -audit 0 -br -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1 xterm &

~> chmod u+x xgl.sh
~> gedit compiz.sh

#!/bin/sh
DISPLAY=:1 gnome-window-decorator &
sleep 3
DISPLAY=:1 compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu switcher &

~> chmod u+x compiz.sh

2. Desde las X pulsamos ALT + CTRL + F1
Nos loqueamos y ponemos:

~> sudo /etc/init.d/gdm stop
~> ./xgl.sh

Despues de esto nos habrá ejecutado Xgl y nos habra cargado un terminal.

3. En el terminal escribimos:

~> ./compiz.sh

Esto carga compiz, si pone algun tipo de error sobre las texturas o algo por el estilo es que la aceleración no se ha cargado, entonces es cuestión de ver el log /var/log/Xorg.93.log y ver lo que falla en la carga del fglrx.

4. En este paso compiz ya esta cargado, entonces podemos poner

~> gnome-session &

para iniciar una sesion de gnome.

Y eso todo, si se cuelga a mi tambien me pasa. Si a alguien no se le cuelga que lo diga, o sabe como hacer para que no se cuelgue que lo diga, :)

Ciao ciao

Pedro Luis

Imagen de bull3tpr00f

Oye colega, una sugerencia, porque no te curras un COMO para instalar Xgl/Compiz para tarjetas ATI?

Seguro hay gente que te lo agradecería.
________________________________
Bullets of Proof

Imagen de kamaleon-linux

Buenas,
el caso que como he dicho solo funciona por unos minutos, luegos se cuelga, estoy investigando las opciones del driver fglrx a ver que tal.

he leido el COMO de tu pagina sobre NVIDIA, yo actualice de breezy asi es que me bajare la Dapper Flight 4 y vere que tal.

cuando lo logre estable pondre el COMO si llego a tiempo, :)

por cierto, sobre lo de capturar pantallas que pones en tu pagina haz esto

gconf-editor

Go in the gconf-editor to:

apps>compiz>general>screen0>options

Change “command0” into"gnome-screenshot"

Then change “run_command0” into"Print"

Lo he sacado de aqui

http://www.ubuntuforums.org/showthread.php?t=131267

Un saludo

Pedro Luis

Imagen de bull3tpr00f

El asunto es que no quiero capturas de pantalla, sino videos. Estoy probando xvidcap y gvidcap pero no están en los repos. Compilando me da muchos errores (no de dependencias) y se me va de las manos. Haber si alguien conoce algún programa para capturar en video el escritorio.

________________________________
Bullets of Proof

Imagen de kamaleon-linux

Toma, aqui tienes los debs de xvidcap y gvidcap en la version 1.1.3p7

http://sourceforge.net/project/showfiles.php?group_id=81535&package_id=8...

Ya sabes

sudo dpkg -i ...

Un saludo

Imagen de arriero

Pues yo solo instalarlo y sacerle una captura y aviso con los drivers de nvidia instalado y todo como dice el howto el tema se vuelve algo inestable y pesado, colgarse no se me a ha colgado en ningun momento, pero firefox hacia cosas muy extrañas se cerraban las ventanas solas y algun extraño mas asi q si alguien no tiene una maquina de pruebas q no lo intente q le veo formateando o borrando archivos de configuracion para dejar medio estable el tema.

Captura
..................................................
Las mejores ideas son propiedad de todos.
Séneca.Epístolas, siglo I d.C.
Mi blog

Si reparas tu problema, añade(Solucionado)en el asunto de tu primer post, así es mas fácil para el que busca después.Mi Blog

Imagen de bull3tpr00f

Arriero por muy simple que parezca, tu firma me cautivó ;)

Las mejores ideas son propiedad de todos.

________________________________
··· Blog ···

Imagen de garridineante

tengo una ati x200, y me pasa lo mismo que a ti, cuando pasa un tiempo,se cuelga, y ha reiniciar, pero lo mio es peor porque al no haberme creado un script para cargar compiz pongo compiz --replaze cube rotate scale... y es dar intro y se cuelga, si has encotrado alguna solucion por favor avisame
javier_garrido_torregrosa@hotmail.com
si me avisas por email muxo mejor.gracias

Imagen de kamaleon-linux

Buenas,
ke va, todavia no lo he hecho funcionar, he ido actualizando y eso pero nada.

Si lo resuelves tu me avisas, :)

Un saludo

Pedro Luis

Imagen de garridineante

Era por saber si has logrado algun avance cn el xgl compiz, he estado hablando con algunas personas que lo han echo rular con ati, era por si quieres que entre los dos lo intentemos, tengo sus archivos de conf, respondeme al email si puedes:javier_garrido_torregrosa@hotmail.com

Imagen de tyrell

Para que no se cuelgen las ati con dapper poner en el xorg.conf en device despues del driver:
Option "UseInternalAGPGART" "no"
Option "KernelModuleParm" "agplock=0"

Yo tengo una mobility x700 y me funciona perfectamente.

Imagen de Haldir

kamaleon-linux hice lo ke pusiste en tu post, pero en mi caso no se bloquea, hasta ahorita anda bien todo, algunas aplicaciones no jalan, en el teclado no me agarran los numeros los que estan en block num.cuando kiero ver un video me bota y me manda de nuevo a consola, a el vlc no se le ve la barra de titulo.
aclaro que puese unas lineas al xorg.conf como dice el post de tyrell que es el primero en este hilo.

Option "UseInternalAGPGART" "no"
Option "KernelModuleParm" "agplock=0"

espero y le sirva. seguiremos probando,
tengo dapper, ati radeon 9250 game edition. amd duron 1800, 384 en ram

Imagen de jocor

Hola muchachos, a ver si vosotros podeis resolver mi problema.
Actualicé de Breezy a Dapper.
Resulta que mirando en esta pagina, encontré un script llamado "inst_xgl.sh" el cual decía que al ejecutarlo, me instalaría XGL.
pero a la hora de reiniciar, el X server no me funciona dandome este error:
GDM: Xserver not found: /user /bin/xgl :0 :0 -fullscreen -ac -accel glx:pbuffer -accel xv:fbo -auth /var /lib/gdm/:0.Xauth -nolisten tep vt7

me dice que vuelva a instalar Xserver o la configuración correcta de GDM.

he entrado al archivo /etc/gdm/gdm.conf-custom, xq en otro sitio que habia mirado, me decía que modificara dos lineas, pero estaban igual.

Tengo una Nvidia MMX 440, y sé que funciona XGL, xq lo probé con el live CD de kororaa, pero no sé xq no me deja esta, espero me podais ayudar, gracias!!

Imagen de Anónimo

Imagen de Anónimo

Imagen de el_mati

Hola a todos, he instalado satisfactoriamente xgl y compiz, ahora...
compiz no quiere arrancar. la consola me tira lo siguiente
"gnome-window-decorator &
[1] 6960
gandalf@gandalf-desktop:~$ X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 147
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 147
Minor opcode: 3
Resource id: 0x0
Failed to open device
"
o esto "
compiz.real: No composite extension
"
lo cual cuando inicio la máquina me hace quedar un escriorio azul pelado sin barra de tareas ni nada.
pero ojo, esto solo sucede cuando agrego en mi xorg.conf las lineas marcadas con < :

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "RenderAccel" "true" <
Option "AllowGLXWithComposite" "true" <
EndSection
y todo este chorizo
Section "Extensions"
Option "Composite" "Enable"
EndSection

quitando esas lineas puedo arrancar normalmente pero sin compiz

Nota: XGL arranca y funciona bien.
de hecho lo estoy usando ahora, pero sin compiz