MPU401 de VIA8237 en Intrepid

Imagen de notacontranota
0 puntos

Hola chicos

Tras haber actualizado de 7.04 a 7.10 y de ésta a 8.04, decidí instalar 8.10 desde cero. En todas las anteriores versiones de Ubuntu nunca hubo problemas con la detección e instalación de drivers para la interfaz MIDI incorporada en mi placa ASUS P4V8X-X (audio VIA8237 con interfaz MIDI compatible MPU401). Pero esta vez sí. Fue para mí una sorpresa que la nueva versión de Ubuntu no reconozca y configure correctamente tan básico y poco extraño hardware. Lo solucioné simplemente añadiendo la línea:

snd-mpu401

al archivo /etc/modules.

Aún tuve que hacer algo más: como utilizo Denemo como interfaz gráfica para Lilypond 2.12 (instalé compilando la última versión, 0.8.2 para poder acceder a la nueva función MIDI), me enteré que no tenía acceso al dispositivo MIDI /dev/midi1 a pesar de tener correctos los permisos (660, si los cambiaba a 666 sí funcionaba), así que edité los permisos de mi usuario dándole la posibilidad de usar dispositivos de audio (Menú Sistema->Administración->Usuarios y grupos, desbloquear y propiedades del usuario, y ahí la solapa "Privilegios de usuario", tilde en "Usar dispositivos de sonido").

Funciona todo: hay interfaz MIDI y Denemo accede a ella.

Saludos desde Salta, Argentina.

Imagen de Fenixin
+1
0
-1

A mi me pasaba lo mismo... pero con una tarjeta de sonido integrada en la placa madre asus (A7N8X). A mi me ha bastado con poner el módulo en la lista de módulos.

Gracias de nuevo!

Salu2!

+1
0
-1
Imagen de joseluis021072
+1
0
-1

hola, yo tengo la versión 10.04 de Ubuntu y tengo una interface midi EDIROL UM-1 ex como debo hacer para que me la reconozca. Soy principiante en Linux.
Gracias.

+1
0
-1