Mil problemas con los repositorios,no toco mas que es peor.

Imagen de UnKn0wN
0 puntos

Hola,la desesperacion me engulle,primero me salian muchos errores de GPG NO_PUBKEY,ya no me salen,creo que lo solucione Buuff.

Ahora abro el gestor de actualizaciones,pincho en actualizar y me dice esto: Imposible obtener http://ppa.launchpad.net/googlegadgets/ubuntu/dists/intrepid/main/binary... 404 Not Found
Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.

Y tengo dos actualizaciones que no puedo actualizar con synaptic,son libcairo2 y songbird,al marcarlos para actualizar me sale esto:

libcairo2:
Depende: libxcb-render-util0 (>=0.2.1+git1) pero se va a instalar 0.2+git36-1

songbird:
Depende: libgtk2.0-0 (>=2.15.0) pero se va a instalar 2.14.4-0ubuntu2
Depende: libsqlite3-0 (>=3.6.10) pero se va a instalar 3.5.9-3ubuntu1

Llevo dias con esto y no puedo actualizarlos,los repositorios me tienen frito,ayuda porfa..

Imagen de Goyo
+1
0
-1

abro el gestor de actualizaciones,pincho en actualizar y me dice esto: Imposible obtener -i386/Packages.gz... 404 Not Found

Es que ese repositorio no existe, ahí solo hay un repositorio para Hardy.

libcairo2:
Depende: libxcb-render-util0 (>=0.2.1+git1) pero se va a instalar 0.2+git36-1

¿A qué versión de libcairo2 estás tratando de actualizar y de dónde sale? No es la de los repositorios oficiales de Intrepid.

songbird:
Depende: libgtk2.0-0 (>=2.15.0) pero se va a instalar 2.14.4-0ubuntu2
Depende: libsqlite3-0 (>=3.6.10) pero se va a instalar 3.5.9-3ubuntu1

Lo mismo que para libcairo2.

+1
0
-1
Imagen de UnKn0wN
+1
0
-1

Ubuntero 100%

Hola Gracias.

Lo primero que dices de que eso es un repositorio para hardy,pues no se que he hecho para que este eso ahi,¿como lo quito?.

El libcairo2 me dice synaptic que la version instalada es 1.8.0-0ubuntu1.1 y la ultima version la 1.8.6-1ubuntu1-fta1

El songbird version instalada 1.0.0+0-0ubuntu1-fta6,ultima version 1.1.1-0ubuntu1-fta4

Eso pone,no se como saber de donde salen,si me explicas yo te lo digo.

Tiene solucion compi?,¿La tiene?,que estoy todo el dia y parte de el de ayer...

+1
0
-1

Ubuntero 100%

Imagen de Goyo
+1
0
-1

Lo primero que dices de que eso es un repositorio para hardy,pues no se que he hecho para que este eso ahi,¿como lo quito?.

Pues yo pienso que se te antojó instalar Google Gadgets, entonces buscaste unas instrucciones o algo y tratando de seguirlas añadiste ese repositorio. Para quitarlo has de seguir el camino inverso. Si no lo recuerdas usa la herramienta Orígenes del software (Sistema -> Administración) o edita borra la línea correspondiente en /etc/apt/sources.list

El libcairo2 me dice synaptic que la version instalada es 1.8.0-0ubuntu1.1 y la ultima version la 1.8.6-1ubuntu1-fta1

El songbird version instalada 1.0.0+0-0ubuntu1-fta6,ultima version 1.1.1-0ubuntu1-fta4

Eso pone,no se como saber de donde salen,si me explicas yo te lo digo.

Pero hombre ¿cómo no lo vas a saber? A ver, de pronto se te ocurrió que querías instalar songbird y entonces...

+1
0
-1
Imagen de arcachofo
+1
0
-1

Hola...

Estas seguro de que esta es una direccion de un repositorio de Ubuntu?:

http://ppa.launchpad.net/googlegadgets/ubuntu/dists/intrepid/main/binary-i386/Packages.gz

Eso de /googlegadgets no me suena a direccion de repositorio...
Comprueba que direcciones tienes en el sources.list, posiblemente tu problema este ahi.
_________________________________________________________________________
http://pic-linux.foroactivo.net

+1
0
-1

_________________________________________________________________________

http://linuxmicros.blogspot.com/

Imagen de UnKn0wN
+1
0
-1

Compis vale que he tocado muchas cosas,pero con el sistema acabado de instalar (Ubuntu Ultimate 2.1) ya me salia el libcairo2 y el songbird, y instale el sistema 2 veces,y no he tocado para nada el sources.list,acabo de poner en terminal sudo /etc/apt/sources.list y eso no se abre asi que no se como se abre eso,yo no lo he tocado,de verdad,y en Origenes del softwareno no me sale ningun http://ppa.launchpad.net/googlegadgets/etc la que sigue,,Y tampoco he querido instalar googlegadgets,de verdad no se que es.

Lo unico que he tocado a sido en synaptic
/configuracion/repositorios/software de terceros que hay un googlegadgets y un songbird,si los desmarco salen otros errores creo.

Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de UnKn0wN
+1
0
-1

Compis que he probado otra ves a desmarcar songbird repo y google gadgets ahi de donde os he dicho antes y ya no me salen los problemas de los que ablabamos,pero ahora an salido otras actualizaciones,estas:

libssl0.9.8
openssl
dpkg-dev

Y cuando pincho en instalar me sale: No se ha tenido exito con todos los cambios y actualizaciones. Para conocer mas detalles sobre el fallo porfavor expanda el panel terminal inferior.
Y bajo solo pone detalles: Preconfigurando paquetes...

UnSaludo y muchas gracias.

Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de danirolo7
+1
0
-1

Haber dicho desde el principio que no era la versión oficial, esas remasterizaciones del Ubuntu original hay que tratarlas con cuidado, vienen con repositorios no oficiales que causan el problema que tienes ahora mismo, con la 2.0 no hay mucho problema, siempre y cuando NO utilices Automatix, está basada en Intrepid también, así que no hay mucho problema...incluso me gusta más la 2.0 en su interfaz.

Prueba buscando los paquetes que te dice en versión .deb en los repositorios online de Debian y Ubuntu.
----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

+1
0
-1

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

Imagen de UnKn0wN
+1
0
-1

No sabia que era importante,como antes tenia la 2.0 y no tenia ningun problema.
Entonces esas tres actualizaciones que me salen ahora y no puedo instalar tambien sera algun repositorio que no tengo que tener?,cual?

Tios perdonarme por no decirlo eh al principio

Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de Goyo
+1
0
-1

Por lo que dices es el propio Ubuntu Ultimate el que ha montado un lío de cuidado con los repositorios. Creo que lo mejor es que pegues aquí el contenido de sources.list a ver si se puede arreglar.

gedit /etc/apt/sources.list

O simplemente usa Nautilus.

+1
0
-1
Imagen de danirolo7
+1
0
-1

Pues nada, señores...a la labor a mano,es decir, compilando cosillas...el libgtk2.0-0 2.15.5 se encuentra en los repositorios de Jaunty, no sé porqué te lo pide en Intrepid...repositorios malos.

Ese paquete lo encuentras aquí: https://launchpad.net/ubuntu/+source/gtk+2.0/2.15.5-0ubuntu1 es el archivo .tar.gz, si no sabes qué hacer con él, te lo explico en otro post.

El libxcb-render-util0 lo enceuntras aquí: http://packages.ubuntu.com/intrepid/libxcb-render-util0

El que falta, el libsqlite3-0 lo tienes aquí: http://packages.debian.org/sid/libsqlite3-0

Los dos últimos los eliges según tu arquitectura, que imagino que será i386 o amd64, el primero se compila.

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

+1
0
-1

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

Imagen de UnKn0wN
+1
0
-1

Muy bien pues por nautilus.
Esto es lo que sale,no entiendo ni papa
_______________________________

# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://archive.ubuntu.com/ubuntu/ intrepid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu/ intrepid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu/ intrepid universe
deb http://archive.ubuntu.com/ubuntu/ intrepid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://archive.ubuntu.com/ubuntu/ intrepid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu intrepid partner
# deb-src http://archive.canonical.com/ubuntu intrepid partner

deb http://archive.ubuntu.com/ubuntu/ intrepid-security main restricted
deb http://archive.ubuntu.com/ubuntu/ intrepid-security universe
deb http://archive.ubuntu.com/ubuntu/ intrepid-security multiverse
_________________________________

Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de Goyo
+1
0
-1

Pues sí que nos va a costar esto. Ve a /etc/apt/sources.list.d, allí debería haber un archivo terminado en .list, dinos cómo se llama y pega aquí el contenido. Si hay varios archivos acabados en .list dinos cómo se llaman pero pega sólo el contenido del primero, que si no va a ser un follón.

+1
0
-1
Imagen de danirolo7
+1
0
-1

Pues eso..que toma ya, porque no hay ningún repositorio anormal.

Estás seguro de que no había más repositorios?...esa puede ser la causa, que habiese otro repositorio anteriormente que quitaste y ahora los paquetes no los encuentra, en todo caso bájate los paquetes de las páginas que te dije, el primero compílalo como .deb y luego lo instalas normalmente, que si no Apt no te lo reconoce.

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

+1
0
-1

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

Imagen de UnKn0wN
+1
0
-1

Le di a saleccionar todo y luego a copiar asi que estara todo pero desactive dos repositorios en origenes del software.

danirolo7 libxcb-render-util0_0.2+git36-1_i386.deb lo he instalado.
libsqlite3-0_3.6.11-4_i386.deb me dice esto,Error:Dependency es not satisfiable:libicu40

El tar.gz ya sabes que no se que hacer con el powa.

Gracias.

UnSaludo.

Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de danirolo7
+1
0
-1

Para el segundo paquete: instala el libicu40 desde aqui: http://packages.debian.org/sid/main/libicu40

Para el paquete en .tar.gz, lee esto: http://www.tuxi.com.ar/2007/12/05/autodeb-compilar-programas-y-generar-a...

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

+1
0
-1

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

Imagen de UnKn0wN
+1
0
-1

Lo del AutoDeb yo no se hacerlo,mira lo que me sale para que te rias un rato:

jose@jose-pc:~$ chmod +x autodeb.sh
jose@jose-pc:~$ sudo ./autodeb.sh –gnome
Type the name of the archive or directory containing the source code : /home/jose/Escritorio/gtk+2.0_2.15.5.orig.tar.gz
Choose a name for the package to create - Press Enter to use 'gtk+2.0_2.15.5.orig' :
Type a a version number for the package - Press Enter to use 'gtk+2.0_2.15.5.orig' : 323
Type in a description of the package - Press Ctrl-D when finished :
^D
Extracting archive... (0%)
tar: Saltando a la siguiente cabecera

gzip: stdin: invalid compressed data--crc error

gzip: stdin: invalid compressed data--length error
tar: Child returned status 1
tar: Salida con error demorada desde errores anteriores
ERROR: Archive extraction failed.
jose@jose-pc:~$
Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de danirolo7
+1
0
-1

Bueno, da igual, lo he encontrado en paquete .deb listo para instalar, pero posiblemente pida más dependencias (más paquetes)..si es que las versiones esas raras la lían un montón con las dependencias. El paquete:

http://debian.cantv.net/debian/pool/main/g/gtk+2.0/libgtk2.0-0_2.16.0-1_...

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

+1
0
-1

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

Imagen de UnKn0wN
+1
0
-1

Si me pide mas cosas,ahora dice: Dependency es not satisfiable:libglib2.0-0
¿No va a parar de pedir mas dependencias de esas?

Ubuntero 100%

+1
0
-1

Ubuntero 100%

Imagen de Goyo
+1
0
-1

Es posible que no. Por eso creo que sería mejor tratar de apañar una lista coherente de repositorios, como te decía más arriba.

+1
0
-1
Imagen de danirolo7
+1
0
-1

Pienso igual que tú, pero viendo la lista de repos, sólo tiene los oficiales. ¿Hay algún otro repositorio que contenga todos esos paquetes?...¿de Jaunty quizá?.
----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

+1
0
-1

----------------------------------------------------
Sin malos rollos.

http://fausto23.wordpress.com

Linux User #476658
Ubuntu User#23611

¡¡¡Salud y Libertad!!!

Imagen de UnKn0wN
+1
0
-1

Pues yo no se que es mejor hacer,en otro foro me an dado una lista,pero me an dicho que seria un apaño temporar,bueno es esta:

# deb cdrom:[Xubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081030.3)]/ intrepid main multiverse restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://es.archive.ubuntu.com/ubuntu/ intrepid main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://es.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://es.archive.ubuntu.com/ubuntu/ intrepid universe
deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://es.archive.ubuntu.com/ubuntu/ intrepid-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://es.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://es.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://es.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://es.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu intrepid partner
# deb-src http://archive.canonical.com/ubuntu intrepid partner

deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
deb http://security.ubuntu.com/ubuntu intrepid-security universe
deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse

Que tal?.

Ubuntero 100%

+1
0
-1

Ubuntero 100%