Imagen de anduran
0 puntos

Hola a todos.....

 ademas de ser nuevo en el foro tambien soy nuevo utilizando ubuntu.... mi problema es que al iniciar el pc no me activa la particion swap; para tratar de solucionarlo abro el gparted y la activo y hadsta ahi todo bien... pero al volver a prender mi ordenador vuelve el mismo problema como puedo solucionarlo definitivamente..... (que al bootear mi maquina desde mi ubuntu o mi debian que tambien tengo instalado me aparesca activada mi particion swap ya que en debian tampoco me la activa)

Imagen de keygen
+1
0
-1

primero que nada debes de identificar que particion es la swap, con esto quiero decir si es (hda1,hdb1,...,hdxx o sdxx) en mi caso es (hda5), ahora lo que tienes que hacer es agregar una linea como la que se describe en el archivo /etc/fstab:

 /dev/hda5       none            swap    sw              0       0

solo cambia /dev/hda5 por el dispositivo que tu tienes (hdxx o sdxx), despues tienes que ejecutar el comando swapon con el parametro 'a' como root:

sudo swapon -a

y pues con esto deberia de estar activada tu particion swap, si no se activa de momento se activará en el proximo inicio del sistema, de no ser asi puede ser algun error diferente(ej. el no formatear con el sistema de archivos adecuado a la particion swap) 

-- [vivie siempre libre]

+1
0
-1

--
[vivie siempre libre]

Imagen de Cristian T.
+1
0
-1

Hola, quisiera saber como puedo averiguar cual es mi particion swap. En mi archivo fstab sale que es /dev/sda7 pero al ocupar el comando

sudo swapon -a

sale lo siguiente:

swapon: /dev/sda7: Argumento inválido

 

+1
0
-1

 

Imagen de capiporra
+1
0
-1

para listar las particiones del disco 

sudo fdisk -l /dev/sda 

 En fstab prueba tambien a ponerlo con su UUID

sudo vol_id -u /dev/sda7 

te dará un numerajo y lo sustituyes en la linea que te dejo aquí y que deberás porner en fstab 

UUID=xxxxxx-xxxxx-xxxx-xxxx  none swap sw 0 0

 

desmontamos y montamos las unidades

sudo umount && -a sudo mount -a 

Al final, te manco con el hacho!

+1
0
-1

Sign by Danasoft - Myspace Layouts and Signs

Imagen de Cristian T.
+1
0
-1

Hola, hice lo que me dijiste, busque el numero y lo sustitui en la linea del fstab, pero eran los dos el mismo numero. Luego desmonté y me salio lo siguiente en el terminal

 Uso:   umount [-hV]
       umount -a [-f] [-r] [-n] [-v] [-t vfstypes] [-O opciones]
       umount [-f] [-r] [-n] [-v] special | node...
 

ahí no se que debo hacer.

Mi problema es que mi disco swap no esta activado,  instale el administradr de arranque y active la opcion de "Mostrar texto durante el arranque. Cuando sale la linea "Activate swap..." dice "failed". Ahora quiero reactivarlo y no se como.

 

+1
0
-1

 

Imagen de capiporra
+1
0
-1

perdon ,fallo tecnico, desmontar y montar es respectivamente:

sudo umount -a
sudo mount -a 

o

sudo umount -a && sudo mount -a

Has vuelto a reiniciar despues de aplicar los cambios en fstab?

a que te refieres con que los numeros eran iguales? Ya tenias en fstab asignado un UUId y era igual al que te devuelve el comando vol_iD?

+1
0
-1

Sign by Danasoft - Myspace Layouts and Signs

Imagen de Cristian T.
+1
0
-1

Si, reinicie luego de cambiar el UUid, y si, el UUid era igual al que me devuelve el comando vol_iD.

Alguna idea que me pueda ayudar?

+1
0
-1

 

Imagen de capiporra
+1
0
-1

 Copia y pega lo que te devuelve

sudo fdisk -l /dev/sda 

 

 prueba a hacerle un:         (cambia X por tu particion swap)

sudo mkswap /dev/sdaX                                      -->crea una(un?) swap
sudo swapon /dev/sdaX                                       -->la añadimos la sistema

 

 

____________________________________________

Gutsy Gibbon 7.10 32bits

+1
0
-1

Sign by Danasoft - Myspace Layouts and Signs

Imagen de Cristian T.
+1
0
-1

Ha resultado crear un swap nuevo. Primero utilice los comandos que me diste y se creo una nueva particion swap y le asigno una nueva UUid, la cual copié y pegué en el archivo /etc/fstab como me habias recomendado mas arriba y ahora tengo el swap activo nuevamente.

Muchas gracias.

 Saludos desde Chile

 

+1
0
-1

 

Imagen de capiporra
+1
0
-1

me alegro que dieras con ello

marca el hilo como "solucionado" 

 

 

 

____________________________________________

Gutsy Gibbon 7.10 32bits

+1
0
-1

Sign by Danasoft - Myspace Layouts and Signs

Imagen de donmatas
+1
0
-1

Estimado Keygen:

tengo identificada mi partición swap (/dev/sda4), pero no tengo la mínima idea de a qué te refieres con "agregar una linea como la que se describe en el archivo /etc/fstab".

gracias de antemano

DM

 

¡Linux o Barbarie!

+1
0
-1

¡Linux o Barbarie!
Usuario Linux n° 480792

Imagen de donmatas
+1
0
-1

Para modificar la mentada linea se puede acceder desde el terminal de la siguiente manera:

sudo gedit /etc/fstab  

(sudo para entrar como super usuario; gedit, para abrir el fichero fstab que está en la carpeta etc)

Esto abrirá un texto donde debes reemplazar la línea donde está montado la SWAP (en mi caso /dev/sda4) por el siguiente texto (en negrita)

# /dev/sda4 :
/dev/sda4 none swap sw 0 0

así quedó resuelto el problema en mi caso 

¡Linux o Barbarie!

+1
0
-1

¡Linux o Barbarie!
Usuario Linux n° 480792

Imagen de truxo01234
+1
0
-1

gracias

yo tenía el mismo problema
y me sirvió mucho este tema

saludos!!!! (no podía dejar de agradecer)

+1
0
-1
Imagen de cosarara97
+1
0
-1

Me ha servido, a mi me pasaba lo mismo, os explico como lo he solucionado:
1. Usar este comando para abrir el fichero etc/fstab:

sudo gedit /etc/fstab

2. El comando vol_id no me ha funcionado, he usado este:

sudo blkid

Te da una lista con tus particiones, he buscado la que era: TYPE="swap".

3. He copiado el "UUID=xxxxxx-xxxxx-xxxx-xxxx" que me ha dado el comando blkid.

4. He substituido el "UUID=yyyyyy-yyyyy-yyyy-yyyy" que habia en la ultima linea del fichero fstab por el "UUID=xxxxxx-xxxxx-xxxx-xxxx" que me dio el comando blkid.

Ejemplo:
Abrimos un terminal y escrivimos:

sudo gedit /etc/fstab

(Pulsa "Enter")
Se abrira el fstab como root.

Abrimos otro terminal (no se si se puede hacer desde el mismo, yo no lo se hacer), y escribimos:

sudo blkid

(Pulsa "Enter")

El comando blkid les dara algo como esto (inventado):

/dev/sda1: LABEL="SISTEMA"    UUID="1234567ABC91011X" TYPE="ntfs" 
/dev/sda2: LABEL="DOCUMENTOS" UUID="ESTOESUNEJ3MPL02" TYPE="ntfs" 
/dev/sda3: UUID="XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sda5: UUID="YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY" TYPE="swap" 
/dev/sda6: UUID="ZZZZZZZZ-ZZZZ-ZZZZ-ZZZZ-ZZZZZZZZZZZZ" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sda7: UUID="AAAAAAAA-AAAA-AAAA-AAAA-AAAAAAAAAAAA" TYPE="ext4" 

Si se lo miran un poco veran que las 2 primeras son particiones ntfs (win) Luego hay una que es ext3, luego el swap. !
Ah, el swap, lo que buscábamos, pues ese es. Copiamos el "YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY" (en realidad creo que es imposible que sean todo "Y"s, pero esto es un ejemplo)
Vamos al fichero fstab que abrimos con gedit.
Yo solo tengo 3 lineas, no se si siempre es asi.
Vamos a la ultima linea, en la que pone:

UUID=EJEMPLO-EEEE-BBBB-CCCC-DDDDDDDDDDDD none            swap    sw              0       0

Sustituyen el la parte en negrita por el "YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY" (Sin comillas) que en realidad sera lo que os salga a vosotros en el comando blkid, no copien el "YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY".
Denle a guardar.
Si ya tenían activado el swap desde Gparted mejor lo desactivan.
En un terminal:

sudo swapon -a

(Pulsa "Enter")
Si no les da error, buen señal, para comprobar que realmente funciona, abran el Monitor del sistema y miren la parte en que habla del espacio de intercambio. Si pone que tienen algo diferente de 0 (ejemplo, 19,0 MiB (0,9 %) de 2,0 GiB), es que tienen activado el swap.

Bueno, no se si lo he explicado bien, ahora estoy preocupado por que no la lien copiando el "YYYYYYYY-YYYY-YYYY-YYYY-YYYYYYYYYYYY" literalmente, cosa que recuerdo que NO hay que hacer, tienen que copiar lo que les ha dado.

(Esto no parece un comentario, y es el primero que hago)

+1
0
-1