Problema deteccion memoria RAM

Imagen de Inaxio182
0 puntos

Hola

Resulta que mi ubuntu 9.04 64 bits no detecta 4gb de memoria RAM, marca 2.5 gb (no uso VGA)
ademas lo raro es que en un windows xp de 32bits tambien marca 2.5 gb en vez de los 3 o 3.5 a los que puede llegar

la BIOS detecta los 4gb perfectamente

Nombre del motherboard ECS P4M890T-M
Tipo de BIOS AMI (08/08/07)
CPUID Nombre de la CPU Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz(x 2)
Placa de video Radeon X1300/X1550 Series (512 MB)

si alguine me dice de recompilar el kernel......lo intnte pero no encontraba la opcion de high memory support......ademas me acba liando, necesitaria saberlo paso por paso

ayudenme por favor
gracias

Imagen de dark_saito
+1
0
-1

Estas seguro que tienes Ubuntu 9.04 en 64 bits, y si es asi busca cualquier problema que pueda haber con el chipset VIA que tienes P4M890T-M, yo tengo este chipset (P4M890-TE) y me ha dado bastante rollos en 32 bits...

Si puedes mandar un log del kernel seria bueno, prueba con

uname -r

Y mandas su respuesta aqui...

+1
0
-1
Imagen de Inaxio182
+1
0
-1

2.6.28-15-server

Si es un ubuntu jaunty 9.04 de 64bits
la cosa es que en el windows tambien marca el mismo limite......entonces no se que pasa (windos de 32bits deberia llegar a 3gb o 3.5)

+1
0
-1
Imagen de Ramatote
+1
0
-1

yo tengo un problema parecido, uso karmic koala en mi laptop, le puse memoria ram de 4 gib marca kingston, pero solo me detecta 3, a que se debe?? soy nuevo en esto, aun no entiendo muchas cosas, tengo como procesador Intel Core 2 Duo T7300 (2.0 Ghz, 800 Mhz FSB, 4 MB L2 cache)

+1
0
-1
Imagen de keopx
+1
0
-1

instalar el kernel:

2.6.31-14-generic-pae

Y reinicia.

Si usas Jaunty instala el kernel *-server

www.keopx.net

+1
0
-1
Imagen de Andrewwet
+1
0
-1

hola a todos, yo tengo el mismo problema pero mas agudo, ya que entre lo que tengo de ram y lo que me detecta hay un mundo, tengo 8gigas de ram y me detecta 3.2, menos de la mitad, aunque me va de P.M. es un asuntillo que me gustaria resolver y sobre todo conocer las causas del fallo para que no se repitan en un futuro. Quiero decir tambien como detalle, que el win vista que tengo en otra particion detecta los 8 sin problemas, lo que me sugiere que un fallo del propio ubuntu 9.10. Un saludo. Gracias.

+1
0
-1
Imagen de keopx
+1
0
-1

Ubuntu no tiene ningún problema. Deberías de documentarte y leer antes de comentar que puede ser un fallo del S.O.

Los sistemas de 32 bits solo soportan 3.2GB de RAM. En Linux existe la opción de PAE que permite la utilización de toda la memoria RAM mediante la paginación de la misma. Para ello puedes instalar el kernel.*-server o instalar el kernel compilado con la extension PAE (tambien puedes compilarlo tu mismo). La otra opción es la utilización de un sistema de 64 bits.

Seguramente ese windows que mencionas sera de 64bits.

Un saludo y espero que sirva la explicación.

www.keopx.net

+1
0
-1
Imagen de Luisinho77
+1
0
-1

Hola Keopx... la explicación me ha servido, pero no sé como realizarla... cómo se instala el kernel.*-server?? yo tengo un Acer Aspire 6930 y creo que esa debe ser mi opción porque no es de 64 bits...

Gracias ^_^

+1
0
-1

"Si te doy un pez comerás un día, si te enseño a pescar comerás todos los días"

Imagen de Inaxio182
+1
0
-1

ya veo que gente ajena a mi problema ha comentado su problema y le han contestado a el....se supone que el post es mio.....y a mi nadie me ha dicho todavía nada.......lo repito para los que no lean el principio.....

YO uso un sistema de 64 bits ubuntu 9.04, tengo 4gb de RAM y me parecen 2.5gb........ese mismo limite me aparece en un windows xp de 32 bits
Intel core 2 duo (1.86 ghz x2)

LA BIOS detecta 4096 mb..... es decir, la BIOS detecta plenamente los 4gb de RAM

Si alguien me ayuda le doy las gracias de antemano

pero invadir posts ajenos para que te ayuden....por mi parte no me agrada....por lo menos ami no se si alguien coincidirá...

+1
0
-1
Imagen de keopx
+1
0
-1

Tienes razón, disculpa.

Mira este enlace (http://systemadmin.es/2009/11/maxima-memoria-soportada-por-el-hardware-de-un-sistema) y ejecuta sus comandos para ver que resultados te devuelve y coméntanos. Con estos resultados quizás podamos sacar alguna conclusión. De todas maneras no serán 3.5GB en vez de 2.5GB, pregunto por si loa has copiado mal y así descartar.

Gracias.

www.keopx.net

+1
0
-1
Imagen de Luisinho77
+1
0
-1

Gracias Keopx, esto es lo que me dice a mí:

# dmidecode 2.9
SMBIOS 2.5 present.

Handle 0x0015, DMI type 16, 15 bytes
Physical Memory Array
Location: System Board Or Motherboard
Use: System Memory
Error Correction Type: None
Maximum Capacity: 4 GB
Error Information Handle: Not Provided
Number Of Devices: 2

Handle 0x0016, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x0015
Error Information Handle: No Error
Total Width: 64 bits
Data Width: 64 bits
Size: 2048 MB
Form Factor: SODIMM
Set: 1
Locator: M1
Bank Locator: Bank 0
Type: DDR2
Type Detail: Synchronous
Speed: 667 MHz (1.5 ns)
Manufacturer: Mfg 0
Serial Number: 1234-B0
Asset Tag: Not Specified
Part Number: SODIMM000

Handle 0x0017, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x0015
Error Information Handle: No Error
Total Width: 64 bits
Data Width: 64 bits
Size: 2048 MB
Form Factor: SODIMM
Set: 1
Locator: M2
Bank Locator: Bank 1
Type: DDR2
Type Detail: Synchronous
Speed: 667 MHz (1.5 ns)
Manufacturer: Mfg 1
Serial Number: 1234-B1
Asset Tag: Not Specified
Part Number: SODIMM001

+1
0
-1

"Si te doy un pez comerás un día, si te enseño a pescar comerás todos los días"

Imagen de Inaxio182
+1
0
-1

# dmidecode 2.9
SMBIOS 2.5 present.

Handle 0x0008, DMI type 6, 12 bytes
Memory Module Information
Socket Designation: DIMM0
Bank Connections: 1 0
Current Speed: Unknown
Type: SDRAM
Installed Size: 2048 MB (Double-bank Connection)
Enabled Size: 2048 MB (Double-bank Connection)
Error Status: OK

Handle 0x0009, DMI type 6, 12 bytes
Memory Module Information
Socket Designation: DIMM1
Bank Connections: 3 2
Current Speed: Unknown
Type: SDRAM
Installed Size: 512 MB (Single-bank Connection)
Enabled Size: 512 MB (Single-bank Connection)
Error Status: OK

Handle 0x0027, DMI type 16, 15 bytes
Physical Memory Array
Location: System Board Or Motherboard
Use: System Memory
Error Correction Type: None
Maximum Capacity: 4 GB
Error Information Handle: Not Provided
Number Of Devices: 2

Handle 0x0029, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x0027
Error Information Handle: Not Provided
Total Width: 64 bits
Data Width: 64 bits
Size: 2048 MB
Form Factor: DIMM
Set: None
Locator: DIMM0
Bank Locator: BANK0
Type: DDR2
Type Detail: Synchronous
Speed: Unknown
Manufacturer: Manufacturer0
Serial Number: SerNum0
Asset Tag: AssetTagNum0
Part Number: PartNum0

Handle 0x002B, DMI type 17, 27 bytes
Memory Device
Array Handle: 0x0027
Error Information Handle: Not Provided
Total Width: 64 bits
Data Width: 64 bits
Size: 512 MB
Form Factor: DIMM
Set: None
Locator: DIMM1
Bank Locator: BANK1
Type: DDR2
Type Detail: Synchronous
Speed: Unknown
Manufacturer: Manufacturer1
Serial Number: SerNum1
Asset Tag: AssetTagNum1
Part Number: PartNum1

dmidecode -t memory | grep Maxi | grep Capa
Maximum Capacity: 4 GB

Como puedes observar lo maximo que soporta mi placa base es de 4gb, yo ocmpre las 2 memorias de 2gb cada una (repito que la BIOS detecta los 4096mb- 4gb) pero aqui me dice que una memoria es de 2gb y otra de 512mb ¿?¿?¿
y si tanto en ubuntu 64bits y wn windows xp marca el limite en 2.5gb.....reduci la agp a 64 mb ya que uso una tajeta grafica PCI

+1
0
-1
Imagen de keopx
+1
0
-1

La solución mas coherente es que mires la memoria, con el disco live de ubuntu te permite revisar por software la memoria, mira a ver si te da algun fallo.

Prueba con otra memoria (que te la preste alguien) y mira los resultados. Te digo esto por que no solo es Ubuntu sino que windows también te da los mismos resultados, seguramente la memoria te este fallando.

Espero que te sirva y ya nos contaras.

PD.: chequea que no sea una de 2GB y la otra de 512MB, los técnicos a veces hacen cosas de esas, quien sabe.

www.keopx.net

+1
0
-1
Imagen de Luisinho77
+1
0
-1

Hola Keopx, como has podiod ver en mi post anterior, a mí el sistema me detecta que tengo dos módulos de 2048 MB y al hacer

# dmidecode -t memory | grep Maxi | grep Capa
Maximum Capacity: 4 GB

Qué pued pasar en este caso??

+1
0
-1

"Si te doy un pez comerás un día, si te enseño a pescar comerás todos los días"

Imagen de keopx
+1
0
-1

Deberías de abrir tu propio post, mas que nada por que es un tema diferente, pero bueno te contesto:

Ubuntu 9.10:

sudo aptitude install linux-image-2.6.31-14-generic-pae

Ubuntu 9.04 (Puede que el kernel cambie de numeración mira los que hay en el repositorio):

sudo aptitude install linux-image-2.6.28-15-server

www.keopx.net

+1
0
-1
Imagen de Inaxio182
+1
0
-1

Bueno aqui voy a comentar unos estudios/pruebas que he realizado :(las dos memorias son de 2gb son identicas del mismo tamño no como las de 512mb que son el doble de grandes y sus componentes son mas pequeños)

-prueba 1
Desconecte una de las memorias y deje una.....
BIOS....deteccion 2048 mb,
ubuntu(64bits)...2024mb
Hice un analisis con memorytest86+....cero errores

-Prueba 2
El mismo proceso pero quitando la memoria que estaba puesta y poner la otra en el otro puerto de RAM...
Obtuve los mismos resultados que en la prueba anterior

-Prueba 3
Como disponia de las memorias viejas(de 512mb cada una) puse una de 2gb y otra de 512 (igual a como me detecta ubuntu
BIOS......2560mb
Ubuntu(64 bits).....2482mb(o algo muy parecido, aprox los 2560...diferencia de 78mb...teniendo en cuneta ke la targeta VGA integrada en su asignacion minima de RAM consume 32mb)

- Prueba 4
puse las dos memorias de 2gb
BIOS.....4096mb (como siempre)
ubuntu(64bits)......2482 mb
otra vez igual ..................................

otra observacion......aunque no creo quee tenga relacion.......ubuntu detecta 128mb de mi tarjeta grafica ATI radeon 1300/1550x series de 512mb......en windows si ke detecta los 512mb

+1
0
-1
Imagen de keopx
+1
0
-1

La verdad no se que decirte. Imagino que has probado a cambiarlas de canal. Las tienes el Dual chanel, no se dame mas pistas con estos datos no puedo ayudarte. Por cierto arrancandlo un live cd de 64 Bits que memoria te dice que tiene???

Un saludo

De todas maneras los datos te da tanto en Win como en Linux, así que doy por echo que tiene que ser alguna configuración.

www.keopx.net

+1
0
-1
Imagen de Inaxio182
+1
0
-1

lo de cambiarlas de canal a que te refieres? a cambiarlas de puerto/enchufe?
desconozco lo de Dua chanel....pero en el analisis de dmidecode e observado :
(...)
Type: SDRAM
Installed Size: 2048 MB (Double-bank Connection)
Enabled Size: 2048 MB (Double-bank Connection)
Error Status: OK

Handle 0x0009, DMI type 6, 12 bytes
Memory Module Information
Socket Designation: DIMM1
Bank Connections: 3 2
Current Speed: Unknown
Type: SDRAM
Installed Size: 512 MB (Single-bank Connection)
Enabled Size: 512 MB (Single-bank Connection)
Error Status: OK

tiene que con eso subrayado de single double bank connection ??
--------------------------
He estado mirando lo de dual channel ahora ya se que es..... mi placa si la soporta, y mis memorias tambien pero como lo activo?¿?¿? he visto algo de subirle el voltaje a la ram en la BIOS opcion AI, algo asi

+1
0
-1
Imagen de keopx
+1
0
-1

Si te fijas en donde estas las memorias hay 4 slot (ranuras) para memorias. 2 de un color y otras 2 de otro color. Bueno pues el Dual channel pon las memorias donde coincidan los colores (2 naranja y 2 amarillo), por ejemplo en las 2 amarillo. Automáticamente te debería de configurar como dual channel en la placa, en caso contrario tendrás que configurar la BIOS.

Placa Dual Channel

Como ya te dije, tiene que ser alguna configuración o algo similar, ya que en 2 OS te da el mismo problema.

Un saludo y ya me contaras.

PD: de todas maneras estas seguro que no son 2 memorias de 1GB que suman un total de 2GB no?¿?¿?¿ No lo pongo en dudad pero hay veces que lees la caja y pone 2GB pero son 2 memorias de 1GB, puede llevar a error.
www.keopx.net

+1
0
-1
Imagen de Inaxio182
+1
0
-1

http://www.ecs.com.tw/ECSWebSite/Products/ProductsDetail.aspx?CategoryID...

en esa direccion esta mi placa.....pero no se que hacer, una memoria esta en double bank connection y la otra en single, como lo cmabio? ahi pone que si soporta dual channel? ademas el procesador va a 266mhz tiene algo que ver?

+1
0
-1