Instalar y Activar Inalámbrico Broadcom En Ubuntu 9.10 (HP dv6620la)

Imagen de PHOBOS82
0 puntos

Hola banda:

Para todos aquellos que ayan instalado Ubuntu 9.10 y se ayan encontrado con la sorpresa de que su tarjeta de red inalámbrico Broadcom no funciona pues aquí les traigo unos pasos sencillos que a mi me funcionaron 100%. Pues les cuento...

Estuve varios días intentando configurar los driver para la tarjeta wifi BCM4322, en mi laptop HP dv6620la.

Luego de leer, buscar y rebuscar en varios foros encontré una solución. Compilando los drivers oficiales se puede lograr que funcione. Les detallo lo que hice por si le puede servir:

Antes que nada hay que revisar que su tarjeta inalámbrica sea una Broadcom, esto se hace tecleando el siguiente comando en la Terminal:

lspci

Si entre la lista de hardware les sale algo como esto "Network controller: Broadcom Corporation BCM4312 802.11a/b/g" entonces sigan los pasos que a continuación se mencionan; caso contrario busquen otro método.

Primero deben descargar el driver, disponible en 32 y 64 bit:

http://www.broadcom.com/support/802.11/linux_sta.php

Cuando lo ayan descargado descomprimen el archivo desde Terminal con el siguiente comando (en este caso es el de 32 bits):

tar -xzf hybrid-portsrc-x86_32-v5.10.91.9.3.tar.gz

En caso de que les aya creado una carpeta (en este caso con el nombre "hybrid-portsrc-x86_32-v5.10.91.9.3") simplemente entren a la carpeta con el comando "cd [NOMBRE DE LA CARPETA]":

cd hybrid-portsrc-x86_32-v5.10.91.9.3

Ahora a compilar el driver:

sudo make -C /lib/modules/`uname -r`/build M=`pwd`
sudo make install

Luego montamos los módulos para probarlos:

sudo modprobe lib80211_crypt_tkip
sudo insmod wl.ko
sudo cp wl.ko /lib/modules/`uname -r`/kernel/net/wireless/
sudo depmod -a
sudo modprobe -r b43 ssb wl
sudo modprobe wl

Si les detecto el inalámbrico y notaron que en la parte superior derecha salio su señal Wifi y la tarjeta se pudo conectar y desconectar entonces todo va de maravilla. Luego en la Terminal teclear esto:

sudo gedit /etc/rc.local

Y agregar las siguientes lineas antes del "exit 0":

modprobe -r b43 ssb wl
modprobe wl

Finalmente vamos a hacer que el modulo inicie automáticamente. Para ello abrimos el archivo "modules" con el siguiente comando para editarlo:

sudo gedit /etc/modules

Agregar esta linea al final:

lib80211_crypt_tkip

Ahora si entran en "Sistemas -> Administración -> Controladores de hardware" y deben ver los driver "Broadcom STA" activados.

Reinician y con esto al cargar de nuevo Ubuntu les debe de detectar el inalámbrico .

Espero que les sirva. Si no es así pues no resta mas que seguir buscando banda jajajaja.

Saludos desde Chiapas, México.

Bye =).

Imagen de Fantaguayaba
+1
0
-1

Gracias, soy demasiado novato en Ubuntu y tuve el mismo problema al instalar la versión 9.10, segui tus instrucciones al pie de la letra y funciono a la perfección. Excelente Aportación

+1
0
-1
Imagen de pablover20
+1
0
-1

Hola, al parecer mi targeta tampoco funciona, tengo un pavillion dv9925nr, y me imagino que el problema es el mismo, pero como soy nuevo en esto, no he aprendido muy bien eso de manejar las cosas con comandos. yo introduzco " tar -xzf hybrid-portsrc-x86_32-v5.10.91.9.3.tar.gz " pero me sale algo que dice No Existe el fichero o directorio, y con el comoando cd [Nombre de carpeta], no me funciona. en que lado debo tener el archivo para poderlo desinstalar?

+1
0
-1
Imagen de PHOBOS82
+1
0
-1

Pues revisa bien si se descargo correctamente el archivo "hybrid-portsrc-x86_32-v5.10.91.9.3.tar.gz" y en donde se descargo. Puede que se aya descargado en otra carpeta. Si no trata de bajarlo de manera "manual" desde el siguiente link:

http://www.broadcom.com/docs/linux_sta/hybrid-portsrc-x86_32-v5.10.91.9....

Guárdalo en tu carpeta "home". Luego revisa si ya puedes usar los comando de arriba.

Revisa tambien que el nombre del archivo que bajaste sea igual al del comando "tar -xzf hybrid-portsrc-x86_32-v5.10.91.9.3.tar.gz". Cualquier cosa estamos en contacto por este medio.

Bye =).

+1
0
-1
Imagen de pablover20
+1
0
-1

no me deja copiar nada en la carta home, y el archivo esta bien, lo volví a descargar y es el mismo... porfa, como hago, soy nuevo en esto de ubuntu y necesito mi wireless, si me puedes explicar paso a paso... te lo agradeciera.

+1
0
-1
Imagen de joaquingo
+1
0
-1

hola yo me compré una notebook con una broadcom 4315 y al probarla con el live cd la tarjeta funcionaba pero al instalar ubuntu no, entonces lo que hice fue agregar el cd como origen de software e instalar desde synaptic el controlador y listo.
Tal vez también funcione así para esa tarjeta, igual tu método esta bien para saber como se compila.

¡¡Soporte a Win2 0% a menos que el sexo de esa noche este en juego!!

Cuando  despierte la convenzo de ser libre

+1
0
-1

¡¡Soporte a Win2 0% a menos que el sexo de esa noche este en juego!!

Cuando  despierte la convenzo de ser libre

Imagen de chr15t14n
+1
0
-1

hermano gracias me funciono perfectamente te lo agradezco ya que soy totalmente nuevo y esto me sirve de mucho gracias

+1
0
-1
Imagen de onlycparra
+1
0
-1

no puedo compilar, dice que no existe el directorio... ¿que comillas son esas?
LINUX ES EL FUTURO SEÑORES.
---Dios les bendiga---

+1
0
-1

<<>>

Imagen de onlycparra
+1
0
-1

compilé, pero marqué y arrastré a fuerza de mouse... ¿cuáles con las comillas simples que se usa?
LINUX ES EL FUTURO SEÑORES.
---Dios les bendiga---

+1
0
-1

<<>>

Imagen de emguepo
+1
0
-1

tengo el mismo inconveniente y no he podido solucionarlo, soy defensor de linux, pero esto de que ya no reconozca los drivers del pc, deja mucho que pensar

Me sale esto: No Existe el fichero o directorio, y con el comando cd [Nombre de carpeta], no funciona.

Archivo bajado: hybrid-portsrc-x86_64-v5.10.91.9.3.tar.gz

mi nivel de uso en linux es intermedio, no soy un experto pero he aprendido a usar el terminal, no es complicado

+1
0
-1
Imagen de patricioumtz
+1
0
-1

completamente nuevo en linux, es la cuarta maquina que se lo instalo y cada vez agradezco mas el que exista el sistema y gente que ayude a que siga creciendo, mil gracias.

Por cierto es muy importante lo del home, eso quiere decir que cuando descarga la carpeta la cortemos de "descargas" y la saquemos a la carpeta de arriba, que tiene el nombre del usuario, sino nomas no pega jiji, saludos

+1
0
-1
Imagen de sinigamy
+1
0
-1

gracias por compartirlo
ya te escribo gracias a la claridad de tu post desde mi red inalambrica con un chip broadcom
salud compa

+1
0
-1

gracias por compartirlo

Imagen de alduxz
+1
0
-1

Tuve problemas a la hora de escribir esta linea (compilar)

sudo make -C /lib/modules/`uname -r`/build M=`pwd`

es un poco extraño creo k intentaba hacer algo en donde no habia la carpeta build

revisando en la carpeta lib/modules/ encontre 2 carpetas similares asi k cambie el nombre por

sudo make -C /lib/modules/2.6.31-14-generic/build M=`pwd`

y funciono perfecto es sencillisimo .

excelente amigo exitos.

AlduXz

+1
0
-1

AlduXz

Imagen de thydda
+1
0
-1

Hola, he hecho todos los pasos que dices pero cuando hago sudo modprobe -r b43 ssb wl me dice: FATAL: Module w1 not found

Ya no sé qué hacer. He buscado durante días para poder configurar la conexión wifi el linux pero siempre me da algún fallo.

Mi ordenador es un Mac y tengo instalado Linux Ubuntu 9.10 en una partición. ¿Puede tener algo que ver con esto?
¿Alguna respuesta?

Muchas gracias

+1
0
-1
Imagen de gusku
+1
0
-1

PHOBOS82, excelente tutorial, lo he seguido paso a paso y he conseguido porfiiiiin instalar la tarjeta wifi del Archos 9 en el Ubuntu 10.10 que me estaba dando dolores de cabeza desde hace 3 días.

Nuevamente muchísimas gracias.

PD: Ahora voy a pelearme con el resto de complementos
- Pantalla tactil
- Web Cam

+1
0
-1

--
http://www.desconsolados.com ¿Estudias?¿Trabajas?¿o Videojuegas?

Imagen de monkey.d.luffy
+1
0
-1

Te lo agradezco mucho, al parecer ya puedo conectarme sin ningun problema :D

+1
0
-1
Imagen de _Maverick_
+1
0
-1

Segui cada uno de los pasos y en el paso donde dice que ya deben estar activados los driver de la broadcom en "Sistemas -> Administración -> Controladores de hardware" no aparecen los driver "Broadcom STA" activados.

Y si me detecta las inalambricas y me puedo conectar pero al momento de reiniciar sigue con el mismo problema ya no me detecta las inalabricas

Mi tarjeta wifi es una "Network controller: Broadcom Corporation BCM4312 802.11a/b/g" igual a la que se describe ahi

Si me pudieran ayudar se los agradeceria de antemano. Saludos

+1
0
-1
Imagen de David14628
+1
0
-1

Hola me pregunto que si puedo usar esta información para hacer un vídeo

+1
0
-1
Imagen de Naranjon
+1
0
-1

Se que hace bastante tiempo desde que se creo este hilo, pero posiblemente buscando por Google para solucionar su problema acabaron aquí.

Yo hoy he intentado hacer todo lo que arriba se explica, pero me daban errores en el makefile. Buscando y buscando encontré este sitio en donde se da solución de una forma mas rápida: http://nfolamp.wordpress.com/2011/10/15/ubuntu-11-10-getting-wireless-bc...

Este método es para la tarjeta de red inalámbrica "Broadcom BCM4311", pero imagino que también funcionará en otras Broadcom. Mi versión de Ubuntu es 12.04, pero imagino que funcionará en todas las versiones (Soy un poco novato en el tema Ubuntu).

Si no quieren mirar la página que puse arriba, unicamente tienen que escribir POR ORDEN estas líneas en su terminal:
$ sudo apt-get update
$ sudo apt-get install firmware-b43-installer
$ sudo apt-get remove bcmwl-kernel-source
$ sudo reboot

La última línea les hará reiniciar la máquina para hacer efectivos los cambios.

De nada ;)

+1
0
-1