Problemón targeta gráfica nVidia FX 5500 (resolución muy baja) (solucionado)

Imagen de elwizard
0 puntos

Buenas de nuevo. Tengo un problemón con mi targeta de video. Resulta que tengo una nVidia FX 5500 (256 Mb) y tengo una resolución de 640x480px de pantalla. Mi monitor es de 17'' (agiler) Con esta resolución tan baja, me va muy mal para todo. Bajo Windows trabajo con una resolución de 1280x1024px, optima para mi.
He ido a Preferencias -> Sistema -> Pantalla y he intentado subir la resolución, pero lo más que hay es 640x480px (tengo auto, 640x480 y 320x240). Leyendo por este foro, no he encontrado ninguna respuesta de alguien que le pasara lo mismo, aunque si a gente que ha tenido problemas con la misma targeta. Entonces, instalé la aplicación de Nvidia X Server settings con el Synaptic, para configurar los controladores privativos, en Sistema -> Administración -> Controladores de Hardware en el cual tengo el controlador para targetas gráficas Nvidia (versiones 173 y 96), teniendo tan sólo activa la 173 (que me marca recomendada).

Usé también para instalar:

sudo aptitude install nvidia-settings

Lo extraño del caso es que si me trabaja la aceleración 3D y que dispongo de una profundidad de 16.7 Millones de colores (24 bits), que es la misma que en Windows.

Otra cosa que me he dado cuenta es que el monitor me pone desconocido CRT-0 (no sé si esto tiene importancia o no)

Mi ordenador dispone de AMD 2600+, 1Gb memoria RAM, y la targeta gráfica es por puerto AGP 8x.

Trabajo con Ubuntu 9.10 (instalé primero 9.04) y luego se me actualizó perfectamente).

Soy muy novato en el tema. A ver si alguien me puede hechar una mano y decirme como puedo subir la resolución y corregir este problemón, ya que ahora lo veo todo muy grande, y me cuesta mucho trabajo poder hacer este post.
Muchas gracias por anticipado.

Imagen de jespitec
+1
0
-1

He cambiado la tarjeta anterior, una ati 9200 SE por no llegar a alcanzar mayor resolución con mi monitor y al instalar este modelo lo máximo es 640 x 480. No funciona con los controladores privativos, yo diria que empeora. ¿Hay alguna solución?
Gracias por la ayuda y un saludo. Mi monitor es un TFT Sony.

+1
0
-1
Imagen de elwizard
+1
0
-1

Yo he mejorado algo, pero sigo sin conseguirlo.
Mejoras que he hecho:
1. Descargarme la versión de aquí, Ubuntu 9.10 Karmic Koala.
2. Ejecutar el Ubuntu desde el CDlive
3. Volver a instalar Ubuntu en el mismo Disco Duro (borrando la anterior) $ sudo gparted
4. Al reiniciar de nuevo, dispongo ya de 800x600px (es algo más de los 640x480px) aunque insuficiente aún.

Cosas que me han pasado. He vuelto a instalar los controladores privativos para mi targeta de vídeo y ZASCA! otra vez con 640x480px como máxima resolución. Desinstalo los controladores (173 recomendado), y vuelvo a tener 800x600px.
Increible. Con los controladores que supuestamente son de mi targeta, tengo menor resolución que sin tener los controladores.

@jespitec: me pregunto si a ti también te dice "Monitor desconocido" en rojo. Es que tal vez estemos enfocando algo mal y el problema sea más bien del monitor que no de la targeta en si.

+1
0
-1

Ubuntu User #29271

Imagen de an0nym0us
+1
0
-1

Hola, sin ver el contenido de tu /etc/X11/xorg.conf va a ser bastante dificil ayudarte. Una cosa que puedes hacer para crearte un xorg.conf es, una vez iniciado Ubuntu abre una terminal (lee todo bien antes de hacer nada) y pon:

$ sudo su

Así ya somos root, y después:


# killall gdm

Así matas el entorno gráfico. Después en la terminal ponemos:

# Xorg -configure

Nos creará un xorg.conf.new en la carpeta root, así que lo copiaremos a su carpeta correspondiente:

# cp /root/xorg.conf.new /etc/X11/xorg.conf

Después es cuestión de retocarlo un poco y poner las resoluciones que queramos:

# nano /etc/X11/xorg.conf

Fíjate en la sección "Screen" y en las Subsecciones Display. Añade la linea Modes para cara profundidad de color (Depht), y pones las resoluciones que quieras.

	SubSection "Display"
		Depth		16
		Modes		"1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Para guardar con nano es Control + O y enter, para salir Control + X. Después nos logueamos como usuario normal:

# su usuario

Donde usuario será el tuyo, y ya podemos iniciar las X

$ startx

Siempre pueda darte algún error, solo es cuestión de leer un poco y retocar lo que nos indique.

Un saludo.

-----------------------------------------------------------

Debian Squeeze/Sid GNU/Linux

http://adruca.blog.com.es/
http://doc.ubuntu-es.org/
http://www.esdebian.org/wiki

+1
0
-1

Dell Inspiron 1525 <> Core Duo T2370 @ 1.73GHz <> 2GB RAM <> Intel Graphics X3100 @ 384MB <>
Debian Squeeze 6.0 x86_64
Documentación de Ubuntu: http://doc.ubuntu-es.org/

Imagen de fantasialinux
+1
0
-1

Miraria el monitor, tengo la misma grafica, trabaja a 1280x1024, y en nvidia pone crt0(samsung), lo cual es correcto.
Si solo te pone crt0, pienso no esta bien configurado el monitor.
Reconfiguracion manual de Xorg o restablecer sistema x desde el reinicio del pc(modo depuracion) restablecer configuracion X.

Un saludo!

+1
0
-1
Imagen de elwizard
+1
0
-1

Ostras, muchas gracias. Esto ya me da un aliento. Lo que no sé es esto que me dices de "Reconfiguración manual de Xorg o restablecer sistema x desde el reinicio del pc(modo depuración) restablecer configuración X.". Hay algún documento donde yo pueda leerlo y aprender a editar el Xorg. Actualmente tan sólo puedo ir a 800x600px, sin usar los controladores privativos de mi targeta.
Lo cierto es que mi monitor es de marca Agiler modelo HD17A (creo que es un crónico de Acer pero no estoy seguro) TDT de 17'', y debe hacer como unos 10 años que me lo compré (pantalla tdt con 10 años que no se me ha roto ni un pixel, funcionando como el primer día). Esta compañía ya no existe (Google) y la verdad es que con el 'Ventanas' me lo detecta bien y a la primera, sin necesidad de drivers.
¿donde localizo el Xorg?
Muchas gracias de nuevo.

+1
0
-1

Ubuntu User #29271

Imagen de fantasialinux
+1
0
-1

La configuracion de las x esta en .../etc/x11/Xorg.conf, con lo cual lo puedes editar con "sudo gedit" y la ruta anterior.
Por otra parte ,mas sencillo ya que nos podemos equivocar en alguna linea de texto y dejar cao al sistema grafico, seria cuando inicias el pc, portada de bios o marca de la placa, si tiene logo, la mia es una asus y sale una cartelera de asus, despues de esto cuando va a arracar el pc , si pulsas "esc" puedes elegir modo depuracion, donde te acabara llevando a un menu con varias opciones y una de ellas es corregir el entorno X, es como un asistente y siempre es mas agradecido que hacerlo a mano.

Espero te valga.

Un saludo!

Cambios en 9.10..........no vale lo anterior...............
Ha investigar.

+1
0
-1
Imagen de eldoc
+1
0
-1

Es raro. Asumo que si tienes los efectos activados tienes instalado el controlador. Hace poco instalé ubuntu 9.04 en una máquina con esa placa y la resolución se configuró correctamente desde nvidia-settings (recordar que para que guarde los cambios hay que ejecutar con permisos de administrador). Prueba ejecutar "sudo nvidia-settings" (perdona si ya lo hiciste) y busca el apartado "X Server Display Configuration". Ahí está el botón para elegir resolución, selecciona la que quieres, la aplicas (Apply) y luego das click en el botón "Save to X Configuration File". Si te da algún error postéalo.

Saludos!

+1
0
-1
Imagen de elwizard
+1
0
-1

Muchas gracias a todos. Con las ayuditas que me estáis dando, y algunos otros posts que he leido por aquí sobre problemas similares, ya he logrado poner el monitor a 1024x768, y ya he aprendido a modificar el xorg. Aún me queda un poco, pero ahora lo veo todo mejor. Seguiré investigando sobre el asunto hasta que lo deje todo fino.
Si tengo algo ya os lo comento. Gracias.

+1
0
-1

Ubuntu User #29271

Imagen de elwizard
+1
0
-1

Solucionado. Como me temía en el primer post, el problema viene del monitor, no de los controladores privativos de la targeta gráfica, los cuales ahora trabajan bien. Una lección aprendida más. La verdad es que he tenido un poco de suerte, ya que los sincronismos horizontales y verticales del monitor no los podía averiguar de ninguna forma (que yo sepa). Poniendo unos genéricos han resultado funcionar perfectamente. Ahora dispongo de un gran rango de resoluciones. Muchas gracias a todos.

Ahora me queda el archivo xorg.conf así (para futuros usuarios):

Rango de frecuencias para el monitor Agiler HD-17A es:

        HorizSync 31-64
        VertRefresh 50-120
Section "Monitor"
        Identifier "Monitor genérico"
        HorizSync 31-64
        VertRefresh 50-120
        Option "DPMS"
EndSection

Section "Screen"
	Identifier "Configured Screen Device"
        Monitor "Monitor genérico"
        Device "Configured Video Device"
	DefaultDepth 24
        SubSection "Display"
        Depth 1
        Modes "1440x900" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 4
        Modes "1440x900" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 8
        Modes "1440x900" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 16
        Modes "1440x900" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
        Depth 24
        Modes "1440x900" "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "Device"
	Identifier "Configured Video Device"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection
+1
0
-1

Ubuntu User #29271