sudo aptitude install "soprano-backend-sesame"

Imagen de aberfert
0 puntos

Hola a todos! Estoy intentando activar nepomuk y el servicio strigi de kde pero necesito instalar el paquete que aparece en el asunto y no me deja. No se por donde seguir pues ya he seguido muchos tutoriales pero ninguno me "apaña" o me da solución a ese problemilla con ese paquete. A ver si alguien me puede ayudar, en el terminal aparece lo siguiente:

dani@dani-laptop:~$ sudo aptitude install soprano-backend-sesame
[sudo] password for dani:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Los siguientes paquetes están ROTOS:
soprano-backend-sesame
0 paquetes actualizados, 1 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 1561kB de ficheros. Después de desempaquetar se usarán 1925kB.
No se satisfacen las dependencias de los siguientes paquetes:
soprano-backend-sesame: Depende: libqtcore4 (>= 4:4.5.2) pero está instalado 4.5.3really4.5.2-0ubuntu1.
Las acciones siguientes resolverán estas dependencias

Instalar los paquetes siguientes:
soprano-backend-sesame [2.3.0-0ubuntu1 (karmic)]

La puntuación es -9920

¿Acepta esta solución? [Y/n/q/?]

Si dices "no" no hace nada. Si dices "q" aborta. Si dices "yes" aparece:

¿Acepta esta solución? [Y/n/q/?] y
Se instalarán los siguiente paquetes NUEVOS:
soprano-backend-sesame
0 paquetes actualizados, 1 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0B/1564kB de archivos. Después de desempaquetar se usarán 1933kB.
¿Quiere continuar? [Y/n/?]

Si dices "Yes" aparece:

Escribiendo información de estado extendido... Hecho
debconf: no se pudo inicializar la interfaz: Dialog
debconf: (Necesita una pantalla de al menos 13 líneas de alto y 31 columnas de ancho para la interfaz «dialog».)
debconf: probando ahora la interfaz: Readline
Seleccionando el paquete soprano-backend-sesame previamente no seleccionado.
(Leyendo la base de datos ... 00%
183806 ficheros y directorios instalados actualmente.)
Desempaquetando soprano-backend-sesame (de .../soprano-backend-sesame_2.3.0-0ubuntu1_amd64.deb) ...
Configurando soprano-backend-sesame (2.3.0-0ubuntu1) ...
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Leyendo la información de estado extendido
Inicializando el estado de los paquetes... Hecho
Escribiendo información de estado extendido... Hecho

Parece que todo perfecto. Pero ejectutas strigi y aparece un update de kde para instalar de nuevo ese paquete, por tanto strigi continua sin funcionar.
Si accedes a synaptic y buscas el paquete soprano-backend-sesame aparece con un cuadro verde (aparentemente instalado) y una estrellita, y se puede marcar para actualizar,sin embargo, cuando aplicas cambios te dice de nuevo que ese paquete:
soprano-backend-sesame:
Depende: libqtcore4 (>=4:4.5.2) pero se va a instalar 4.5.3really4.5.2-0ubuntu1

Gracias, un saludo.
Y espero que alguien le haya pasado lo mismo y lo haya solucionado!!

Imagen de Goyo
+1
0
-1

Si aparece con un cuadro verde es que está instalado. Si aparece además con una estrella es porque hay disponible otra versión que apt considera preferible y te propone actualizarla, pero es esa otra versión la que te da problemas de dependencias.

Aparentemente tienes algún repositorio que no es compatible con Karmic o que depende a su vez de otro repositorio que no tienes. Además sospecho que la versión que apt considera superior es en realidad inferior y que se ha hecho un lío con la numeración.

Las cartas no me dicen más.

+1
0
-1
Imagen de aberfert
+1
0
-1

Muchas gracias!
Tus cartas me han servido de mucha ayuda.
Eliminé de los repositorios el enlace que me daba problemas y voilá, se solucionó.
El propósito era activar escritorio semántico con el servicio strigi, por tanto, continué el tutorial desde ese punto y conseguí solucionarlo perfectament!

Muchas gracias de nuevo.
POST SOLUCIONADO

+1
0
-1