kde4 no inicia sesion grafica en ubuntu 9.10

Imagen de pepitito
0 puntos

Que tal. Por ahi es un tema que vieron titulado parecido en otras partes. He leido bastantes de esos post y finalmente ninguno de ellos contemplaba mi problema, por lo que creo no estar violando las reglas del foro.
Uso ubuntu karmic (9.10) que funciona de maravillas. Instale escritorio de xubuntu y anda perfecto. El problema surgio cuando instale kde4 , ya que al poner mi nombre y contraseña , empieza a cargar, hace un pantallazo negro y vuelve a la pantalla de inicio de sesion.
Info adicional: antes usaba hardy (8,04) y paso exactamente lo mismo, con la salvedad que ademas de estos escritorios, tambien tenia kde3.5 que funcionaba correctamente.
Hice correr kubuntu 9.10 en virtualbox y carga bien el escritorio, por lo que queme un cd y probe con live cd. Cargo tambien el live cd (por esto pienso que no es una cuestion de la tarjeta grafica)
Sigo sin poder iniciar kde4 desde el rigido en compañia de gnome y xfce.
Pentium IV 3.00 ghz placa asus P5VDC-MX
memoria ddr2 2gb
placa integrada via unichrome pro igp 64mb
Alguien podria ayudarme?
muchas gracias

Imagen de Adrian Montoya Lince
+1
0
-1

Si te carga con xubuntu y gnome, no creo que sea problemas de la tarjeta gráfica.. ya que te pasaria lo mismo en todos los gestores de ventanas...

Me parece mas bien un problema con el kdm. Yo haria primero una reconfiguracion del paquete: #sudo dpgk-reconfigure kdm
Te pedirá que escojas el gestor por defecto, ya que tienes instalados varios.

Un detalle: hay un bug conocido con el kdm en karmic, cuando en el fstab no se tienen montadas las particiones adicionales del disco. Te recomendaria que si tienes particiones windows las definas previamente en el fstab.

Espero que eso te sirva, suerte!

Adrián Montoya Lince
Linux User #319165

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de pepitito
+1
0
-1

Te agradezco mucho por contestar.
LO de reconfigurar kdm ya lo hice varias veces y alterne entre kdm y gdm sin resultados.
Con respecto al punto de fstab, no tengo windows en mi disco.
lo que note es que con gestor de ventanas metacity inicia sesion en kde, solo que con una distribucion de los elementos un tanto rara y con algunas cosas de la barra que no funcionan.
Si elijo gestor de ventanas kwin hace el mismo pantallazo negro y vuelve a gdm (o kdm segun el caso). Descubri tambien que si estoy en gnome y cambio de gestor de metacity a kwin pasa exactamente lo mismo. Por eso pienso, no lo se, que lo que funciona mal es kwin (raro igual que con kubuntu en virtualbox cargue sin problemas) No se si hay alguna manera de ver que pasa con este gestor. Si aun es inetsable, si kde dejo de lado a los que no tienen una tarjeta mejor que una integrada o si es una particularidad en la configuracion de mi pc (espero que sea esta ultima porque es la unica que me deja aun una alternativa)
BUeno , muchas gracias. Espero mas respuestas y ayuda. Saludos.

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

mmm... esta raro el asunto.. Sigo pensando en algún bug en el gestor de ventanas que tenga que ver con la correcta configuracion de las X11.. ¿?

Aunque no tiene nada que ver.. por que no borras las configuraciones KDE de tu usuario?. Quiza pueda ser problema del entorno de usuario de KDE!
# rm -rf .kde

De todas maneras siempre es bueno que leas algunos detalles del karmic: http://www.ubuntu.com/getubuntu/releasenotes/910 que te podrían dar alguna idea si el problema persiste.

Lamento no poder ayudarte más en el asunto,

Suerte!

Adrián Montoya Lince
Linux User #319165

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de pepitito
+1
0
-1

gracias por tu ayuda. Hice lo que me dijiste pero sigue todo igual. LO de la configuracion de las x no se donde fijarme,ya que para mi sorpresa descubri que no tengo xorg.conf y parece que karmic ya no usa.si a vos o a alguien mas se les ocurre algo agradecidisimo. Igual gracias por responderme dos veces. Si logro solucionar, lo escribo

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

Karmic si usa el archivo xorg.org, si no existe entonces efectivamente tienes un problema... para generarlo usa:

#sudo Xorg -configure

Suerte!

Adrián Montoya Lince
Linux User #319165

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de Panko
+1
0
-1

Permiteme corregirte, pero no, no usa xorg.conf si no se halla en el sistema...
Hal usa "modo hotplug" en las ultimas versiones y es capaz de reconocer y configurar los distintos dispositivos en el sistema sin necesidad de la existencia del archivo /etc/X11/xorg.conf
En el caso de que se trate de una grafica como ati o nvidia, con controladores propietarios, entonces si que deberia generar un xorg.conf para asegurarse de que el sistema usa el driver correspondiente. En otro caso, no suele ser necesaria la existencia de ese archivo...
Yo buscaria bugs relacionados con la grafica y kde, que parece que van por ahi los tiros...
Para ver los errores, si al arrancar te ha dado algun problema, puedes mirar en el home de tu usuario, un archivo llamado .xsession-errors, ahi tendrás un log de lo ocurrido en el inicio de sesion de las X.
Tambien puedes probar, una vez seleccionado kde como entorno por defecto, salirte a una tty pulsando alt+F1 p.e. y una vez alli, teclar startx para que inicie el entorno grafico sin pasar por kdm/gmd y ver el error que da en caso de no iniciar...
Salu2.

+1
0
-1
Imagen de Adrian Montoya Lince
+1
0
-1

Gracias Panko! No sabia lo del modo hotplug

Adrián Montoya Lince
Linux User #319165

+1
0
-1

Adrián Montoya Lince
Linux User #319165

Imagen de pepitito
+1
0
-1

gracias a ambos por responder.
el archivo .xsession-errors luego de querer entrar en kde fallidamente y leido posteriormente al entrar en gnome es

/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=es_AR.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/none.
gnome-session[4799]: WARNING: Could not parse desktop file /home/nicoylau/.config/autostart/xfconf-migration-4.6.desktop: El archivo clave no tiene la clave «Name»
gnome-session[4799]: WARNING: could not read /home/nicoylau/.config/autostart/xfconf-migration-4.6.desktop
gnome-session[4799]: WARNING: Could not parse desktop file /home/nicoylau/.config/autostart/xfce4-settings-helper-autostart.desktop: El archivo clave no tiene la clave «Name»
gnome-session[4799]: WARNING: could not read /home/nicoylau/.config/autostart/xfce4-settings-helper-autostart.desktop
GNOME_KEYRING_SOCKET=/tmp/keyring-Moez0b/socket
SSH_AUTH_SOCK=/tmp/keyring-Moez0b/socket.ssh

(gnome-settings-daemon:4871): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(gnome-settings-daemon:4871): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
Unable to find a synaptics device.
Advertencia del gestor de ventanas: Ocurrió un error al leer el archivo de sesión guardado /home/nicoylau/.config/metacity/sessions/10d831effc95daa13012638418853058400000047990031.ms: Ha ocurrido un error al abrir el archivo «/home/nicoylau/.config/metacity/sessions/10d831effc95daa13012638418853058400000047990031.ms»:·No existe el fichero ó directorio

(polkit-gnome-authentication-agent-1:4930): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:4930): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(nautilus:4903): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

MCS->Xfconf settings migration complete

** Message: Reading of RFKILL events failed
** Message: killswitches state 3
** Message: killswitches state 3
** (gnome-panel:4902): DEBUG: Adding applet 0.
** (gnome-panel:4902): DEBUG: Initialized Panel Applet Signaler.
/usr/share/smart-notifier/smart_notifier/gui.py:51: DeprecationWarning: Passing the named_service parameter to add_signal_receiver by name is deprecated: please use positional parameters
path=smart_notifier.UD_SERVICE)
** (gnome-panel:4902): DEBUG: Adding applet 1.
** (gnome-panel:4902): DEBUG: Adding applet 2.
Initializing nautilus-gdu extension
** (gnome-panel:4902): DEBUG: Adding applet 3.
** (gnome-panel:4902): DEBUG: Adding applet 4.
** (gnome-panel:4902): DEBUG: Adding applet 5.
** (gnome-panel:4902): DEBUG: Adding applet 6.
** (gnome-panel:4902): DEBUG: Adding applet 7.

** (nautilus:4903): WARNING **: No marshaller for signature of signal 'UploadFinished'

** (nautilus:4903): WARNING **: No marshaller for signature of signal 'DownloadFinished'

** (nautilus:4903): WARNING **: No marshaller for signature of signal 'ShareCreateError'
** (gnome-panel:4902): DEBUG: Adding applet 8.
Nautilus-Share-Message: Called "net usershare info" but it failed: La «red compartida» devolvió el error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No existe el fichero ó directorio
Please ask your system administrator to enable user sharing.

** (gnome-panel:4902): DEBUG: Adding applet 9.
** (gnome-panel:4902): DEBUG: Adding applet 10.
** (gnome-panel:4902): DEBUG: Adding applet 11.

(nautilus:4999): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
evolution-alarm-notify-Message: Setting timeout for 28084 1263870000 1263841916
evolution-alarm-notify-Message: Tue Jan 19 00:00:00 2010

evolution-alarm-notify-Message: Mon Jan 18 16:11:56 2010

lo de entrar en tty y hacer startx no resulta seleccionando kde ni gnome. Por ahi lo estoy haciendo mal. No se si con esta info se puede hacer algo.
Agradezco mucho las respuestas

+1
0
-1
Imagen de Panko
+1
0
-1

Me parece que ese archivo no nos sirve para ayudarte, ya que esos errores parecen mas bien de la sesion de gnome...
No te asustes, muchas veces es normal encontrar errores en ese archivo aun cuando hayas iniciado sesion y todo funcione bien...
Para que podamos ver los errores procedentes de kde, tienes que hacer lo siguiente:
1.- Cierra tu sesion de gnome o xfce
2.- Intenta iniciar sesion en kde.
3.- en el momento que te vuelva a gdm/kdm, pulsa CTRL+ALT+F1 para irte a una tty
4.- introduce tu nombre de usuario en Login y tu pass en Password
5.- Una vez estés loggeado en la tty, usa el comando

cp ~/.xsession-errors ~/xsession-errors-kde

6.- ahora ya puedes cerrar la sesion de tty con el comando exit.
7.- pulsa ALT+F7 y volverás a la sesion grafica con gdm/kdm.

Ahora ya puedes iniciar tu sesion de gnome y xfce normalmente y ponernos el contenido del archivo xsession-error-kde que has copiado antes, asi veremos los errores de inicio de sesion en kde.

+1
0
-1
Imagen de pepitito
+1
0
-1

hice lo que me dijiste y es de no creer. Luego de querer entrar fallidamente a kde no se puede ir a tty.Se tilda en una pantalla negra con colores.
tambien hice lo otro que me dijiste, que inicie kde como predeterminado desde tty con startx y ahi se congelaba la pantalla de carga de kde y no respondia ni teclado ni mousse.
asi que tampoco puedo ver cual es el error en cuestion. Se te ocurre algo? estara viva esta pc?
gracias por responder
Espero tu respuesta

+1
0
-1
Imagen de Panko
+1
0
-1

Pues la verdad, poco se me ocurre ya...

volviendo a la cuestion de que el problema surgio al instalar kde$, puedes probar desde una consola, en la sesion de gnome mismo, es indiferente, uno de los siguientes comandos:

sudo aptitude install -f
sudo apt-get --install -f
sudo dpkg --configure -a

cualquiera de los tres te valdria, aunque para asegurarse, uno de los primeros (aptitude o apt-get) y luego el tercero (dpkg). Con esto se reintenta/acaba una instalacion/actualizacion que no se ha hecho correctamente. (no creo que valga para nada si luego has instalado o actualizado algo, ya que si fuera ese el problema, no lo podrias haber hecho, pero bueno, por probar xD)

Otra cosilla que puedes probar, es buscar con synaptic mismo todos los paquetes de KDE que estén instalados y marcarlos para una reinstalacion, ya que estando en una sesion gnome/xfce, estos no se encontrarán en uso (al menos la mayoria de ellos) y será mas segura dicha reinstalacion...

Otra cosa no se me ocurre... bueno si, desinstalar todo lo que tengas instalado de kde y luego volver a instalarlo, de este modo se perderán algunas configuraciones, pero muchas de ellas permanecerán en tu home y aparecerán al volver a instalar los paquetes...

Suerte!

P.D.: ¿has buscado errores / bugs en foros/páginas de ubuntu ó kde de posibles incompatibilidades de KDE con tu gráfica?

+1
0
-1
Imagen de pepitito
+1
0
-1

busque en paginas, pero nada es concluyente. Incluso algunos hablan de problemas con tarjetas ati o nvidia, pero nada oficial. Yo tengo una integrada via unichrome que ubuntu detecto muy bien, tengo aceleracion grafica tengo activado el compositor de metacity. Compiz no soporta, pero bueno, es logico. Incluso en una pagina un sujeto me dijo que tenia un perfil de hardware muy parecido al mio con la misma tarjeta y que tenia gnome y kde.
Probe con los truquitos que me diste y desinstalo algunas cosas e instalo otras pero todo sigue igual.
Ya habia probado esto de marcar con synaptic. Es mas marque uno por uno para que los desinstale definitivamente (borrando tambien las configuraciones y todo igual.
En virtual box instale kubuntu sin problemas y es la misma tarjeta y tambien probe kubuntu live cd y carga el escritorio.
xfce y fluxbox andan sin problemas y cuando tenia hardy habia instalado kde3 sin problemas Tambien en ese entonces habia instalado el kde4 y pasaba lo mismo que ahora (eso es que no cargaba) Por eso no se si sera por algo de configuracion. LO extraño es que si fuera problema de tarjeta no cargaria nunca kde4 y en el virtualbox he cargado mandriva open suse kubuntu y nunca hubo problemas mas lo que dije que probe kubuntu con live cd y tambien carga.
En fin , no tengo ni idea.
Te agradezco mucho tu ayuda.

+1
0
-1