No puedo instalar el gcc

Imagen de ViChO
0 puntos

Bueno antes que nada saludos!!

tengo un problema horrible :S no puedo instalar el gcc g++ y no se exactamente porque.

A decir verdad soy novato en el mundo linux pero tengo un poco de nocion sobre el tema.

Bueno pues he intentado con apt-get install gcc y me sale lo siguiente:

root@simon:/home/vicho # apt-get install gcc
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
gcc: Depende: cpp (>= 4:3.3.5-1) pero 4:3.3.4-1 va a ser instalado
Depende: gcc-3.3 (>= 1:3.3.5-1) pero no va a instalarse
Depende: cpp-3.3 (>= 1:3.3.5-1) pero 1:3.3.4-9ubuntu5 va a ser instalado
gcc-3.2: Depende: cpp-3.2 (>= 1:3.2.3-5.bunk) pero no va a instalarse
Depende: cpp-3.2 (< 1:3.2.4) pero no va a instalarse
xmms-geekosphere: Depende: mesag3
Depende: xlib6g (>= 3.3.4-0slink1) pero no es instalable
W: No se puede leer la lista de paquetes fuente http://www.tux.org woody/main Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_woody_main_binary-i386_Packages) - stat (2 No existe el fichero o el directorio)
W: No se puede leer la lista de paquetes fuente http://www.tux.org woody/non-free Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_woody_non-free_binary-i386_Packages) - stat (2 No existe el fichero o el directorio)
W: Tal vez quiera ejecutar 'apt-get update' para corregir estos problemas
E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).
root@simon:/home/vicho #
-----------------------------------------

y con apt-get install gcj:

ot@simon:/home/vicho # apt-get install gcj
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
gcc-3.2: Depende: cpp-3.2 (>= 1:3.2.3-5.bunk) pero no va a instalarse
Depende: cpp-3.2 (< 1:3.2.4) pero no va a instalarse
gcj: Depende: cpp (>= 4:3.3.5-1) pero 4:3.3.4-1 va a ser instalado
Depende: gcc (>= 4:3.3.5-1) pero no va a instalarse
Depende: g++ (>= 4:3.3.5-1) pero no va a instalarse
Depende: gcj-3.3 (>= 1:3.3.5-1) pero no va a instalarse
xmms-geekosphere: Depende: mesag3
Depende: xlib6g (>= 3.3.4-0slink1) pero no es instalable
W: No se puede leer la lista de paquetes fuente http://www.tux.org woody/main Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_woody_main_binary-i386_Packages) - stat (2 No existe el fichero o el directorio)
W: No se puede leer la lista de paquetes fuente http://www.tux.org woody/non-free Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_woody_non-free_binary-i386_Packages) - stat (2 No existe el fichero o el directorio)
W: Tal vez quiera ejecutar 'apt-get update' para corregir estos problemas
E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).
root@simon:/home/vicho #

----------------------------------------

con apt-get install linux-source-2.6.8.1 :

root@simon:/home/vicho # apt-get install linux-source-2.6.8.1
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
El paquete linux-source-2.6.8.1 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
W: No se puede leer la lista de paquetes fuente http://www.tux.org woody/main Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_woody_main_binary-i386_Packages) - stat (2 No existe el fichero o el directorio)
W: No se puede leer la lista de paquetes fuente http://www.tux.org woody/non-free Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_woody_non-free_binary-i386_Packages) - stat (2 No existe el fichero o el directorio)
W: Tal vez quiera ejecutar 'apt-get update' para corregir estos problemas
E: El paquete linux-source-2.6.8.1 no tiene candidato para su instalación
root@simon:/home/vicho #

--------------------

Lo peor del caso es que no me corrige los errores con el apt-get update

:\ entonces ya no tengo ni idea de que tengo que hacer para poder instalar y utilizar el gcc y si me urge trabajar en ello :S

alguien sabe que me esta pasando? o como podria solucionarlo?

de ante mano muchas gracias !!!!

Imagen de bull3tpr00f
+1
0
-1

hola
postea porfavor tu archivo /etc/apt/sources.list para que le echemos un ojo.
Otra cosa, desde synaptic tambien te ocurre??

Saludos

________________________________________

Blog de cutOff

+1
0
-1
Imagen de ViChO
+1
0
-1

Bueno aqui les posteo mi sources.list :

#deb cdrom:[Debian GNU/Linux 20030727 _Sid_ - fsn.hu unofficial i386 Binary-2 ($#deb cdrom:[Debian GNU/Linux 20030716 _Sid_ - fsn.hu unofficial i386 Binary-3 ($#deb cdrom:[Debian GNU/Linux 20030727 _Sid_ - fsn.hu unofficial i386 Binary-1 ($#deb cdrom:[Debian GNU/Linux 20030727 _Sid_ - fsn.hu unofficial i386 Binary-4 ($#deb cdrom:[Debian GNU/Linux 3.0 r1 _Woody_ - Official i386 Binary-1 (20021218)$
# main debian mirrors - track testing and unstable
deb ftp://ftp.us.debian.org/debian/ testing main non-free contrib
deb ftp://ftp.us.debian.org/debian/ unstable main non-free contrib
deb http://non-us.debian.org/debian-non-US/ testing/non-US main contrib non-fre$deb http://non-us.debian.org/debian-non-US/ unstable/non-US main contrib non-fr$
# sources
deb-src http://non-us.debian.org/debian-non-US/ testing/non-US main contrib non$deb-src ftp://ftp.us.debian.org/debian/ testing main non-free contrib

# DVD/mplayer packages
deb ftp://ftp.nerim.net/debian-marillat/ testing main
# deb ftp://ftp.nerim.net/debian-marillat/ unstable main

# mplayer+skins
#deb http://twolife.free.fr/debian/ unstable main non-free

# Blackdown Java
deb http://www.tux.org/pub/java/debian/ woody main non-free

# Unofficial cr.yp.to packages
# deb http://smarden.org/pape/Debian/ woody unofficial pape
# deb-src http://smarden.org/pape/Debian/ woody unofficial pape

# Odd packages which were removed
# deb ftp://ftp.mowgli.ch/pub/debian/ sid unofficial

# Misc games and whanot

# games, xmms plugins, X on screen display, Flightgear, Fortunes,Quake,
# Acroread, flashplayer-mozilla, KDE applets, KDE themes, A/V codecs and tools,
#
# Mencoder, Mplayer, OGMtools, WINE and otheres# #

#deb http://jeroen.coekaerts.be/debian/ unstable main contrib non-free mirror
# deb-src http://jeroen.coekaerts.be/debian/ unstable main contrib non-free

# silc-client
# deb http://silcnet.org/download/client/deb/ ./
# deb-src http://silcnet.org/download/client/deb/ ./

# Extra wallpapers
# deb http://www.steve.org.uk/apt/ ./
# deb-src http://www.steve.org.uk/apt/ ./

# k3b
deb http://www.planet-moll.de/debian/ sarge main

# opera grabber
# deb http://www-katzien.de/debain/opera ./

-----------------------------------------------------------

Bueno este es mi sources.list pero hay un pequeño problema :\ este soirces.list me lo paso un amigo que usa Debian y cometi el error de ponerlo en lugar del que tenia y no respalde el antiguo o_O

asi que pues yo creo que por eso es el problema :\ bueno si alguien me puede ayudar se los agradeceria :S no me gusta la idea de tener que pasarme a windows para programar en C o_O

saludos!!!

CLC
http://www.Linux-Chetumal.org

+1
0
-1
Imagen de bull3tpr00f
+1
0
-1

pues sí, creo que ese es el problema. Personalmente te recomiendo utilizar solo los repositorios oficiales de Ubuntu (que nada tienen que envidiar a los de Debian). Echale un ojo a la guia-ubuntu, en la que lo tienes perfectamente detallado.

Salut!

________________________________________

Blog de cutOff

+1
0
-1
Imagen de Anónimo
+1
0
-1

Acabo de resolver un problema similar. Me pedia el CD de Ubuntu para instalar los paquetes necesarios para gcc. Yo le habia regalado el CD a un amigo, y, novato yo, decidi descargar otro cd de ubuntu para poder instalar gcc, pensando que de cualquier forma otro cd no me vendria mal.
Sin embargo, en la informacion de repositorios de Synaptics venia el CD original, distinto del CD que acababa de quemar. Para resolverlo, elimine el cd de la lista de repositorios y ya ta. Se lo descargo de internet sin mayor problema.

+1
0
-1
Imagen de zodman
+1
0
-1

creo que estas agregando al source.list del apt
reposorios incorrectos

repositorios debian != reposiitorios ubuntu

ubuntu es basado een debian
pero q io sepa no funciona revolver repositorios

+1
0
-1

www.zod.com.mx
arriba el punk!