Problemas al instalar dependencias[SOLUCIONADO]

Imagen de gonzalo_taflik
0 puntos

hola tengo un par de problemas con libqt4 y cada ves que intento instalar algo me dice las dependencias no se pueden resolver les pongo la info de la terminal:

aflik@roberto-desktop:~$ dpkg --get-selections | grep linux-image
linux-image-2.6.28-11-generic install
linux-image-2.6.28-18-generic install
linux-image-2.6.31-20-generic install
linux-image-2.6.31-21-generic install
linux-image-2.6.32-22-generic deinstall
linux-image-2.6.32-23-generic deinstall
linux-image-2.6.32-24-generic install
linux-image-2.6.35-22-generic install
linux-image-2.6.35-23-generic install
linux-image-generic install
taflik@roberto-desktop:~$ uname -a
Linux roberto-desktop 2.6.35-23-generic #37-Ubuntu SMP Fri Nov 5 19:16:29 UTC 2010 x86_64 GNU/Linux

cuando quiero instalar algo como mixxx me dice lo sig:
sudo apt-get install mixxx
[sudo] password for taflik:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
mixxx : Depende: libqt4-network (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-opengl (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-qt3support (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-script (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-sql (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-svg (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-xml (>= 4:4.5.3) pero no va a instalarse
Depende: libqt4-xmlpatterns (>= 4:4.5.3) pero no va a instalarse
Depende: libqtgui4 (>= 4:4.6.1) pero no va a instalarse
Depende: libqtwebkit4 (>= 2.0~week31) pero no va a instalarse
Depende: libqt4-sql-sqlite pero no va a instalarse
E: Paquetes rotos

gracias por vuestra ayuda!

Imagen de Goyo
+1
0
-1

¿Qué versión de libqt4-network tienes disponible para instalar?

+1
0
-1
Imagen de gonzalo_taflik
+1
0
-1

tengo la vercion: 4:4.7.0-ubuntu 4.,,pero cuando intento instalarla me dice esto:

libqt4-network:
Depende: libqt4-dbus pero no va a ser instalado
Depende: libqtcore4 (=4:4.7.0-0ubuntu4) pero se va a instalar 4:4.7.0-0ubuntu4.1

y asi con casi todos los paquetes :S

+1
0
-1

_gonzalo a.taflik_

Imagen de Goyo
+1
0
-1

Instala previamente la versión 4:4.7.0-0ubuntu4 de libqtcore4 y vuelve a intentarlo. Asegurate de no actualizar libqtcore4 a la versión 4:4.7.0-0ubuntu4.1.

Te recomiendo que consideres la posibilidad de eliminar el repositorio de donde venga ese libqtcore4 en versión 4:4.7.0-0ubuntu4.1, contiene una versión incompleta de Qt4 que te está creando problemas y probablemente continuará haciéndolo.

+1
0
-1
Imagen de gonzalo_taflik
+1
0
-1

gracias!! lo pude solucionar instalando la vercion anterior

+1
0
-1

_gonzalo a.taflik_

Imagen de gonzalo_taflik
+1
0
-1

tendra algo que ver con la sources.list ??

+1
0
-1

_gonzalo a.taflik_

Imagen de Scorpyo82
+1
0
-1

Gonzalo, si es el source.list que te pasé, no tiene nada añadido, por lo menos por mí!

Lo unico que hice fue activar los repositorios universe y multiverse.

Y de lo que te pasa no tengo ni idea.

Siento no poder ayudarte.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de gonzalo_taflik
+1
0
-1

si,si no importa provare aciondo eso de cambiar previamente

+1
0
-1

_gonzalo a.taflik_

Imagen de albert_arbiol
+1
0
-1

**/Moderado/**

Las preguntas en su propio hilo por favor. Gracias.

+1
0
-1