Desesperado porque no puedo editar menú aplicaciones y me han desaparecido Administración y Preferencias - ubuntu 10.10

Imagen de truchas
0 puntos

Hola

Ayer instalando una aplicación y sin venir a cuento las aplicaciones que tenía instaladas en el menú de aplicaciones desaparecieron. Miré por el foro y pude recuperarlas pero ahora no puedo entrar con el botón derecho a Editar los menús y además me he dado cuenta que me han desaparecido de Sistema las opciones de Administración y Preferencias, por lo cual no puedo acceder a nada del sistema.

Estoy mirando por el foro pero no encuentro la solución. No sé si es problema de permisos o no, pero estoy perdido. Llevo poco tiempo con ubuntu y no encuentro la solución.

Gracias de antemano por vuestra ayuda, el ordenador que tengo es el que uso para trabajar y estoy desesperado.

Un saludo

Imagen de anselo
+1
0
-1

Abre una terminal y copia y pega secuencialmente estas tres órdenes. A cada una pulsa "Entrar"

gconftool-2 --shutdown
rm -rf ~/.gconf/apps/panel
pkill gnome-panel

Y paneles como nuevos.

+1
0
-1

Saludos y suerte

Usa el Botón Buscar, DocUbuntu Guía Ubuntu Mi Blog

Imagen de truchas
+1
0
-1

Gracias anselo por tu correo.

He seguido tus instrucciones, ha desaparecido por un momento el panel superior y ha vuelto a aparecer pero sigo sin poder acceder e Editar los menús y no aparecen Sistema y Preferencias. Parece como si hubiese perdido los permisos para modificar el ubuntu. ¿Hay alguna manera para saber que permisos tengo y si estoy como súper usuario?

Gracias

+1
0
-1
Imagen de anselo
+1
0
-1

Al menu se puede acceder desde Sistema/Preferencias/Menú del sistema pero ya que no te aparece Sistema, pulsa Alt + F2 y en la caja de texto escribe alacarte. Esto debería abrir "Editar el menú". A ver si por ahí ves lo que pasa.
Para editar el menú no es necesario ser superusuario.

+1
0
-1

Saludos y suerte

Usa el Botón Buscar, DocUbuntu Guía Ubuntu Mi Blog

Imagen de truchas
+1
0
-1

Hola anselo

Cuando ejecuto alacarte no hace nada.

Buscando por el foro he conseguido al menos parchear el problema instalando el gnome-control-center pero aun así no puedo entrar a modificar los menús.

Una pregunta: Si reinstalo el ubuntu 10.10, ¿hay alguna manera de conservar todos los programas instalados e iconos? El backup que hago de mi carpeta personal se restaura tal cual en la nueva instalación y vería lo mismo que tenía antes? Igual entonces sigo sin poder editar los menús...

Muchas gracias por tu ayuda

Un saludo

+1
0
-1
Imagen de j-c
+1
0
-1

¿Tienes Alacarte instalado? Instalalo de esta forma:

$ sudo apt-get install alacarte

+1
0
-1
Imagen de neossoftware
+1
0
-1

pues muchas gracias brother el gnome control center me fue de maravilla gracias!!!

+1
0
-1
Imagen de heavynetol
+1
0
-1

Pero lo solucioné.. Así.
Cuando ingresé a gnome-control-center desde la consola, y de hecho traté de ingresar a "Menú Principal" no sucedía nada :|, así que revisando los errores de la consola me di cuenta que no tenía acceso al directorio:

IOError: [Errno 13] Permiso denegado: '/home/tu_nombre_de_usuario/.config/menus/applications.menu'

Lo cual solucioné ingresando hasta .config y:

:~/.config$ sudo chown tu_nombre_de_usuario menus/

Luego de aquello, tranquilamente me deja hacer clic derecho sobre "Aplicaciones" y clic en "Editar menús"

Saludos.

+1
0
-1

Intel Pentium 4 @ 2.8 Ghz
Intel D865 Perl
2Gb Memoria RAM PC-400
NVidia Geforce FX-5200 256MB
Creative Audigy SE
Ubuntu 10.10 Maverick

Imagen de atropos17
+1
0
-1

quisiera saber como revisar los errores por consola y tambien como accedo al menu principal desde la consola yo tengo debian 6 y menus se encuentra en etc/xdg/menus. Te agradeceria mucho un poco mas de detalle porque soy novato en linux

+1
0
-1
Imagen de posteo
+1
0
-1

Desaparición de Sistema/Preferencias ... /Administración ... /Centro de Control. Imposibilidad de con botón derecho sobre /Aplicaciones.

Al instalar la distribución Molinux -basada en Ubuntu-, en alguna operación o actualización, desaparecieron los antes mencionados.
Al realizar una actualización me indicaba un error en la misma, que me dio la clave para solucionar el problema.

Había desaparecido el archivo: etc/xdg/menus/settings-molinux.menu. Por tanto, en la actualización no podía sustituir el archivo, dando un error.
Lo solucioné creando un archivo vacío de nombre settings-molinux.menu. Al actualizar lo instaló de nuevo y todo volvió a funcionar.

Generalizando, se podría realizar la misma operación en cualquier distribución para que el sistema autogenere el archivo, o copiar sobre el mismo, si existe, el contenido de uno idéntico que no esté corrupto.

Espero que os sirva, un saludo.

+1
0
-1