Restaurar Unity (Ubuntu 11.10) tras problemas con configcompiz?? [SOLUCIONADO]

Imagen de Art.
0 puntos

Hola.

Resulta que me bajé el administrador de configuraciones de compiz, y tras estar probando cosas con él (sin tocar lo del cubo de escritorio ni tocar practicamente nada), el escritorio y toda la interfaz me desaparecieron. No estaba ni la barra superior, ni la lateral, tan solo el fondo de pantalla. He leido por ahi que le ha pasado a varias personas, y encontrado una solución que no me ha resultado.

Es la siguiente, abres la terminal (con ALT + CTRL + F1, porque no lo puedes hacer de otra forma) ingresas tu nombre de usuario y cntraseña, y despues tecleeas unity --reset. Debería de funcionar, pero a mi no me funciona. Me da error, proceso no encontrado, y no me deja hacer nada más, además de que no se soluciona.

Encontré este video que lo soluciona, (http://www.youtube.com/watch?v=hNYf3u3aN7c) pero para Ubuntu 11.04, no sirve para 11.10 (ya que en este no se pueden crear lanzadores), asique tampoco se puede hacer nada. Y encima como 11.10 acaba de salir, no hay absolutamente nada en internet sobre la cantidad de problemas que da la maldita versión.

Si entro con Ubuntu 2D, si me sale todo correcto, pero de la otra forma no.

Alguien me puede ayudar?

SOLUCIÓN

Recordemos que en principio el problema viene a raiz de "utilizar" el CCSM (Administrador de configuraciones ConfigCompiz), y es que se deshabilita Unity 3D, quedándose el escritorio sin interfaz y sin poder realizar nada.

En principio bastaría con abrir la terminal (ALT + CTRL + F1) y escribir el siguiente comando: unity --reset

Pero si esto no os funciona, lo que debeis de hacer es lo siguiente:

- Teniendo el CCSM instalado, debeis de entrar en vuestro usuario con Unity 3D (es decir, con el que está fastidiado)
- A continuación, como solo nos aparece la barra de herramientas, haceis click en "Archivo/Ventana nueva" y os dirijis al directorio /usr/bin/
- Una vez aquí, buscais el archivo CCSM y lo ejecutais.
- Se os abrirá el programa que os dio el problema, es decir, el administrador de configuraciones. Una vez aquí, activais la casilla de "Unity plugin", que debería estar desactivada (de ahi el problema).
- Os informará de que hay problemas con ciertos atajos de teclado, entonces los deshabilitais todos.

Una vez hayais deshabilitado todos los atajos, automáticamente todo volverá a la normalidad.

Imagen de Capa
+1
0
-1

Movido al foro "Ubuntu - Unity"

+1
0
-1
Imagen de pisangas
+1
0
-1

pues compañero la verdad tenia el mismo problema, soy un ubuntunero nuevo y me decidi meter con esta version de la cual no se ubica mucha info, te cuento lo que hice (de antemano se que no es la manera ingenieril que exige la comunidad pero sirvio), ingrese como a modo de recuperacion y luego a la consola de comandos teclee unity --reset, apague y encendi en 10 minutos y wuala!!!! se reestablecio, prueba y me cuentas

+1
0
-1
Imagen de egomantes
+1
0
-1

Je,je,je... soy otro torpe más que se ha quedado sin Unity por culpa de Compiz.

Al ejecutar unity --reset en el terminal me dice que unity no está instalado y que ejecute no se cual orden para ello. Lo hago, con lo que entiendo que he instalado unity (no sé en qué momento debí desinstalarlo). El caso es que en Ubuntu2D si aparece unity, pero en Ubuntu a secas... pues no.

Entonces pruebo a ejecutar de nuevo lo de unity --reset desde el modo de recuperación y la pantalla se me llena de mensajes de error, con lo que sigo sin Ubuntu, pero sí con Ubuntu 2D

En fin, a ver si alguno con más luces que yo (fácil) puede echarme una mano.

Gracias!

+1
0
-1
Imagen de Art.
+1
0
-1

El mensaje que me sale al dar el comando unity --reset es este:

“WARNING: no DISPLAY variable set, setting it to:0
unity-panel-service: proceso no encontrado”

He probado ya con todo, he desinstalado unity, lo he vuelto a instalar

sudo apt-get purge unity
sudo apt-get install unity

no se restaura, y al poner la orden reset, me sigue dando el mismo error.. ya no se que hacer..

+1
0
-1
Imagen de egomantes
+1
0
-1

El mío mola más:

Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : default
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
Initializing bailer options...done
Initializing detection options...done
Initializing composite options...done
Initializing opengl options...done
Initializing decor options...done
Initializing snap options...done
Initializing resize options...done
Initializing vpswitch options...done
Initializing mousepoll options...done
Initializing move options...done
Initializing wall options...done
Initializing grid options...done
Initializing place options...done
Initializing gnomecompat options...done
Initializing session options...done
Initializing animation options...done
Initializing workarounds options...done
compiz (expo) - Warn: failed to bind image to texture
Initializing expo options...done
Initializing ezoom options...done
Initializing staticswitcher options...[ERROR]: Option "next_button" already defined
[ERROR]: Option "next_key" already defined
[ERROR]: Option "prev_button" already defined
[ERROR]: Option "prev_key" already defined
[ERROR]: Option "next_all_button" already defined
[ERROR]: Option "next_all_key" already defined
[ERROR]: Option "prev_all_button" already defined
[ERROR]: Option "prev_all_key" already defined
[ERROR]: Option "next_group_button" already defined
[ERROR]: Option "next_group_key" already defined
[ERROR]: Option "prev_group_button" already defined
[ERROR]: Option "prev_group_key" already defined
[ERROR]: Option "next_no_popup_button" already defined
[ERROR]: Option "next_no_popup_key" already defined
[ERROR]: Option "prev_no_popup_button" already defined
[ERROR]: Option "prev_no_popup_key" already defined
[ERROR]: Option "next_panel_button" already defined
[ERROR]: Option "next_panel_key" already defined
[ERROR]: Option "prev_panel_button" already defined
[ERROR]: Option "prev_panel_key" already defined
[ERROR]: Option "speed" already defined
[ERROR]: Option "timestep" already defined
[ERROR]: Option "window_match" already defined
[ERROR]: Option "minimized" already defined
[ERROR]: Option "auto_change_vp" already defined
[ERROR]: Option "popup_delay" already defined
[ERROR]: Option "mouse_select" already defined
[ERROR]: Option "saturation" already defined
[ERROR]: Option "brightness" already defined
[ERROR]: Option "opacity" already defined
[ERROR]: Option "icon" already defined
[ERROR]: Option "icon_only" already defined
[ERROR]: Option "mipmap" already defined
[ERROR]: Option "row_align" already defined
[ERROR]: Option "focus_on_switch" already defined
[ERROR]: Option "bring_to_front" already defined
[ERROR]: Option "highlight_mode" already defined
[ERROR]: Option "highlight_rect_hidden" already defined
[ERROR]: Option "highlight_color" already defined
[ERROR]: Option "highlight_border_color" already defined
[ERROR]: Option "highlight_border_inlay_color" already defined
done
Initializing fade options...done
Initializing scale options...done
Starting unity-window-decorator

(unity-window-decorator:2621): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,

(unity-window-decorator:2621): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,

(unity-window-decorator:2621): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,

(unity-window-decorator:2621): Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap»,
Setting Update "main_menu_key"
Setting Update "run_key"

+1
0
-1
Imagen de Art.
+1
0
-1

Bueno ya tengo la solución. Después de probarlo todo sin éxito, realizar lo siguiente es lo que basta para poder solucionar este problema.

Recordemos que en principio el problema viene a raiz de "utilizar" el CCSM (Administrador de configuraciones ConfigCompiz), y es que se deshabilita Unity 3D, quedándose el escritorio sin interfaz y sin poder realizar nada.

En principio bastaría con abrir la terminal (ALT + CTRL + F1) y escribir el siguiente comando: unity --reset

Pero si esto no os funciona, lo que debeis de hacer es lo siguiente:

- Teniendo el CCSM instalado, debeis de entrar en vuestro usuario con Unity 3D (es decir, con el que está fastidiado)
- A continuación, como solo nos aparece la barra de herramientas, haceis click en "Archivo/Ventana nueva" y os dirijis al directorio /usr/bin/
- Una vez aquí, buscais el archivo CCSM y lo ejecutais.
- Se os abrirá el programa que os dio el problema, es decir, el administrador de configuraciones. Una vez aquí, activais la casilla de "Unity plugin", que debería estar desactivada (de ahi el problema).
- Os informará de que hay problemas con ciertos atajos de teclado, entonces los deshabilitais todos.

Una vez hayais deshabilitado todos los atajos, automáticamente todo volverá a la normalidad.

+1
0
-1
Imagen de egomantes
+1
0
-1

Gracias! (y hecho)

+1
0
-1
Imagen de vmard@@1
+1
0
-1

Gracias muchas... estaba todo perdido.

+1
0
-1
Imagen de Fededomi
+1
0
-1

Buff, muchas gracias, ya estaba pensando en pasarme a gnome shell.

+1
0
-1
Imagen de fxborbor
+1
0
-1

Gracias me ayudo de mucho,

Como adicional, antes de encontrar esta respuesta desintale el CCSM y al parecer el unity se fue con el, lo que tuve que hacer fue:
1- entrar en Ubuntu-2D y reinstalar el CCSM
2- Ctrl+Alt+F1
3- usuario y clave
4- probe con unity --reset (continuaba el mensaje diciendo que no esta instalado)
5- apt-get purge unity (por las dudas)
6- apt-get install unity
7- reiniciar
8- iniciar sesion en Ubuntu (ahora ya aparece en la lista) y seguir con la solucion aqui planteada

Nota. al activar el plugin de Unity indica que hay conflicto, clic en solucionar y desactivar todo aquello que de algun conflicto.

+1
0
-1
Imagen de slackgher
+1
0
-1

Gracias por la ayuda deberas que si funciona porque le he ayudado a un amigo con el mismo problema y se a solucionado.. mi problema es algo mayor creo ya que no me sale ni la BARRA DE HERRAMIENTAS solo me aparece el fondo de pantalla y por ende no puedo ingresar a ningun lugar.. intento abrir la terminal (ALT + CTRL + F1) y escribo unity --reset y no pasa nada se queda pegada y no avanza tambien he intendado dirirge hasta el directorio donde se encuntra el archivo ccsm y ejecurlo pero tampoco nada me funciona quisiera me ayudaran gracias..

+1
0
-1
Imagen de slackgher
+1
0
-1

por favor podrian ayudarme ya que a ami ni siquiera ame aparece la barra de herramaientas entonces por ende no puedo hacer nada.. He intenta ejecutar el script ccsm y tampoco funciona podrian ayudarme gracias

+1
0
-1
Imagen de Korba
+1
0
-1

Gracias muy buena la solución. Simple y efectiva :-)

+1
0
-1

Un saludo.

Ubuntu 11.10

Imagen de eduardo_cordova
+1
0
-1

Muchas gracias, ya estaba apunto de reinstalar xD

+1
0
-1
Imagen de eamusic
+1
0
-1

Hace tiempo estaba en ubuntu 10.04 lts y decidì actualizarme; al comenzar con la tocadera que le da a uno por todos lados, búscando los efectos que uno añora, ps, toque donde no debia :D

Pero gracias a tu ayuda lo recuperé

+1
0
-1
Imagen de delia82
+1
0
-1

Gracias!!

+1
0
-1
Imagen de Bratitoful
+1
0
-1

yo tenia el mismo problema instalando unos cursores cambie la configuración en compiz en preferencias, le cambie el perfil por de defecto en ves de unity por error, y se me desaparecieron la barra superior y el lanzador gracias por tu ayuda la seguí al pie de la letra y resolví el problema, en un momento pensé en reinstalar el sistema pero ya lo resolví.
GRACIAS

+1
0
-1
Imagen de nordik_14
+1
0
-1

Pues bien a mi me funciono abrir la terminal y luego unity --reset. Lo que provoco mi problema fue unicamente habilitar el cubo de escritorio. Soy ubuntero desde 10.04 y ahora esta version de unity es mas inestable que las anteriores. Esperemos la cambien para abril.
gracias comunidad

+1
0
-1

Desde ubuntu 11.04

Imagen de yadoble
+1
0
-1

Me sirvio mucho este post.

Nota personal: NO jugar con unity

+1
0
-1
Imagen de davinal12
+1
0
-1

Mi solución fue escribir en consola "apt-get purge unity" , reiniciar y escoger ubuntu 2D y ya !

+1
0
-1

David

Imagen de andyubuntu12.4
+1
0
-1

Muy buenas. Después de instalar compiz y apagar el equipo, cuando lo volví al dia siguiente, inicie mi sesión y me cargaba el fondo de pantalla pero ninguna de las barras ni la vertical ni la horizontal pero si en 2D. Entonces en este blog vi lo de unity --reset y me aparecía que no lo tenia instalado. Por tanto si me dio problemas cuando instale compiz he utilizado un poco la lógica es decir sudo apt-get --purge remove compiz, después sudo apt-get autoremove por si quedara algún paquete o algún objeto huérfano que me haya dejado compiz. Al desirme que no tenia instalado unity decidi primero actualizar los paquetes de distribucion y paquetes instalados, sudo apt-get update, después de este por si acaso actualizar sistema con sudo apt-get dist-upgrade. Después de todo esto por fin instalar nuevamente unity, sudo apt-get install unity. una ves instalado unity le hize un reset unity --reset, después reinicie ubuntu 12.4 y wala arranco en 3D perfecto tal como lo tenia. Para mi opinión es problema del compiz que por defecto desinstala unity. A mi me ha ido genial y no soy un experto sino que soy un nuevo ubuntunero. espero que os sirva de utilidad.

+1
0
-1
Imagen de furuikisui
+1
0
-1

Después de intentar varias soluciones, he podido lograrlo gracias a ti, recomiendo ampliamente tu comentario y si bien, para ti es lógico desinstalar y reinstalar la interface, no sabia como hacerlo xD, es m'as quería tratar de instalar otra como enlightment o gnome. Gracias.

Entre a ubuntu y no se veía ni la barra superior ni la lateral, entonces di ctrl+alt+delete para cerrar la sesión y después puse el usuario y el pass a ciegas porque tampoco se veía. No funciono y salio la interface o logon screen como se llame, di clic al engrane ese de ubuntu y le di en ubuntu 2D, luego abrí la terminal y seguí el proceso de nuestro amigo acá arriba, y reinicie. Problema solucionado.

+1
0
-1
Imagen de furuikisui
+1
0
-1

que creen, no es cierto, no funciono :(

+1
0
-1
Imagen de furuikisui
+1
0
-1

Si me hacen el favor de quitar mis respuestas anteriores y sólo dejar la solución.

En primera instancia, creí que la solución de arriba, la principal, la que dice que abramos una ventana y ejecutemos el ccs..., creí que no me funcionaba, que que no viene bien explicada. En realidad no explica nada, y para usuarios novatos como yo es algo molesto que no sean específicos.

Después de intentar múltiples soluciónes, descubrí cuál era mi problema. Y porsupuesto que tiene que ver con la ocnfiguración de Compiz, hice lo siguiente:

En mi escritorio no se veía ninguna barra, ni la superior ni la lateral, tampoco ningun menú ni nada. Estaba vacio. Luego en el escritorio cree una carpeta nueva y la abri. De esta manera pude seguir el procedimiento de
directorio /usr/bin/
Una vez abierto el archivo CCSM, lo único que necesitaba para restaurar las ventanas, o lo que pudiera llamarse marcos de las ventanas. Era activar
Sin categoría> Unity MT Grab Handles que está por última opción. En realidad no se para que funcióne pero estaba desactivada.
Pero lo que realmente solucióno fue activar la casilla de:
Diseño> Decoración de ventanas ya que era la que me causaba no tener la barra de arriba, por lo que no podía agarrar las ventanas y todas se abrían en el mismo lugar.
Dejo estos enlaces por si quieren cargar una configuración en vez de tratar de arreglarlo:
Para Usarlo debes de ir a Preferencias y usar importar configuración. Tardará un poquito.
http://www.4shared.com/file/tNll6DTT/compiz_estable1.html?
http://www.4shared.com/file/LA44H4yx/Compiz_2_o_3_efectos.html?

También déjenme comentarles que se puede evitar hacer todo esto. Simplemente se tiene que crear un cuenta nueva de usuario administrador, cerrar la sesión, abrir la nueva sesión y eliminar la que falló :D
Que cómo se hace eso, pues no sé,alguien que quiera poner las instrucciones porfavor.

Trataré de dejar un video corto.
http://youtu.be/DdyMG-lvAcY

+1
0
-1
Imagen de bLaOr
+1
0
-1

El problema es unity en 3d no va bien con algunas tarjetas de video, tuve un amigo que tenia ese problema con su tarjeta NVIDIA

+1
0
-1
Imagen de FERMON@FERMON
+1
0
-1

gracias por tu aportación fue muy importante para recuperar mi 3d te agradezco saludos y buena suerte.

+1
0
-1