error Gtk-WARNING en terminal al instalar o desinstalar aplicaciones [SOLUCIONADO]

Imagen de Arnao
60 puntos

pues eso que me he dado cuenta que al instalar o desinstalar una aplicación por medio del terminal me arroja los siguientes mensajes

Procesando disparadores para man-db ...
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103.

edito: como información uso ubuntu 11.10 x64 y el equipo es un HP pavilion dv6

Imagen de almursi
+1
0
-1

buenas, un warning no es un error propiamente dicho, es tan sólo una advertencia. Si te incordian mucho seguramente desaparezcan si instalas el paquete de algún tema de iconos estándar de gnome. Saludos cordiales.

+1
0
-1
Imagen de Arnao
+1
0
-1

muchas gracias pensaba que era algún tipo de error, pero el caso que las aplicaciones se instalan bien, pero no se me preocupó un poco ver todas esas lineas, ahora me dejas más tranquilo, era la primera vez que me sucedía en los tres añitos que llevo en el mundo linux.

Por cierto, puedes recomendarme algún tema de iconos que sea interesante? ahora mismo tengo puesto AwOken.

Un saludo

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, pues no sabría decirte, aunque uso gnome siempre uso el tema oxygen de kde que me resulta un poco más legible y si cambio (uso el mismo desde hace años) ya no sé qué es qué :). Saludos cordiales.

+1
0
-1
Imagen de Arnao
+1
0
-1

en parte se solucionó pero el problema sigue ahí, lo que hice fue reinstalar con synaptic todos lo paquetes de iconos que tenía instalados e instalé uno más que encontré en synaptic y ahora cuando instalo o desinstalo una aplicación con por medio del terminal ya no aparece el warning este (estoy haciendo pruebas instalando y desinstalando audacity), pero si lo hago por synaptic, en la ventana que se me abre "cambiando aplicados" en mostrar detalles aún aparecen un par de lineas con el warning, concretamente me sale todo esto:

Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97, <> line 5.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103, <> line 5.
Seleccionando el paquete audacity-data previamente no seleccionado.
(Leyendo la base de datos ... 194657 ficheros o directorios instalados actualmente.)
Desempaquetando audacity-data (de .../audacity-data_1.3.13-5_all.deb) ...
Seleccionando el paquete libportsmf0 previamente no seleccionado.
Desempaquetando libportsmf0 (de .../libportsmf0_0.1~svn20101010-3_amd64.deb) ...
Seleccionando el paquete libwxbase2.8-0 previamente no seleccionado.
Desempaquetando libwxbase2.8-0 (de .../libwxbase2.8-0_2.8.11.0-0ubuntu10_amd64.deb) ...
Seleccionando el paquete libwxgtk2.8-0 previamente no seleccionado.
Desempaquetando libwxgtk2.8-0 (de .../libwxgtk2.8-0_2.8.11.0-0ubuntu10_amd64.deb) ...
Seleccionando el paquete audacity previamente no seleccionado.
Desempaquetando audacity (de .../audacity_1.3.13-5_amd64.deb) ...
Procesando disparadores para hicolor-icon-theme ...
Procesando disparadores para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Procesando disparadores para desktop-file-utils ...
Procesando disparadores para gnome-menus ...
Procesando disparadores para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procesando disparadores para man-db ...
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97.
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «pixmap», at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103.
Procesando disparadores para menu ...
Configurando audacity-data (1.3.13-5) ...
Configurando libportsmf0 (0.1~svn20101010-3) ...
Configurando libwxbase2.8-0 (2.8.11.0-0ubuntu10) ...
Configurando libwxgtk2.8-0 (2.8.11.0-0ubuntu10) ...
Configurando audacity (1.3.13-5) ...
Procesando disparadores para libc-bin ...
ldconfig deferred processing now taking place
Procesando disparadores para menu ...

+1
0
-1
Imagen de almursi
+1
0
-1

buenas, debe ser error de los guiones de instalación que aún buscan los temas de gnome 2 pero hayan cambiado de sitio en gnome 3 (que he leído que usas en otro hilo :) ). Seguramente lo irán corrigiendo con el tiempo (o quizá alguien que sepa más de gnome 3 pueda explicarte mejor). Saludos cordiales.

+1
0
-1
Imagen de Arnao
+1
0
-1

muchas gracias, esperaremos pues, de todos modos no me preocupa tanto porque a parte de esto todo anda bien.

Un saludo

+1
0
-1
Imagen de Arnao
+1
0
-1

bueno en si no está solucionado pero tampoco me preocupa.

Resulta que en VMware con un ubuntu 11.10 virtualizado, en el cual estoy haciendo una serie de pruebas que no vienen al caso, me ha aparecido el mismo warning con lo cual deduzco que es un bug de ubuntu, vamos, que no es nada que le haya estropeado yo por enreda xD, si no que debe ser problema del propio ubuntu.

Con lo cual pueden dar el tema por zanjado

Gracias almursi por ser tan amable de haber perdido tu tiempo con estas cuestiones.

Un saludo

+1
0
-1
Imagen de bean
+1
0
-1

Arnao . . .Audacity es una maravilla . En 11.10 me corre como los dioses y bajo Unity.
Como ya hemos dicho por ahí, 11.10 viene para calzar al 100% con Unity y no con Gnome. No digo que no puedan compatibilizar, o con Unity 2D, pero la idea es como te digo, y ergo, no hay ningún bug de Ubuntu como lo indicas.

mismo warning con lo cual deduzco que es un bug de ubuntu

Instala 11.10 con Unity y verás como tu Audacity te dará enormes satisfacciones.
Saludos.

+1
0
-1
Imagen de Arnao
+1
0
-1

creo que no has entendido:
1º yo ya uso unity, de hecho me gusta mucho y lo prefierao antes que gnome-shell
2º el warning me sale al instalar o desinstalar cualquier aplicación, pero solo cuando lo hago desde synaptic, en el terminal no me sale.
3º audacity solo lo he usado para hacer pruebas instalandolo y desinstalandolo desde synaptic y desde el terminal, lo usé para comprobar cuando salía el citado warning, nada más, igual que usé audacity podría hacer usado cualquier otra aplicación.
4º ya conozco audacity de sobra, muy bueno si, pero le falta "potencia", prefiero ardour...
5º el warning no solo me sale en mi laptop con ubuntu 11.10 64bits con unity, si no que tambien me salió en una maquina virtual con ubuntu 11.10 32 bits con unity y en un PC desktop con el mismo SO, todos con instalaciones en limpio, con lo cual pienso que es cosa de ubuntu y que se solucionará con alguna actualización.
6º ya comenté que no me preocupaba pues todo lo de más me funciona perfecto.

Espero que no te haya parecido demasiado brusca mi contestación, pero esque todo esto ya lo comenté y solo es cuestión de leer con un poquito más de atención. Muchas gracias de todos modos y pido disculpas si he podido sonar un poco brusco.

Un saludo

+1
0
-1
Imagen de bean
+1
0
-1

y como te veía intentando con el Audacity, me fui por ahí. Ok.
Pero entonces debes decir lo que es, porque si fuera un bug de Ubuntu todos debiéramos estar afectados; lo que no es así, yo instalo e instalo aplicaciones en 11.10 con Unity 3D y sin dificultades de ningún tipo; ahora bien, con atención en la lectura, sólo puedo concluir que quien tiene el bug - si es que de eso se trata y no de una incompatibilidad manifiesta con alguna aplicación que tengas y que desconozco cual sea, es VMWare, o hay algún bug o error en tu proceso de virtualización, con lo cual Ubuntu no tiene nada que ver.
Saludos y que bueno que puedas convivir con ello. Yo en tu caso habría mandado a freír espárragos a todas esas virtualizaciones y demases etc., y dejado solito el Ubuntu para disfrutar sin problemas de ningún orden sus maravillas.
Y la pregunta final es qué sucede cuando instalas aplicaciones no con terminal ni con Synaptic sino desde el Centro de Software de Ubuntu.
Saludos.

+1
0
-1
Imagen de Arnao
+1
0
-1

a ver... que me pasa en el laptop UBUNTU 11.10 x64 con unity instalado nativamente y con instalación limpia, desde 0, no es actualización. A parte tambien lo he observado en una máquina vitual con ubuntu 11.10 x32 con unity, y a parte tambien me ocurre en otro equipo totalmente distinto, diferente al laptop, aislado de este, sin maquinas virtuales ni nada, en el que tengo instalado Ubuntu 11.10 x32 con unity, desde instalacion limpia y sin haberle instalado nada, ni hacerle ninguna clase de configuración, me fijé que esto sucedía cuando instalé el primer programa desde synaptic. Vamos que no tiene nada que ver con las máquinas virtuales, ni con un solo ordenador, ni con un solo programa...

Ya he dicho que esto solo se observa si hago las instalaciones o desinstalaciones desde synaptic y no aparece en ventanas a parte ni nada, si no que aparece en el terminal que se abre cuando al instalar le das a detalles, solo aparece en esa consola, vamos que si ni te enteras, ya he dicho que instalando desde la terminal con sudo apt-get install ****** no aparece, ni tampoco aparece instalando desde el centro de software, con lo cual seguro que no es cosa mia y le pasa a más gente y por eso no se hayan dado cuenta, porque es algo que pasa desapercibido a simple vista y que me di cuenta de casualidad.

Creo que esto lo explique ya antes, quizá deberías poner un poco más de interés o concentración a la hora de leer.

Un saludo

+1
0
-1
Imagen de bean
+1
0
-1

porque en ninguna parte habías dicho que hubo aplicaciones instaladas desde el Centro de Soft. a menos que esté quedando ciego, por eso la consulta final.

1.

Creo que esto lo explique ya antes, quizá deberías poner un poco más de interés o concentración a la hora de leer

2.

era la primera vez que me sucedía en los tres añitos que llevo en el mundo linux.

Aunque lleves mil, como la amabilidad no se enseña en Linux ni siquiera en la "U" , es cosa tuya responder del modo aquél, yo siempre te contestaré con mucho interés y afabilidad e incluso algo de humor, porque me nace de adentro.

3.

Resulta que en VMware con un ubuntu 11.10 virtualizado, en el cual estoy haciendo una serie de pruebas que no vienen al caso, me ha aparecido el mismo warning con lo cual deduzco que es un bug de ubuntu,

4.

Vamos que no tiene nada que ver con las máquinas virtuales, ni con un solo ordenador,

Te contradices y borras con el codo (4.) lo que escribes con la mano (3.), e inclusive por el caso del VMWare achacas un bug a Ubuntu.

Y ahora, contestando, al fin, con el estilo tuyo tan poco amistoso ( me es difícil ) :
y por el maldito demonio . . . . .
Borré editando lo que había escrito porque luego me arrepentiría de haber hecho lo que critico.
Un saludo.

+1
0
-1
Imagen de Arnao
+1
0
-1

mira si he resultado grosero lo siento, simplemente quería explicar claro algo que pienso que ya lo estaba y parece que no entiendes o no quieres entender, asique lo siento y pido disculpas por no haber guardado las formas... no voy a discutir mas sobre el tema, además ya puse que el tema estaba ya zanjado y solucionado antes de tu intervención con lo cual no tiene sentido darle más vueltas y enredar más la madeja...

Un saludo

+1
0
-1