Mi swap debería ser de 2Gb pq así lo dice Gparted pero en realidad es de 3Gb

Imagen de esbrinartot
0 puntos

El problema que tengo si miro el espacio asignado a SWAP mediante Gparted veo que son 2Gb tal y como configure en la instalación: (ver link adjunto)

http://img411.imageshack.us/img411/7834/201111192033121680x1050.png

Si mediante la terminal escribo el comando free son 3 GB (ver resultado):

total used free shared buffers cached
Mem: 1017540 902348 115192 0 25480 577188
-/+ buffers/cache: 299680 717860
Swap: 3072700 18108 3054592

Es muy raro... Pq me pasa esto?
También noto que a pesar de tener el valor de swappiness a 10 la memoria de intercambio se activa demasiado. Creo que da igual el valor que le ponga que el ordenador usa el valor que quiere

Tengo que comentar que recien instalado lubuntu 11.10 me dio el siguiente error:

/dev/mapper/cryptswap1 no esta listo o presente.

"según me informe este error ocurre siempre que cifres tu partición home"

Para solucionar este problema hice lo siguiente: (No se si esto puede causar el problema?)

sudo swapoff - a
sudo cryptsetup remove /dev/mapper/cryptswap1
sudo gedit /etc/crypttab
dentro de este archivo comenté/borré la siguiente linea:
# cryptswap1 /dev/sda8 /dev/urandom swap,cipher=aes-cbc-essiv:sha256
después en la terminal:
sudo /sbin/mkswap /dev/sda9
sudo swapon /dev/sda9
sudo gedit /etc/fstab
y dentro del archivo cambié esta linea:
/dev/maer/cryptswap1 none swap sw 0 0
por esta otra:
/dev/sda9 none swap sw 0 0

Reinicié y después habilité la partición cifrada mediante:
sudo ecryptfs-setup-swap

A ver si alguien me ayuda a saber si miro la swap que tengo mediante gptared o free me da valores diferentes

Imagen de selerto
+1
0
-1

Hola amigo.

Esos dos programas informan de cosas distintas.

El GParted informa sobre las particiones, el free informa sobre la memoria.

La swap puede estar en una o varias particiones y/o en uno o varios archivos, o en una combinación de ambas cosas.

+1
0
-1
Imagen de esbrinartot
+1
0
-1

Gracias por contestar Selerto. A veces hay preguntas que cuesta encontrar respuesta o que alguién te responda. Pensava que esta seria una de ellas.

ok de acuerdo puedes tener mas de una partición swap pero no es mi caso. (se puede ver en el gparted)

Además no tengo configurado ningún archivo de intercambio y pienso que es así porqué no lo he configurado y no se generan por defecto.

Por lo que te comento me sigue pareciendo raro lo que pasa en mi netbook. Aún no lo veo lógico.

Lo que si hice fue instalar zram. Pero dudo que zram genere algun tipo de archivo de intercambio...

+1
0
-1
Imagen de esbrinartot
+1
0
-1

Gracias por contestar Selerto. A veces hay preguntas que cuesta encontrar respuesta o que alguién te responda. Pensava que esta seria una de ellas.

ok de acuerdo puedes tener mas de una partición swap pero no es mi caso. (se puede ver en el gparted)

Además no tengo configurado ningún archivo de intercambio y pienso que es así porqué no lo he configurado y no se generan por defecto.

Por lo que te comento me sigue pareciendo raro lo que pasa en mi netbook. Aún no lo veo lógico.

Lo que si hice fue instalar zram. Pero dudo que zram genere algun tipo de archivo de intercambio...

+1
0
-1
Imagen de selerto
+1
0
-1

Hola de nuevo.

Mi anterior comentario era una respuesta -solo- al último párrafo de tu consulta:

A ver si alguien me ayuda a saber si miro la swap que tengo mediante gptared o free me da valores diferentes

No soy capaz de decirte cual fue la causa de tu problema (entiendo que ya lo solucionaste). No sé como funciona esto de la encriptacion de la swap.

Pero veo una incongruencia en la información que aportas. En la imagen vemos que la swap es sda9, pero nos dices que en /etc/crypttab había una línea en la que cryptswap1 apuntaba a sda8. Esto no cuadra.

Puede que esto confundiese al free haciéndole pensar que tenías 2 áreas swap. O puede que realmente se crease un archivo swap en sda8 (lo dudo).

Este descuadre puede que se debiese a que posiblemente hallas hecho cambios es las particiones de los discos. Pienso esto por que veo que la numeración de la partición swap no coincide con su posición en el disco.

+1
0
-1
Imagen de esbrinartot
+1
0
-1

respecto a la incogruencia es cierto... Al motivo es el siguiente:

1- para reparar la swap formatee de nuevo la unidad de datos y la unidad swap.

Después de pasar esto la Swap en vez de estar en sda8 paso en sda9. (se intercambiarón la partición de datos con la Swap)

Quizás este generando mis comentarios y es la solución a mi pregunta.

Como podria cambiar intercambiar el sda8 por el sda9??

Creo que no entraña ningún peligro el cambio ya que tengo copia de mi unidad de datos y el ordenador sin swap funcionaria.

Otro dato que acabo de ver...

- Si desmonto la partición swap de 2Gb que es la que gparted esta viendo y ejecuto el comando free tengo 1Gb de Swap activada. Deberá tratarse de un archivo pero no se donde esta.

+1
0
-1
Imagen de selerto
+1
0
-1

Como ya te dije, no sé como funciona esto, lo siguiente es solo una suposición.

El error estaba en:

cryptswap1 /dev/sda8 /dev/urandom...

Ahora debería ser:

cryptswap1 /dev/sda9 /dev/urandom...
y dentro del archivo cambié esta linea:
/dev/maer/cryptswap1 none swap sw 0 0
por esta otra:
/dev/sda9 none swap sw 0 0

Pienso que esto deberías volver a editarlo para dejarlo como estaba antes.

Espero que algún otro forero pueda ayudarte mejor que yo.

- Si desmonto la partición swap de 2Gb que es la que gparted esta viendo y ejecuto el comando free tengo 1Gb de Swap activada. Deberá tratarse de un archivo pero no se donde esta.

Sería interesante que nos mostrases el contenido de tu fstab y del crypttab y... del comando: swapon -s

+1
0
-1
Imagen de esbrinartot
+1
0
-1

Selerto,

El error estaba en:
cryptswap1 /dev/sda8 /dev/urandom...

Esto es el error una vez instalado Lubuntu. Como parte para solucionar el problema fue /etc/crypttab y comentar la linea. Por lo tanto da igual que ponga 8 o 9. Actualmente mi /etc/crypttab tiene el siguiente texto:
#
# cryptswap1 /dev/sda8 /dev/urandom swap,cipher=aes-cbc-essiv:sha256
Como esta todo comentado da igual lo que ponga.

Pienso que esto deberías volver a editarlo para dejarlo como estaba antes.
Espero que algún otro forero pueda ayudarte mejor que yo.

Si lo vuelvo a editar como estaba antes me saldra el mismo error que cuando instalé lubuntu. El error tengo entendido que aparece siempre que cifras la unidad home. Ahora no me da errores. No obstante no pierde nada en probarlo mañana. Siempre se puede dar marcha atras si sabes lo que has hecho

Sería interesante que nos mostrases el contenido de tu fstab y del crypttab y... del comando: swapon -s

Empiezo por el resultado del comando swapon -s pq me creo que aquí está la respuesta
Filename Type Size Used Priority
/dev/sda9 partition 2055164 0 -1
/dev/zram0 partition 508768 0 100
/dev/zram1 partition 508768 0 100

Entiendo que Zram genera 2 archivos de intercambio. Aunque solo es intuición. No tengo conocimiento suficientes como para afirmarlo. Veo que la prioridad de sda9 es -1 por lo que diria que nunca se activara.

Otra duda que me aparece es que si tengo fijado el valor de swappiness a 10 afecta solo a la sda9 o actua tanto en sda9 como en zram0 y zram1. Quiero evitar que se active la swap. Mi experiencia es que cuando se activa el sistema siempre se vuelve lento

fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=bdf30805-459a-4207-9eee-5be5a3eee1a1 / ext4 errors=remount-ro 0 1
# /boot was on /dev/sda5 during installation
UUID=c7984874-6152-460a-98cf-a98745065b58 /boot ext4 defaults 0 2
# /home was on /dev/sda7 during installation
UUID=f780468a-c42b-4e45-bf44-8e5b6775df57 /home ext4 defaults 0 2
# swap was on /dev/sda8 during installation
#UUID=08d1c2d8-5c5a-431d-83b2-f5d51f179df9 none swap sw 0 0
/dev/sda9 none swap sw 0 0

UUID=4B6F4ED377725465 /media/DATOS ntfs-3g default 0 0

cryptswap
#
# cryptswap1 /dev/sda8 /dev/urandom swap,cipher=aes-cbc-essiv:sha256

+1
0
-1
Imagen de esbrinartot
+1
0
-1

Selerto,

Una vez desinstalado ZRAM toda está como creo que deberia estar.

swapon -s
Filename Type Size Used Priority
/dev/sda9 partition 2055164 0 -1

Mi pregunta es.... ZRAM mejora el rendimiento de mi computadora. En Muy Linux o en Mundo Geek decian que si pero los comentarios de los usuarios eran que practicamente no notaban la diferencia.

Hago esta pregunta porqué siempre que se me ha activado la Swap el ordenador va sensiblemente mas lento. Esto es uno de los motivos por los cuales instalé lubuntu y estoy usando programas que consuman poca ram.

+1
0
-1