Problema No funciona wifi en sony vaio vpcy2 con ubuntu 11.04 [SOLUCIONADO]

Imagen de edmen
0 puntos

hace un par de semanas que tengo esta note, y el lunes que me decidi a ponerle alguna distro, elegi ubuntu por la facilidad de instalacion y eso, en mis otras maquinas uso debian y sobre todo para armar servidores sencillos.
en esta note cuento con dos sistemas instalados y funcionando : windows 7 ultimate y Ubuntu 11.04 Natty Narwhal,
No tuve muchos problemas al instalar esta version de ubuntu, en lo que respecta la instalacion en general muy sencilla ya que hasta que me decidi ponerle la configuracion de teclado en mi caso teclado yanqui ya estaba finalizando la instalacion, ahora vamos a lo que es el tema principal de este hilo, la wifi
este modelo de note tiene esta wifi
Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
asi que lo que hice me funciono para este modelo

use comandos en terminal ya que es la mejor forma de tener el control absoluto.
edmen@edmen-VPCY2190X:~$ rfkill list
ahi me tiro el listado de todo los componentes de mi maquina y su estado bloqueado o no tanto en hard y soft , en la parte izquierda el numero del componente comienza desde 0, es para identificarlo, veran que les sale algo de un componente marca ACER, bueno ami me salio , en ese momento no le preste atencion, sigamos entonces los desbolquee con esto

edmen@edmen-VPCY2190X:~$ rfkill unblock all

ya estan desbloqueados, me dije , ya esta pense, ahora instalo el wicd, aplicacion para mi de las mejores para la administracion de redes, si quieren instalar esto lo hacen si no no

sudo apt-get install wicd

y ahi empeze a recontramil putear ya que no me funcionaba la wifi, me dije la tengo bien instalada, en lo que refiere a controlador (lo hace automaticamente en el proceso de instalacion), la desbloquee, asi que me arde la cabeza, y segui jugueteando con el rfkill y cuando liste nuevamente los componenetes recien me puse a pensar por que me lista algo con el nombre o denominado ACER, me pregunte esta es una sony vaio, ahi me puse a googlear, y gracias google, encontre la solucion,

El problema es causado por un módulo configurado para portátil ACER que por alguna razón desconocida se carga y se estropea.
Entonces, ¿cómo hacer para este módulo no está cargado?
La solución es simple, basta con añadir al ultimo
"blacklist acer-wmi" sin comillas
en
/ etc / modprobe.d / blacklist.conf para hacer esto sudo gedit /etc/modprobe.d/blacklist.conf, el quiere puede hacer un backup del archivo blacklist por cualquier cosa y reinicie el ordenador portátil. Debe funcionar normalmente si el wifi no esté físicamente desconectado de la unidad. Ami me funciono ah y cuando por enesima vez ejecute el rfckill me salio esto.
edmen@edmen-VPCY2190X:~$ rfkill list
0: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

si ven nada de acer
Espero que les sirva a los que estan luchando con esto, prueben con otros modelos a ver si funciona, trate de explicarlo lo mejor que pude.
Todavia tengo algo que no me convence es el modo de suspenison, hibernacion, cuando paso a alguno de esos modos el sistema no se recupera es decir me queda la pantalla negra y debo apagar la maquina y encenderla de nuevo, por ahora configure la note para que cuando cierre la tapa o este inactiva por un tiempo largo se apague directamente ya que lo tengo que hacer de todos modos, si alguien tuvo ese problema y le dio solucion me avisa

Imagen de jljuanluis
+1
0
-1

Gracias edmen por tu solución.

+1
0
-1
Imagen de francofx
+1
0
-1

Gracias edmen sos un groso

+1
0
-1

Fr4nKite

Imagen de bawatakco
+1
0
-1

hice tu turotial sin mucha fe, pero cuando vi que funcionó fue excelente, yo tengo un packard bell dot z5 e igual tenía ese problema, pero conm tu tutorial está todo solucionado, muchas gracias

+1
0
-1
Imagen de iesmval
+1
0
-1

Llevaba un año sin wifi. Y también tengo un sony vaio.

+1
0
-1
Imagen de Dante_02
+1
0
-1

Realicé los pasos tal como se explican , y FUNCIONÓ a la perfección, mil y mil gracias, llevaba 1 año con el mismo problema y había intentado de todo, muchas gracias nuevamente.

Funcionó en mi portátil Lenovo V360 con módulo de red inalámbrica Atheros AR9285.

+1
0
-1
Imagen de tenorio666
+1
0
-1

ola una preguntota yo tengo una sony vaio vpcek20al con ubuntu 11.10 y tu solucion me salio bien pero ese no es el problema si no que el bluetoock aparece como desactivado como lo puedo activar porfa urge tu respuesta

+1
0
-1
Imagen de omar_13596@hotmail.com
+1
0
-1

ERES EN GENIO DONDE TE PONGO TU MONUMENTO
CASI DOS MESES BUSCANDO LA SOLUCION HASTA QUE AL FIN LA ENCONTRE

pd. las mejores laps son las mac y las vaio
aunque cueste trabajo arreglar la coneccion wifi

+1
0
-1
Imagen de Tsukiakari_LH
+1
0
-1

Tengo una compaq presario cq40, y no me conecta el wifi, pero a mi no me sale el ACER.. alguien k me ayude es urgente.. gracias...

+1
0
-1
Imagen de trendevapor
+1
0
-1

Gracias muchas. Perfecto en Ubuntu 12.04. Packard Bell y Atheros ath9k.

+1
0
-1
Imagen de Tarzanjane
+1
0
-1

Mil gracias llevaba dias buscando la solución!!!!!

+1
0
-1