Antes que nada muchas gracias a eugoias por haberme respondido un tema anterior... bueno ahora... mi duda, lo que pasa es que voy a hacer unos proyectos de la escuela en php, con bases de datos en mysql y con un servidor apache, bueno... el php y el apache los he instalado y funcionan a la perfección, pero cuando pongo me sale en la consola que no se puede porque o ya esta corriendo o,,, bueno no recuerdo que otra cosa me sale y luego instalé el phpmyadmin, y lo corro en la consola y me dice que no se puede conectar con root@localhost... cabe señalar que antes de eso en la instalación de mysql, me salió que tenía ke instalar postfix y bueno lo descargue y se instaló... y a la hora de configurarlo no supe como porque la verdad pues soy nuevo en linux y todo esto, siempre había utilizado windows pero ahora me veo forzado a utilizar linux por cuestiones del lugar donde trabajo... sin embargo la verdad esto me gusta mucho, es muy entretenido... y bueno siguiendo con lo de postfix, le puse que no lo configurara y así lo dejé... tendrá eso algo que ver???... ahora cuando instalé el phpmyadmin, lo instalé y luego hice: http://localhost/phpmyadmin en el navegador para ver si funcionaba, y me sale una página en la que dice que hay un problema en la configuración del php... demonios... no sé que hacer... ojalá me hayan entendido y me puedan ayudar... ha x cierto el php y mysql y todo eso vi como se instalaban desde una página también de ubuntu pero esta en inglés... y los instalé mas o menos asi:


aptitude install php5 apache2 mysql-server

y el phpmyadmin:

aptitude install phpmyadmin

Imagen de yeimsvond
+1
0
-1

Hola,

Para solucionar el problema tienes que decirle a apche que use php, esto se hace desde el archivo httpd.conf añadiendo una línea. La línea no me la sé de memoria pero buscando en google seguro que la encuentras pues es algo muy común. De todas formas creo que está comentado (#) en el archivo la línea que te da soporte php.

Un saludo

PD: Tendrás que buscar donde está la instalación de apache para encontrar el httpd.conf, alomejor alguien del foro te lo dice ¿?, yo es que no lo instalo por paquetes.

PD2: Es posible que con phpmyadmin tengas que entrar en un archivo de configuración para darte permisos, pero todo eso depende de como este hecho el paquete.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Bueno de antemano muchas gracias... y bueno, el php y el apache funcionan, lo que no me funciona es el mysql, ya que cuando hago ... me dice eso de que ya esta corriendo y con el phpmyadmin, me dice que no se puede conectar con root@localhost

+1
0
-1