Problemas con DPKG en Ubuntu Server 10.04

Imagen de sinichi14
0 puntos

Buenas a todos,

después de estar investigando y llegar a la desesperación, acudo a vosotros para saber cómo resolver el siguiente problema que expongo. Viene a la hora de usar apt-get para instalar/eliminar/purgar.... Desesperante:

dpkg: aviso: falta el fichero de lista de ficheros del paquete `libept0', se supondrá que el paquete no tiene ningún fichero actualmente instalado.
(Leyendo la base de datos ... 70%dpkg: error fatal irrecuperable, abortando:
falta un salto de lí­nea nueva al final del fichero de lista de ficheros del paquete `libgnutls26'
E: Sub-process /usr/bin/dpkg returned an error code (2)

¿Alguna solución al problema? He googleado pero tampoco he encontrado mucho relacionado, y lo que he ido encontrando/probando no ha servido de mucho v.v

Muchas gracias de antemano.

Un saludo!

Imagen de Scorpyo82
+1
0
-1

Prueba con :

sudo apt-get install -f

si no funciona pon :

cat /var/lib/dpkg/status | grep libgnutls26

Copia lo que te sale y pegalo aquí, pero por favor, pégalo como código, para entenderlo mejor.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de sinichi14
+1
0
-1

Gracias por la ayuda Scorpyo82.

Con sudo apt-get install -f me saca lo siguiente:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
0 actualizados, 0 se instalarán, 0 para eliminar y 8 no actualizados.

Y ahí finaliza. Con cat /var/lib/dpkg/status | grep libgnutls26:

Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.8), samba-common-bin, libwbclient                                                                                                                               0 (= 2:3.4.7~dfsg-1ubuntu3.8), libacl1 (>= 2.2.11-1), libattr1 (>= 2.4.41-1), li                                                                                                                               bc6 (>= 2.8), libcap2 (>= 2.10), libcomerr2 (>= 1.01), libcups2 (>= 1.4.0), libg                                                                                                                               nutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.8+dfsg), libk5crypto3 (>= 1.6.dfsg                                                                                                                               .2), libkrb5-3 (>= 1.7dfsg), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), l                                                                                                                               ibpopt0 (>= 1.15), libtalloc2 (>= 2.0.0), zlib1g (>= 1:1.1.4), debconf (>= 0.5)                                                                                                                                | debconf-2.0, upstart-job, libpam-runtime (>= 1.0.1-11), libpam-modules, lsb-ba                                                                                                                               se (>= 3.2-13), procps, update-inetd, adduser
Depends: libc6 (>= 2.11), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), lib                                                                                                                               gssapi-krb5-2 (>= 1.7+dfsg), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1                                                                                                                               g (>= 1:1.1.4), ca-certificates
Depends: libgtk2.0-common, libatk1.0-0 (>= 1.29.3), libc6 (>= 2.11), libcairo2 (                                                                                                                               >= 1.6.4-6.1), libcups2 (>= 1.4.0), libfontconfig1 (>= 2.8.0), libfreetype6 (>=                                                                                                                                2.2.1), libglib2.0-0 (>= 2.23.6), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>                                                                                                                               = 1.6.dfsg.2), libjasper1 (>= 1.900.1), libjpeg62, libpango1.0-0 (>= 1.20.0), li                                                                                                                               bpng12-0 (>= 1.2.13-4), libtiff4, libx11-6 (>= 0), libxcomposite1 (>= 1:0.3-1),                                                                                                                                libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6 (>= 0), libxfixes3 (>=                                                                                                                                1:4.0.1), libxi6 (>= 0), libxinerama1, libxrandr2 (>= 2:1.2.99.3), libxrender1,                                                                                                                                zlib1g (>= 1:1.1.4), shared-mime-info
Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6 (>= 2                                                                                                                               .4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), zlib1g (>= 1:1.1                                                                                                                               .4)
Depends: libc6 (>= 2.3.6-6~), libcurl3-gnutls (>= 7.19.5), libgcrypt11 (>= 1.4.2                                                                                                                               ), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libidn11 (>= 1.1                                                                                                                               3), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), python (<< 2.7), python (>= 2                                                                                                                               .6), python-support (>= 0.90.0)
Package: libgnutls26
Depends: libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfs                                                                                                                               g), libsasl2-2

Un saludo!

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Con el segundo comando la estructura de las lineas debería ser similar a esta:

Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.8), samba-common-bin, libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.8), libacl1 (>= 2.2.11-1), libattr1 (>= 2.4.41-1), libc6 (>= 2.8), libcap2 (>= 2.10), libcomerr2 (>= 1.01), libcups2 (>= 1.4.0), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.8+dfsg), libk5crypto3 (>= 1.6.dfsg.2), libkrb5-3 (>= 1.7dfsg), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), libpopt0 (>= 1.15), libtalloc2 (>= 2.0.0), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0, upstart-job, libpam-runtime (>= 1.0.1-11), libpam-modules, lsb-base (>= 3.2-13), procps, update-inetd, adduser Depends: libc6 (>= 2.11), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), ca-certificates Depends: libgtk2.0-common, libatk1.0-0 (>= 1.29.3), libc6 (>= 2.11), libcairo2 (>= 1.6.4-6.1), libcups2 (>= 1.4.0), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libglib2.0-0 (>= 2.23.6), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libjasper1 (>= 1.900.1), libjpeg62, libpango1.0-0 (>= 1.20.0), libpng12-0 (>= 1.2.13-4), libtiff4, libx11-6 (>= 0), libxcomposite1 (>= 1:0.3-1),libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6 (>= 0), libxfixes3 (>= 1:4.0.1), libxi6 (>= 0), libxinerama1, libxrandr2 (>= 2:1.2.99.3), libxrender1, zlib1g (>= 1:1.1.4), shared-mime-info Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), zlib1g (>= 1:1.1.4) Depends: libc6 (>= 2.3.6-6~), libcurl3-gnutls (>= 7.19.5), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), python (<< 2.7), python (>= 2.6), python-support (>= 0.90.0) Package: libgnutls26 Depends: libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), libsasl2-2

(Esa no es la mía, es la tuya corregida desde mi punto de vista...)
Y no como te aparece a tí, con espacios grandes y cortes en las palabras. puede que tu archivo status esté corrupto.
También puede ser que al pegarlo aquí se esté interpretando algo como código, pero no creo.
De todas maneras, eso lo sabrás tú, si antes de pegarlo tenía o no esos espacios tan grandes cortando las palabras y las dependencias...
Yo revisaría tambien el archivo backup de status (status-old) que está en la misma carpeta.

cat /var/lib/dpkg/status-old | grep libgnutls26

Mira a ver eso que te digo y me comentas.

Un saludo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de sinichi14
+1
0
-1

Buenas!

Lo de los espacios puede ser por Putty, te lo vuelvo a poner tal cual lo saco:

cat /var/lib/dpkg/status | grep libgnutls26

Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.8), samba-common-bin, libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.8), libacl1 (>= 2.2.11-1), libattr1 (>= 2.4.41-1), libc6 (>= 2.8), libcap2 (>= 2.10), libcomerr2 (>= 1.01), libcups2 (>= 1.4.0), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.8+dfsg), libk5crypto3 (>= 1.6.dfsg.2), libkrb5-3 (>= 1.7dfsg), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), libpopt0 (>= 1.15), libtalloc2 (>= 2.0.0), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0, upstart-job, libpam-runtime (>= 1.0.1-11), libpam-modules, lsb-base (>= 3.2-13), procps, update-inetd, adduser
Depends: libc6 (>= 2.11), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), ca-certificates
Depends: libgtk2.0-common, libatk1.0-0 (>= 1.29.3), libc6 (>= 2.11), libcairo2 (>= 1.6.4-6.1), libcups2 (>= 1.4.0), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libglib2.0-0 (>= 2.23.6), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libjasper1 (>= 1.900.1), libjpeg62, libpango1.0-0 (>= 1.20.0), libpng12-0 (>= 1.2.13-4), libtiff4, libx11-6 (>= 0), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6 (>= 0), libxfixes3 (>= 1:4.0.1), libxi6 (>= 0), libxinerama1, libxrandr2 (>= 2:1.2.99.3), libxrender1, zlib1g (>= 1:1.1.4), shared-mime-info
Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), zlib1g (>= 1:1.1.4)
Depends: libc6 (>= 2.3.6-6~), libcurl3-gnutls (>= 7.19.5), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), python (<< 2.7), python (>= 2.6), python-support (>= 0.90.0)
Package: libgnutls26
Depends: libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), libsasl2-2

cat /var/lib/dpkg/status-old | grep libgnutls26

Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.8), samba-common-bin, libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.8), libacl1 (>= 2.2.11-1), libattr1 (>= 2.4.41-1), libc6 (>= 2.8), libcap2 (>= 2.10), libcomerr2 (>= 1.01), libcups2 (>= 1.4.0), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.8+dfsg), libk5crypto3 (>= 1.6.dfsg.2), libkrb5-3 (>= 1.7dfsg), libldap-2.4-2 (>= 2.4.7), libpam0g (>= 0.99.7.1), libpopt0 (>= 1.15), libtalloc2 (>= 2.0.0), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0, upstart-job, libpam-runtime (>= 1.0.1-11), libpam-modules, lsb-base (>= 3.2-13), procps, update-inetd, adduser
Depends: libc6 (>= 2.11), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), ca-certificates
Depends: libgtk2.0-common, libatk1.0-0 (>= 1.29.3), libc6 (>= 2.11), libcairo2 (>= 1.6.4-6.1), libcups2 (>= 1.4.0), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libglib2.0-0 (>= 2.23.6), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libjasper1 (>= 1.900.1), libjpeg62, libpango1.0-0 (>= 1.20.0), libpng12-0 (>= 1.2.13-4), libtiff4, libx11-6 (>= 0), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6 (>= 0), libxfixes3 (>= 1:4.0.1), libxi6 (>= 0), libxinerama1, libxrandr2 (>= 2:1.2.99.3), libxrender1, zlib1g (>= 1:1.1.4), shared-mime-info
Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), zlib1g (>= 1:1.1.4)
Depends: libc6 (>= 2.3.6-6~), libcurl3-gnutls (>= 7.19.5), libgcrypt11 (>= 1.4.2), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.6.dfsg.2), libidn11 (>= 1.13), libldap-2.4-2 (>= 2.4.7), zlib1g (>= 1:1.1.4), python (<< 2.7), python (>= 2.6), python-support (>= 0.90.0)
Package: libgnutls26
Depends: libc6 (>= 2.4), libgnutls26 (>= 2.7.14-0), libgssapi-krb5-2 (>= 1.7+dfsg), libsasl2-2

Un saludo

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Pues ahí parece que no hay nada mal, por lo menos en esos párrafos.

Entonces no sé a que se refiere dpkg cuando te dice que le falta un salto de línea.... y mira que he buscado en páginas de foros hasta en inglés... pero no encuentro nada claro, exepto una persona que le salía lo mismo pero empezó a borrar todo lo referente a esa librería dentro del archivo status (cosa que no te recomiendo para nada) y luego se puso a borrar de otros sitios todo lo referente a esa librería... pero repito, no es una solución lógica, porque seguro que a la larga será mucho peor.

Un saludo.

PD: Si me entero de algo posteo.

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.