Problemas de dependencia, al parecer con kernel muestra paquetes rotos ubuntu 10.4

Imagen de nicofgl
0 puntos

Hola, al tratar de actualizar el sistema me di cuenta que había un error de dependencia de ciertos paquetes.

Tengo el siguiente paquete roto: language-pack-es

A) Ahora bien, he intentado los siguientes comandos: 1) sudo dpkg --purge --force-remove-reinstreq
2) sudo apt-get install -f
3) dpkg --listfiles

B) Con el instalador de paquetes me sale el siguiente error:

"Error: Se produjo un fallo al intentar satisfacer todas las dependencias (almacén dañado)"

C) Intento re-instalar el siguiente paquete: "libdesktop-agnostic0 0.3.90-0ubuntu1"

En "A)" 1 y 3 me sale el mensaje que el paquete no existe o ya está desinstalado. En 2 me sale en siguiente error:

"Sub-process /usr/bin/dpkg returned an error code (1)"

En "C)" me es imposible crearlo porque me tira el error del paquete dañado.

Hasta el momento no he podido instalar ni desintalar nada, tampoco puedo actualizar el sistema.

Ayuda por favor.

Gracias

Imagen de MilagrosL
+1
0
-1

yo tenía problemas con los paquetes y actualicé el SO desde un disco,
descargué Ubuntu 11.04 LTS y grabé la imagen en un disco,
lo puse, al reiniciar la compu arrancó desde el disco y le dije instalar,
detectó una versión existente y actualizó el sistema,
ahora me va de maravilla, instala actualizaciones, no más paquetes rotos, y puedo seguir instalando y desinstalando de todo.
espero que soluciones tu problema,
Saluditos

+1
0
-1

Milagros

Imagen de cuentos
+1
0
-1

si tienes instalado synaptic, trae una opcion para reparar paquetes rotos

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de nicofgl
+1
0
-1

Hola, he leido que al actualizar han habido problemas de datos, alguna de la información privada se borra. Tengo el /home en una partición aparte, creo que podría ser la última una solución.

Respecto del synaptic, sí lo tengo y me dice que el paquete roto es:

"libmysqlclient16"

y al intentar reparar el paquete roto me tira el siguiente error:

" language-pack-es: El paquete está en un estado muy malo e inconsistente - debe reinstalarlo antes de intentar desinstalarlo."

Y como expuse arriba, no puedo reinstalar nada, porque no me deja por este paquete roto

Gracias

+1
0
-1
Imagen de cuentos
+1
0
-1

y en el mismo synaptic probaste marcarlo para reistalarlo

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de pacoexe
+1
0
-1

Tu respuesta me ayudo a solucionar mi problema gracias.

+1
0
-1
Imagen de nicofgl
+1
0
-1

Aún no lo soluciono, me sale el siguiente error:

"E:I wasn't able to locate file for the firefox-locale-en package. This might mean you need to manually fix this package., E:I wasn't able to locate a file for the firefox-locale-es package. This might mean you need to manually fix this package. (due to missing arch), E:I wasn't able to locate a file for the linux-image-2.6.32-39-generic package. This might mean you need to manually fix this package. (due to missing arch): "

Ayuda.....

Gracias

+1
0
-1