No aparece el grub para seleccionar el arranque dual

Imagen de dcircus
0 puntos

Hola!

He instalado ubuntu 11 junto con windows xp, para tener opción al arranque dual pero una vez instalado todo ok y reiniciado siempre sale windows directamente y no hay opción a seleccionar el sistema operativo que quiero. He probado varias veces a reinstalar ubuntu y reparar pero sin resultados.

Buscando en los foros veo varios temas pero no consigo encontrar la solución adecuada.

Gracias por adelantado.

Imagen de daniel_perella
+1
0
-1

Versión de Windows?

+1
0
-1

-----------------------------------------------------------------------------------------

Por favor, leed la documentación, que para algo la escribimos...

http://ubuntulinuxafondo.blogspot.com/

Imagen de .doc
+1
0
-1

bueno, si alguien quiere saber la versión, dínosla, pero sería bueno también que nos dijeses cómo tienes las particiones en tu disco duro (cuantas, y tamaño y tipo de cada una), para ver si se ha instalado Ubuntu

O, mejor aún, descárgate la ISO del supergrub2 (lo encuentras fácil con Google), quémala en un CD, arranca con él y, en 'Detect any Operating System mira a ver si te encuentra tu Ubuntu, y si puedes arrancar con él desde ahí mismo.
Y nos lo cuentas.

+1
0
-1
Imagen de daniel_perella
+1
0
-1

He instalado ubuntu 11 junto con windows xp, para tener opción al arranque dual pero una vez instalado todo ok y reiniciado siempre sale windows directamente y no hay opción a seleccionar el sistema operativo que quiero.

Entonces BIEN instalado no está, porque no se te está grabando grub en el mbr del disco.

He probado varias veces a reinstalar ubuntu y reparar pero sin resultados.

Y qué proceso has seguido? ¿Cómo has hecho las particiones? ¿Tienes uno o varios discos? en caso de varios... ¿instalas grub en el disco que la BIOS tiene configurado como disco de arranque?

+1
0
-1

-----------------------------------------------------------------------------------------

Por favor, leed la documentación, que para algo la escribimos...

http://ubuntulinuxafondo.blogspot.com/

Imagen de dcircus
+1
0
-1

Ante todo muchas gracias!

Había una partición libre en otro disco distinto a C: , era una partición de 10 GB y después de instalar ubuntu esa partición está ocupada, al instalar ubuntu no me preguntó nada acerca de particiones por lo que supongo que lo instaló en esa partición y efectivamente no está en el mismo disco de arranque de la bios.

Voy a probar ahora lo del Supergrub2 a ver si detecta el ubuntu

+1
0
-1
Imagen de daniel_perella
+1
0
-1

Si instalas ubuntu, vamos a decir en D: (que sería /dev/sdb1) debes instalar grub en el disco de arranque (que sería C: o /dev/sda) porque la bios va a cargar ese disco.

Por eso no te detecta windows, porque al instalar el cargador en D: no "ve" windows.

Instalar el cargador de arranque (grub) en C: no destruye datos, ya que se aloja en una parte del disco que se llama mbr.

+1
0
-1

-----------------------------------------------------------------------------------------

Por favor, leed la documentación, que para algo la escribimos...

http://ubuntulinuxafondo.blogspot.com/

Imagen de dcircus
+1
0
-1

Con el supergrub2 al darle a detectar los SO sólo aparece windows, supongo que el problema está en particionar el disco C y que ubuntu me pregunte la particion al instalar.

Intentare probar eso

+1
0
-1