Problema con wifi y conexión de red en ubuntu 12.04

Imagen de Gabriel555
0 puntos

¿Qué tal? Instalé Ubuntu 12.04 en una netbook Toshiba C655D Satellite ,pero solo inicia sesión conectada al cable de red.

Es habilitar el wifi y a veces se tranca casi al comenzar y otras veces sigue muy bien pero al reiniciar si no es conectada al cable de red se tranca y no funciona.

Tiene un adaptador de red Ethernet 802.3 de Atheros.

Tampoco puedo instalar los drivers de AMD pues aparece como error interno.

Tengo ubuntu en un dual boot con windows 7 ultimate, la máquina venía con starter.

Probé instalando primero Ubuntu 10.04 pero no me aparecía ningua red, no. Por lo demás el sistema funciona muy bien. No soy muy entendido en esto .

P/D: sois un poco agresivos en la moderación, si soy principiante, de hecho no me quedan claras varias cosas. Se supone que la filosofía de Ubuntu es la de ayudar y eliminar el pedido de ayuda antes que derivarlo no colabora en generar esa imagen

Imagen de DINAMIK
+1
0
-1

Tampoco puedo instalar los drivers de AMD pues aparece como error interno.
me pasa lo mismo, creo que es problema de amd y no nuestro, hay que esperar

Qué tal? Instalé Ubuntu 12.04 en una netbook Toshiba C655D Satellite ,pero solo inicia sesión conectada al cable de red.

la 12.04 esta en beta todavia, posiblemente venga por ahi el tema

+1
0
-1
Imagen de Rodrigo Manzo
+1
0
-1

logré una solución temporal que al menos para mi tarjeta Atheros funciona bien:

1- prueba con sudo apt-get update && sudo apt-get dist-upgrade conectado a una red cableada(eso funciona casi siempre)

2- lo segundo que ha resultado (cuando lo anterior no ha resultado de inmediato) es apagar el inalámbrico (desde la barra de Gnome) y luego Apagar el computador (reiniciar no resulta). luego una vez iniciado el entorno vuelves a prender el adaptador desde la barra y ahí funciona de nuevo.

de lo poco que se y que he podido averiguar es un problema de calibración de mi tarjeta de wifi, no se en específico cuál sea tu problema, pero espero que te funcione la respuesta

+1
0
-1
Imagen de nicolasmilone
+1
0
-1

mi red inalambrica fuincionaba perfecto hasta que la reinicie y luego dejo de funcionar, esa segunda solucion qe diste me funciono una vez pero ahora no ya no se qe hacer

+1
0
-1
Imagen de nicolasmilone
+1
0
-1

una pregunta, solo tienes qe desactivar la red inalambrica o la red?

+1
0
-1
Imagen de nicolasmilone
+1
0
-1

Antes la red inalambrica andaba perfecto, creen que si la formateo de vuelta vuelva a funcionar?

+1
0
-1
Imagen de le-zorr0
+1
+1
-1

El siguiente problema me apareció al instalar Ubuntu 11.10 en una laptop Toshiba C645D-SP4248L... actualmente tengo Ubuntu 12.04 (pensé que con con el upgrade podría solucionarse, pero no lo hizo). El problema se da también tanto en Unity como en Gnome-Shell.

Vamos al grano --> El asunto es que el sistema funciona de maravillas SIEMPRE Y CUANDO el cable de la conexión de red (RJ45) se mantega conectando al laptop con mi router, en caso de ser retirado el pc aguanta 1 minuto aproximadamente antes de pegarse y funcionar mas (ni siquiera puedo mover el mouse, ni entrar en una consola con CTRL+ALT+F1, ni reiniciar de manera correcta con Alt+Impr Pant+REISUB) lo que me obliga a reiniciar a la mala :S.

Ahora les cuento lo que ya intenté y que no dio resultado:

-Prender el PC sin el cable conectado --> luego de arrancar bien el sistema a los pocos segundos se cuelga igual
-Prender el PC con el cable conectado y una vez que funciona bien desconectarlo --> dura aprox 1 minuto y se cuelga
-Pensé en un momento que era el wifi el que daba el problema, pero no es dado que con el cable conectado puedo conectarme sin problema a redes wifi y no se cuelga si no desconecto el cable
-También con el cable conectado intente bajar la interfaz eth0 (sudo ifconfig eth0 down) y sigue funcionando bien el PC hasta que desconecte el cable
-Baje tambien la wlan0 para descartarla (sudo ifconfig wlan0 down) llegando al mismo resultado, todo anda bien hasta que saco el cable.
-Cerré el network-manager (sudo /etc/init.d/network-manager stop) y llegué a lo mismo.

Con todo eso he descartado que sea problema de interfaz (eth0 o wlan0), que sea el network-manager o que sea el entorno grafico. La verdad ya no se que hacer me es muy desagradable tener que estar siempre a 1 metro de mi router y no poder llevar mi PC fuera de casa porque no andará si no lo conecto a un cable de red :S.

De antemano muchas gracias por tomarse el tiempo para leerme, espero sus comentarios.

+1
+1
-1
Imagen de ricardsand
+1
+2
-1

Con en mismo problema que ustedes en ubuntu 12.04, llegue a este post, y buscando y buscando encontré esta solución que he probado y resolvió el problema.
Hay que configurar la bios para que no arranque desde el disco duro o unidad de DVD, y cambiarlo para que arranque desde LAN, esto resuelve el problema, arranca si el cable de red y detecta las señales wifi, podés usar el cabe de red a tu antojo y quitarlo y ya no se congela. aquí dejó el sitio que tiene esta solución y otras posibles.
saludos
http://translate.google.com/translate?hl=es&langpair=en|es&u=http://ubuntuforums.org/showthread.php%3Ft%3D1805387

+1
+2
-1
Imagen de mlorca
+1
+1
-1

Muchas gracias RICARDSAND por una solución simple y efectiva. Ya había probado 4 distribuciones y con todas pasaba lo mismo. Jamás se me ocurrió que el problema pudiera estar en la BIOS, pero efectivamente allí está.
Gracias nuevamente.

+1
+1
-1
Imagen de arturo valdez
+1
0
-1

hola una pregunta me podrias decir como le hiciste es que la verdad por mas que le busco no le encuentro por favor ayudame de antemano muchas gracias

+1
0
-1

:D

Imagen de saulcanastuj
+1
0
-1

tu aporte me salvo, igual si funciono. GRACIAS.

+1
0
-1
Imagen de saulcanastuj
+1
0
-1

Ricardsand, ¿ has encontrado información si este problema se puede solucionar de otra forama ? en definitiva ya que la opción de la modificación del bios solo funciona si hay una red wifi cerca de otra forma si no hay se queda colgado el sistema. gracias.

+1
0
-1
Imagen de jomarocas
+1
0
-1

Desde siempre, trabajar desde la consola tiene sus pro y contras. Una contra es la incomodidad para conectarse a una red WiFi facilmente. Voy a tratar de explicar una forma un tanto mas sencilla.

Una vez que tenemos instalado el sistema basico, el paquete impresindible a instalar es wireless-tools. Viene incluido en el CD/DVD 1 en Debian, y en el CD de Ubuntu. ( para la el tipo CD-Netinstall es necesario conectarse por cable.)

Primero nos logueamos como root:

En Debian:
franco@debian-fg:~$ su
Contraseña: ******
debian-fg:/home/franco#

En Ubuntu:
franco@ubuntu-fg:~$ sudo bash
Contraseña:
ubuntu-fg:/home/franco#

Luego procedemos a instalar el paquete wireless-tools:

En ambos:
debian/ubuntu-fg:/home/franco# apt-get install wireless-tools

Ahora verificamos que la tajeta WiFi de nuestra computadora es reconocida correctamente por el sistema:

En mi caso el nombre de la interface de red Wifi se llama wlan0, pero esto puede variar (ath0, brt0, etc..):

debian/ubuntu-fg:/home/franco# iwconfig
lo no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:"dlink2"
Mode:Managed Frequency:2.447 GHz Access Point: 00:1C0:3B:59:67
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality=56/64 Signal level=34/65
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

*Si no aparece tu tarjeta con, visita este post para instalarla http://www.taringa.net/posts/linux/2635906/Linux-Wireless---Drivers-nati...

Bien, el paso siguiente es buscar la red WiFi a la debemos conectarnos:

debian-fg:/home/franco# iwlist scan
lo Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:1C0:3B:59:67
ESSID:"dlink2"
Mode:Master
Channel:8
Frequency:2.447 GHz (Channel 8)
Quality=39/64 Signal level=29/65
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000142754be7a

eth0 Interface doesn't support scanning.

Ahora debemos identificar el nombre de la red "ESSID", en mi caso se llama dlink2. Luego si tiene contraseña o no ( por el momento solo admite WEP 64/128bits), en el ejemplo dice "Encryption key: off". En mi router no tengo puesta contraseña por que tiene activado el filtro por direccion MAC y porque ningun vecino mio tiene menos de 65 años, asi que por el momento no es necesario, pero siempre es recomendable poner cualquier contraseña.

Ya sabiendo el ESSID y la clave nos podemos conectar tranquilamente, este ejemplo lo pongo como si mi red tuviese contraseña en 64bits:

debian-fg:/home/franco# iwconfig wlan0 essid dlink2 key 3135393230

La sintaxis del comando es muy sencilla. "iwconfig" es el progrma que permite hacer la conexion, "wlan0" es el nombre de la interface de red WiFi de nuestra computadora, "essid" es el parametro a completar con el nombre de la red, y "key" aplica a ser la llave o clave de red. Por defecto "key" solicita la clave en Hexadecimal, podemos ponerla en ASCII poniendo el prefijo s:, por ejemplo:

debian-fg:/home/franco# iwconfig wlan0 essid dlink2 key s:15920

Bien, teoricamente estamos conectados, segun la pagina oficial, pude que debamos repetir 1 o 2 veces el comando para asegurarnos de la conexion. Bien ahora si no tenemos definida la configuracion IP de nuestra tarjeta, no hay problema, con dhclient (el cliente DHCP por defecto en linux) gestionamos la IP automaticamente:

debian-fg:/home/franco# dhclient wlan0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:18:e7:2d:cb:16
Sending on LPF/wlan0/00:18:e7:2d:cb:16
Sending on Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
bound to 192.168.0.100 -- renewal in 236179 seconds.

Con esto concluye la conexion a la red WiFI, para verificarlo podemos hacer un ping a cualquier sitio de internet, por ejemplo:

debian-fg:/home/franco# ping 209.85.195.104
PING 209.85.195.104 (209.85.195.104) 56(84) bytes of data.
64 bytes from 209.85.195.104: icmp_seq=1 ttl=247 time=29.2 ms
64 bytes from 209.85.195.104: icmp_seq=2 ttl=247 time=35.1 ms
64 bytes from 209.85.195.104: icmp_seq=3 ttl=247 time=27.2 ms
^C
--- 209.85.195.104 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2006ms
rtt min/avg/max/mdev = 27.274/30.548/35.155/3.352 ms

*El comando ping en Linux, por defecto, es indefinido, debemos cortarlo a mano pulsando Ctrl + C.

Bueno, espero que a alguien le sirva, no es muy complicado.

+1
0
-1
Imagen de tbk
+1
0
-1

hola!
tuve un problema parecido
necesitaba tener una distro de linux en mi pc
asi que decidi instalar ubuntu 10.10 el cual me andaba perfecto en mi computador anterior
sin embargo desde el proceso de instalacion no me detectaba ninguna red ( inalambrica ni cableada)
segui con la instalacion por que crei que quizas despues se arreglaria pero no.
entonces decidi probar con ubuntu 12.04 el cual solo me reconocia la red cableada
despues de mucho buscar encontre esto que solucionó mi problema

http://www.ubuntu-es.org/node/155497

espero que les sirva !

+1
0
-1
Imagen de milo_sama91
+1
0
-1

**/Moderado/** http://pastebin.ubuntu.com/6344283/

Por favor abre un hilo propio, Gracias

+1
0
-1

THE REVOLUTION OF THE WORLD, IT'S THE FREESOFT