Ubuntu 12.04 solo usa 1 CPU de 4

Imagen de grigri
0 puntos

(SOLUCIONADO) : Actualicé la BIOS del portátil y ahora va perfecto: usa las 4 cpu y tengo la máxima resolución de pantalla 1366 en lugar de los 1024 pixeles en horizontal.
Es un error de la BIOS de Intel y no de Linux; últimamente los desarrolladores del núcleo usan parte del código de la BIOS . . . y así nos va.

Los foros están "plagados" de gente con el mismo problema, bien sea pantalla negra o recalentón por uso de una sola CPU. En mi caso estuve puteado con este problema hasta ahora 17 Febrero 2013. y estaba hasta los CJNS .
________________________Fin solución______________________

_______________Empieza el comentario inicial_____________

Tengo un HP G62 que se calienta demasiado 62ºC temperatura normal sin apenas carga. Lo habitual era de 40 a 45ºC.

Observo con el comando "top" y luego pulsando 1, que solo visualiza CPU0
Pruebo con el comando cat /proc/cpuinfo y me da la misma información: solo una CPU
mi portátil tiene 4 cpu's (2 físicas).

El .config del kernel indica que está configurado CONFIG_X86_64_SMP=y
La documentación de Ubuntu indica que predeterminadamente se compila con soporte smp, pero por lo que comento más arriba, diría que es errónea.

Descargo una nueva versión del kernel (3.3.6) desde kernel.org compilo e instalo. Pero sigo en la misma situación con el nuevo kernel: solo una cpu

Además 12.04 no instaló soporte para cpufreq, por lo que supongo que tampoco baja la frecuencia cuando está con bajo porcentaje de utilización.

¿Podeis comprobar si obteneis el mismo resultado: solo un procesador ?

__________________ Editado __________________
Después de probar cosas, añado: cualquier imagen del kernel en modo recuperación sí reconoce las 4 CPU y funciona el cpufreq perfectamente. El problema tiene que ver con acpi=off.
Si no añado este parámetro, el sistema arranca pero la pantalla se queda negra. Si quito el acpi=off se presenta el problema que abrió este post.
Comprobado con kernel de ubuntu 12.04 (64 bits) : 3.2.0-23-generic, actualizado a 3.2.0-24-generic (y 3.3.6 pero este fue descargado de kernel.org.
???????????????
O pantalla negra o bajo rendimiento y calentamiento. Esta es la cuestión.

Imagen de cuentos
+1
0
-1

Que versión de ubuntu instalaste, o mira en la terminal que kernel tienes:
uname -a

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de grigri
+1
0
-1

Modifiqué el post con la información que pides y parece que tiene que ver con acpi.

+1
0
-1
Imagen de grigri
+1
0
-1

Modifiqué el post con la información que pides y parece que el problema tiene que ver con acpi.

+1
0
-1
Imagen de cuentos
+1
0
-1

haber el resultado completo del comando da algo como esto:
Linux deb03 2.6.32-5-amd64 #1 SMP Sun May 6 04:00:17 UTC 2012 x86_64 GNU/Linux
2.6.32-5-amd64
hay te da si tienes el sistema de 32 o 64 bits., para ir viendo.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de grigri
+1
0
-1

Linux grigri-HP-G62 3.3.6 #1 SMP Mon May 21 13:20:54 CEST 2012 x86_64 x86_64 x86_64 GNU/Linux

+1
0
-1
Imagen de furtaxi
+1
0
-1

Prueba a activarlo, o desactivarlo, según como lo tengas.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.