como cambiar el selector de arranque

Imagen de orlando0650
0 puntos

Hola al foro he instalado esta ultima version y he cometido el error de instalar el grub en la particion windows en lugar de MBR y no puedo iniciar el windows ¿ Hay alguna manera de mover el grub al MBR y Windows? Gracias

Imagen de Jose Luis 1320
+1
0
-1

pero antes debes decir como tienes organizado el disco. windows por lo general es la primera partición del disco y ahí se debe de quedar para que pueda arrancar, si quitas a windows de la partición primaria 1, deja de arrancar.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de orlando0650
+1
0
-1

Hola Jose Luis ,este es mi disco

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 204799999 102296576 7 HPFS/NTFS/exFAT
/dev/sda3 204800000 409599999 102400000 7 HPFS/NTFS/exFAT
/dev/sda4 409602046 976769023 283583489 5 Extendida
La partición 4 no se inició en el limite físico del sector
/dev/sda5 409602048 604911615 97654784 83 Linux
/dev/sda6 781459456 976769023 97654784 83 Linux
/dev/sda7 604913664 612724735 3905536 82 Linux swap / Solaris
/dev/sda8 612726784 781449215 84361216 83 Linux
tengo:
window con C: y D:
Debian
Home
Ubuntu en dev/sda/8
Es decir al instalar Ubuntu ya tenia el grub, creo que mi error fue volver a instalarlo en sda1, hay alguna forma de desintalarlo de ahi y hacer un update desde Debian? o algo para recuperar el windows sin tener q reinstalar? Gracias

+1
0
-1
Imagen de cuentos
+1
0
-1

no entiendo lo ultimo que dices;

Es decir al instalar Ubuntu ya tenia el grub, creo que mi error fue volver a instalarlo en sda1, hay alguna forma de desintalarlo de ahi y hacer un update desde Debian? o algo para recuperar el windows sin tener q reinstalar?

Ya tenias instalado ubuntu en sda8, y lo quisiste instalar de nuevo. o lo acabas de instalar, y no te detecta los demás sistemas el grub al iniciar.
Y como realizaste la instalación, desde un cd, o usb.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de orlando0650
+1
0
-1

Ya tenias instalado ubuntu en sda8, y lo quisiste instalar de nuevo. o lo acabas de instalar, y no te detecta los demás sistemas el grub al iniciar.
Y como realizaste la instalación, desde un cd, o usb.

NO. tenia el grub, porque tengo instalada una distro de Debian.Entonces al bootear la pc ingresa al grub de Debian, cuando selecciono Win en ese grub, me deriba al de Ubuntu y no me permite ingresar al win. Concretamente tengo 2 grub (1 en el MBR y otro en SDA1) No se si esta bien explicado asi..... Gracias

+1
0
-1
Imagen de cuentos
+1
0
-1

Intenta esto, si puedes iniciar con debian,prueba a instalar el administrador de arranque, y ya instalado, lo ejecutas y mira si te detecta los tres sistemas, y te los configura.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de orlando0650
+1
0
-1

Intenta esto, si puedes iniciar con debian,prueba a instalar el administrador de arranque, y ya instalado, lo ejecutas y mira si te detecta los tres sistemas, y te los configura.

Eso es lo primero que hice, el tema es eliminar el grub del sda1. Creo que tendré q usar Resactux, salvo alguna mejor opinión. Se agradece

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

¿como volviste a instalar Ubuntu? ¿desde windows? si en /dev/sda1 tienes windows, como la salida de tu fdisk indica, entonces tienes Ubuntu instalado con wubi y todavía tienes Ubuntu en /dev/sda8, Es decir tienes 2 Ubuntus, uno dentro de windows y otro en la partición /dev/sda8.

Desinstala el Ubuntu que instalaste desde windows, y luego reinstala el grub ya sea el de Debian o el de Ubuntu que tienes en /dev/sda8.

sudo grub-install /dev/sda

y luego lo actualizas

sudo update-grub
+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de orlando0650
+1
0
-1

Gracias por el aporte. solucionado

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Debes de subir en el foro tu solución, para que otros usuarios con el mismo o similar problema al tuyo, puedan aprovecharla.

Saludos.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro