Problemas con java

Imagen de MarioQuartz
0 puntos

En la anterior version de Ubuntu tenia instalado java y no nada problemas. Ahora en una pagina en la que necesita java me dice que no tengo java 1.4 o superior. Pero he instalado java 1.6 y 1.7 y el icedtea esta instalado

¿Que puedo hacer?

Imagen de Alcruz
+1
0
-1

Me faltan datos para poder dar una sugerencia,estos serían
1.- Como o usando que método para instalar
2.- Si es de 32 o 64 bits
3.- Ejecuta en un terminal
java -version

pones aquí lo que te sale
4.- En Firefox entra a Herramientas --> Complementos--> Plugins y allí te muestra el que corresponde a Java, copia aquí lo que te muestra.

+1
0
-1
Imagen de MarioQuartz
+1
0
-1

1/ He usado esto:
sudo apt-get install openjdk-6-jdk openjdk-6-jre
sudo apt-get install openjdk-7-jdk openjdk-7-jre
Y ademas el icedtea esta actualizado.

2/ 64 bits

3/
java version "1.7.0_03"
OpenJDK Runtime Environment (IcedTea7 2.1.1pre) (7~u3-2.1.1~pre1-1ubuntu3)
OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)

4/
IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2ubuntu1))

+1
0
-1
Imagen de Alcruz
+1
0
-1

Primero borra lo que has instalado , especialmente el icedtea que va a emtrar en conflicto cob rl jdk 7u4 de Oracle que se instala ejecutando los siguientes comandos en el orden indicado
wget -c http://www.java.net/download/jdk7u4/archive/b19/binaries/jdk-7u4-ea-bin-...

sudo tar zxvf jdk-7u4-ea-bin-b19-linux-x64-05_apr_2012.tar.gz -C /usr/lib/jvm/
sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk1.7.0_04/bin/java 2200
sudo update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk1.7.0_04/bin/javac 2200
sudo update-alternatives --config java
#·En este paso elije la versión de Java que quedará activa, en este caso sería la 1.7.0_04

sudo ln -fs /usr/lib/jvm/jdk1.7.0_04/jre/lib/amd64/libnpjp2.so '/usr/lib/mozilla/plugins'
#En este último paso se crea un enlace para el caso de usar Firefox, supongo que será similar para el caso de usar Chromium
+
PD: no contesté antes por tener problemas de conexión.

+1
0
-1
Imagen de MarioQuartz
+1
0
-1

Lo he hecho y ahora da problemas con los certificados de la FNMT. He vuelto a buscar y es problema de JSS3.
Lo he instalado de forma manual y tampoco va. Creo que voy a tardar menos con un windows virtual.

+1
0
-1
Imagen de BrusBilis
+1
0
-1

Yo he instalado java en dos ordenadores asi y cero problemas.El solo me instalaba tambien el plugin en firefox.

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-jdk7-installer

Como has hecho ya varias instalaciones de java borralas antes de probar esto o una vez instaladas prueba con
sudo update-alternatives --config java
para asegurarte que usas la que te interese

+1
0
-1